Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] /dev/sdXX (boot, root und swap) verschwunden
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Wed Feb 24, 2010 3:15 am    Post subject: [solved] /dev/sdXX (boot, root und swap) verschwunden Reply with quote

Ich verstehe mein Problem gerade irgendwie nicht und versuche mal das ganze zu erklären. Ich habe neulich ein kernel-update gemacht. Zuvor natürlich updates über portage, aber was und wann genau weiss ich nicht mehr. Nun habe ich bemerkt das /dev/sdb3 nicht nach /boot gemountet ist. Also mount /boot/ eingegeben und folgende Fehlermeldung erhalten:
Code:
mount: Gerätedatei /dev/sdb1 existiert nicht

Einen ähnlichen Fehler erhalte ich bei ls -lha1 /dev/sd*:
Code:
ls: Zugriff auf /dev/sd* nicht möglich: Datei oder Verzeichnis nicht gefunden



Hier die /etc/fstab
Code:
# <fs>         <mountpoint>      <type>      <opts>                     <dump/pass>
/dev/sdb1      /boot            ext2      noatime                     1 2
/dev/sdb3      /               ext3      noatime                     0 1
/dev/sdb2      none            swap      sw                     0 0
/dev/cdrom      /mnt/dvdrom      auto      noauto,ro,user                  0 0
/dev/sda3      /mnt/backupdrive   ext3      noatime                     0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
shm                     /dev/shm                tmpfs           nodev,nosuid,noexec                                     0 0

# Automount Drives   ( ID Auflistung: ls -l /dev/disk/by-uuid )
UUID=109C-6523      /mnt/key-of-twilight   vfat      uid=1000,gid=100,atime,exec,sync,utf8,noauto,user   0 0
UUID=3433-3231      /mnt/media2k      vfat      uid=1000,gid=100,atime,exec,sync,utf8,noauto,user   0 0
/dev/mmcblk0p1          /mnt/SD-Karte           auto            uid=1000,gid=100,atime,exec,sync,utf8,noauto,user       0 0
/dev/sdc1               /mnt/usbstick           vfat            uid=1000,gid=100,atime,exec,sync,utf8,noauto,user   0 0


Und mein emerge --info
http://www.phpmygentoo.rainyday-productions.de/acer-aspire-9920g/emerge--info.txt


grub funktioniert übrigends, das System bootet auch! Doch wie bekomme ich /dev/sdXX wieder zurück? Was mache ich falsch?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)


Last edited by Gladdle on Sat Feb 27, 2010 12:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Wed Feb 24, 2010 8:26 am    Post subject: Reply with quote

Hi

Was sagt er denn beim booten? Kann es das selbe sein wie hier: https://forums.gentoo.org/viewtopic-t-811298-highlight-.html

Sebastian
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Thu Feb 25, 2010 6:10 am    Post subject: Reply with quote

Hoi! Nein, es ist nicht dasselbe Problem, /dev und /proc sind ja vorhanden, es fehlt nur /dev/sdXX. Dateisystem wurde mittels Boot CD schon überprüft und für OK befunden. Kann udev das eventuell deaktiviert haben?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Thu Feb 25, 2010 1:09 pm    Post subject: Reply with quote

Hi Gladdle,

schau doch mal ob's daran liegt was ich in folgendem thread geschrieben habe, und ggf. auch mal unterm von mir geposteten link in dem Zweiten posting von mir dort:

Nicht vom Titel verwirren lassen, guck was ich da schreibe...

https://forums.gentoo.org/viewtopic-t-813647-highlight-.html

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat Feb 27, 2010 12:31 pm    Post subject: Reply with quote

Ich habe in der Datei /usr/src/linux/.config die Zeile
Quote:
CONFIG_SYSFS_DEPRECATED_V2=y
in
Code:
# CONFIG_SYSFS_DEPRECATED_V2 is not set
geaendert, den kernel neu gebacken und mit dem neuen gebootet (Eingebunden per Gentoo Live CD), nun funktioniert es. vielen Dank!
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Sat Feb 27, 2010 1:12 pm    Post subject: Reply with quote

Gladdle wrote:
Ich habe in der Datei /usr/src/linux/.config die Zeile
Quote:
CONFIG_SYSFS_DEPRECATED_V2=y
in
Code:
# CONFIG_SYSFS_DEPRECATED_V2 is not set
geaendert, den kernel neu gebacken und mit dem neuen gebootet (Eingebunden per Gentoo Live CD), nun funktioniert es. vielen Dank!

BTW

Beachte das man idR möglichst nicht direkt die .config editieren sollte, denn viele Optionen haben weitere Abhängigkeiten die so nicht berücksichtigt würden.
Also besser "make menüconfig" oder Ähnliches nutzen :wink:

MfG
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat Feb 27, 2010 1:37 pm    Post subject: Reply with quote

Oder danach (wie ich es gemacht habe) ein make oldconfig hinterherwerfen und ein cat .config | grep xyz auf die Funktion(en) die man editiert hat. Aber danke für den Tipp.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum