Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved][emerge] Firefox soll von 3.6 wieder auf 3.5.6
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jan 29, 2010 6:56 am    Post subject: [solved][emerge] Firefox soll von 3.6 wieder auf 3.5.6 Reply with quote

Hi,

bei einem normalen Update soll mein Firefox wieder runtergesetzt werden:
Code:
[ebuild     UD] www-client/mozilla-firefox-3.5.6 [3.6] USE="alsa dbus java sqlite%* startup-notification -bindist -custom-optimization -gnome -iceweasel% -mozdevelop% (-libnotify%*) (-networkmanager%*)" LINGUAS="de en_GB -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -el -en -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mn% -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW" 46,065 kB           
[ebuild     U ] app-emulation/wine-1.1.35 [1.1.29] USE="X alsa cups gecko lcms ncurses opengl perl%* png samba ssl threads%* truetype%* xcomposite xinerama xml (-capi) -custom-cflags (-dbus) (-esd*) -fontconfig% (-gnutls) (-gphoto2) (-gsm) (-hal) -jack (-jpeg) (-ldap) (-mp3) (-nas) (-openal) -oss (-scanner) -test -win64" 23,608 kB                                                                                                                                                       
[nomerge      ] app-portage/genlop-0.30.8-r2  USE="bash-completion"                                                                                             
[nomerge      ]  dev-perl/libwww-perl-5.831  USE="ssl"                                                                                                           
[nomerge      ]   virtual/perl-IO-Compress-2.021                                                                                                                 
[ebuild   R   ]    perl-core/IO-Compress-2.021  USE="(-test%)" 203 kB                                                                                           
[nomerge      ] perl-core/IO-Compress-2.021  USE="(-test%)"                                                                                                     
[nomerge      ]  virtual/perl-Compress-Raw-Zlib-2.021                                                                                                           
[ebuild   R   ]   perl-core/Compress-Raw-Zlib-2.021  USE="(-test%)" 209 kB                                                                                       
[nomerge      ] perl-core/IO-Compress-2.021  USE="(-test%)"                                                                                                     
[nomerge      ]  virtual/perl-Compress-Raw-Bzip2-2.021                                                                                                           
[ebuild   R   ]   perl-core/Compress-Raw-Bzip2-2.021  USE="(-test%)" 141 kB                                                                                     
[nomerge      ] www-client/mozilla-firefox-3.5.6 [3.6] USE="alsa dbus java sqlite%* startup-notification -bindist -custom-optimization -gnome -iceweasel% -mozdevelop% (-libnotify%*) (-networkmanager%*)" LINGUAS="de en_GB -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -el -en -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mn% -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW"                     
[ebuild     UD]  net-libs/xulrunner-1.9.1.6 [1.9.2] USE="alsa dbus java python%* sqlite%* startup-notification -custom-optimization -debug -gnome (-libnotify%*) (-networkmanager%*)" 9 kB                                                                                                                                       
[ebuild   R   ]   sys-devel/binutils-2.19.1-r1  USE="nls -multislot -multitarget -test -vanilla (-gold%)" 15,876 kB                                             

Total: 7 packages (1 upgrade, 2 downgrades, 4 reinstalls), Size of downloads: 86,107 kB

!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:                                               

www-client/mozilla-firefox:0

Interessant ist der letzte Satz, denke ich.
Wie man sieht, hängt der FX auch von niemandem ab.

Code:
$emerge mozilla-firefox:0 -pv

These are the packages that would be merged, in reverse order:

Calculating dependencies ... done!
[ebuild   R   ] www-client/mozilla-firefox-3.6  USE="alsa dbus java libnotify networkmanager startup-notification -bindist -custom-optimization -gnome" LINGUAS="de en_GB -af -ar -as -be -bg -bn -bn_BD -bn_IN -ca -cs -cy -da -el -en -en_US -eo -es -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hr -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -ml -mr -nb -nb_NO -nl -nn -nn_NO -oc -or -pa -pa_IN -pl -pt -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -ta_LK -te -th -tr -uk -vi -zh_CN -zh_TW" 0 kB

Ich kann den neuen aber ganz ohne Probleme neuinstallieren.

Habt ihr eine Idee?

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Sun Feb 28, 2010 7:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Fri Jan 29, 2010 7:44 am    Post subject: Reply with quote

Hi

Ich vermute ma das macht er weil er den xulrunner auch downgraden will. Guck ma nach ob du beides demaskiert hast.

Sebastian
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jan 29, 2010 7:51 am    Post subject: Reply with quote

xulrunner an sich nicht.
Aber vlc benötigt die alte Version von xulrunner und dadurch muss dann auch Firefox auf die Vorversion.

Von Vlc gibt es aber leider keine neue Version.

Was tun?

Danke
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Fri Jan 29, 2010 8:20 am    Post subject: Reply with quote

Hi

An VLC kanns nicht liegen:

Code:
 emerge -a vlc

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-libs/libdvbpsi-0.1.6  USE="-doc"
[ebuild  N    ] media-fonts/dejavu-2.29  USE="X -fontforge"
[ebuild  N    ] sys-libs/libavc1394-0.5.3
[ebuild  N    ] media-libs/libdvdnav-0.1.10
[ebuild  N    ] media-libs/libdvdplay-1.0.1
[ebuild     UD] net-libs/xulrunner-1.9.1.7 [1.9.2] USE="python%* -sqlite%"
[ebuild  N    ] media-video/vlc-1.0.4  USE="X a52 aac alsa cdda cddb dbus dvd ffmpeg flac gcrypt hal id3tag ieee1394 libnotify mmx mp3 mpeg ncurses nsplugin ogg opengl png qt4 samba sse stream svg truetype vorbis x264 xml xv -aalib (-altivec) -atmo -avahi -bidi -cddax -cdio -dc1394 -debug -dirac -directfb -dts -dvb -fbcon -fluidsynth -fontconfig -ggi -gnome -gnutls -httpd -jack -kate -libass -libcaca -libproxy -libsysfs -libtiger -libv4l2 -lirc -live -lua -matroska -modplug -mtp -musepack -optimisememory -oss (-pda) -pulseaudio -pvr -remoteosd -rtsp -run-as-root -schroedinger -sdl -sdl-image -shine -shout -skins -speex (-svga) -taglib -theora -twolame -udev -upnp -v4l -v4l2 -vcdinfo -vcdx -vlm (-win32codecs) -wma-fixed -xcb -xinerama -xosd -zvbi"


Firefox 3.6 ist installiert und bleibt es auch.

Selbst wenn ch xulrunner wieder auf 1.9.1.6 downgrade bleibt Firefox 3.6 erhalten.

Bist du dir sicher das du alles demaskiert hast? Da stimmt irgendwas mit deinen dependencies nicht. Das sagt er ja auch unten. Zeig doch ma bitte deine /etc/portage/package.keywords.

Vorher mach aber bitte nochmal einen sync.

Was du auch nochma posten kannst, ist die Ausgabe von:

Code:
equery depends mozilla-firefox


und

Code:
equery depends xulrunner


Sebastian
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Jan 29, 2010 8:41 am    Post subject: Reply with quote

Ihr habt wahrscheinlich verschiedene portage-Versionen!
Mit USE="-nsplugin" emerge vlc braucht der auch keinen xulrunner mehr.
Wenn es denn am vlc liegen sollte...
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1604
Location: Germany -> Saxony -> Leipzig

PostPosted: Fri Jan 29, 2010 9:26 am    Post subject: Reply with quote

Lustig, wie hier orakelt wird :lol: Der Grund ist https://bugs.gentoo.org/show_bug.cgi?id=301819
Wer das Problem nicht hat, haut xulrunner und firefox einfach in packages.unmask.
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Fri Jan 29, 2010 9:53 am    Post subject: Reply with quote

misterjack wrote:
Lustig, wie hier orakelt wird :lol: Der Grund ist https://bugs.gentoo.org/show_bug.cgi?id=301819
Wer das Problem nicht hat, haut xulrunner und firefox einfach in packages.unmask.

Ich hab jetzt lange überlegt was du uns sagen willst :D
Und jetzt glaub ich weiß ich es :P
Der Bug behandelt einen recht komischen SEGFAULT. Die Lösungsansätze gehen weit auseinander (.mozilla-dirs löschen, USE="custom-optimization", sqlite, ...). Und bei wem das nicht hilft, der soll xulrunner und firefox in die package.mask stecken. Er sagt aber nicht, dass jetzt offiziell xulrunner gemasked ist ^^

Denn hier ist weder xulrunner noch firefox gemasked - es wurde ja installiert - und soll trotzdem downgegradet werden. Auch packages.gentoo.org sagt mir, dass xulrunner nur masked by keyword (also ~amd64) ist.
Darum muss die Ursache wo anders liegen.
Und dass bei Halloween (und auch bei mir mit paludis) nur xulrunner Downgegradet werden soll, bei Finswimmer aber (dank backtracking) auch der Firefox, kann nur Ursache einer anderen portage-Version sein. Ich tippe Finswimmer hat die neuere :P
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1604
Location: Germany -> Saxony -> Leipzig

PostPosted: Fri Jan 29, 2010 10:06 am    Post subject: Reply with quote

mmh, es war zwischenzeitlich hardmaskiert.
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Fri Jan 29, 2010 11:32 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=290318 der bug sollte hilfreicher sein.
dort gibts auch einen passenden patch zum einpflegen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3651
Location: Germany

PostPosted: Fri Jan 29, 2010 4:13 pm    Post subject: Reply with quote

Ich hab das ganze hier auch ein wenig mit verfolgt da ich firefox-3.6 auch von Anfang an genutzt habe.
Ein zwei tage später wurde xulrunner-1.9.2 und ff-3.6 hart maskiert weil es bei einigen Leuten wohl Probleme gab (ich konnte sie weder auf ~x86 noch auf ~amd64 nachvollziehen, woraufhin ich kein Downgrade vornahm sonder die Versionen demaskierte.
Nun gut, die harte Maskierung wurde wohl wieder zurückgenommen, aber der aktuelle vlc-1.0.4 kann noch nicht mit USE="nsplugin" gegen xulrunner-1.9.2 und ff-3.6 gebaut werden.
Ich hab hier nun erst mal vlc mit USE="-nsplugin" gesetzt, somit klappt es auch wieder mit ff-3.6
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Fri Jan 29, 2010 5:30 pm    Post subject: Reply with quote

Hi

Ich hab vor dem posten extra nochma gesynct. Ich hab Firefox und xulrunner in der packages.keywords stehen und sonst nix. USE Flag nsplugin ist gesetzt. Wenn ich vlc emerge klappt das Problemlos. System ist amd64.

Sebastian
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3651
Location: Germany

PostPosted: Fri Jan 29, 2010 10:08 pm    Post subject: Reply with quote

@Hollowman
Sorry, aber das kann so eigentlich nicht sein, ein Blick ins
/usr/portage/media-video/vlc/vlc-1.0.4.ebuild
sagt aktuell
Code:
RDEPEND="
....
nsplugin? ( >=net-libs/xulrunner-1.8 x11-libs/libXpm x11-libs/libXt     <net-libs/xulrunner-1.9.2 )
....

Und firefox-3.6 braucht nun mal >=xulrunner-1.9.2

Code:
$ equery depends xulrunner
 * These packages depend on xulrunner:
media-video/vlc-1.0.4 (nsplugin ? >=net-libs/xulrunner-1.8)
                      (nsplugin ? <net-libs/xulrunner-1.9.2)
www-client/mozilla-firefox-3.6-r1 (~net-libs/xulrunner-1.9.2[java=,wifi=,libnotify=])


/edit:
Quote:
Firefox 3.6 ist installiert und bleibt es auch.

Selbst wenn ch xulrunner wieder auf 1.9.1.6 downgrade bleibt Firefox 3.6 erhalten.
Sowas machst du doch bitte nicht wirklich?
Damit würdest du die Abhängigkeiten von mozilla-firefox-3.6 brechen...!
somit wäre auch klar warum du vlc mit Use "nsplugin" bauen kannst... :wink:
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sat Jan 30, 2010 3:00 pm    Post subject: Reply with quote

Es scheint sich nun dahingehend geklärt zu haben, dass VLC nun xulrunner-1.8.1.19 benötigt.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
lituxer
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2007
Posts: 90
Location: Sauerland

PostPosted: Sat Jan 30, 2010 5:04 pm    Post subject: Reply with quote

Ich habe das hier mal verfolgt und dabei tut sich mir eine Frage auf.

Was für einen Sinn hat das, wenn man VLC mit nsplugin kompiliert?
_________________
GentooFreunde
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1604
Location: Germany -> Saxony -> Leipzig

PostPosted: Sat Jan 30, 2010 8:06 pm    Post subject: Reply with quote

Code:
$ euse -i nsplugin
global use flags (searching: nsplugin)
************************************************************
[- c  ] nsplugin - Build plugin for browsers supporting the Netscape plugin architecture (that is almost any modern browser)


Man bekommt Browserplugins.
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3651
Location: Germany

PostPosted: Mon Feb 01, 2010 9:39 am    Post subject: Reply with quote

Finswimmer wrote:
Es scheint sich nun dahingehend geklärt zu haben, dass VLC nun xulrunner-1.8.1.19 benötigt.

Tobi
Nein, nicht unbedingt...
VLC benötigt xulrunner eigentlich gar nicht, es sei den man möchte auch das Netscape Plugin
dann würde
(Auszug aus dem vlc-1.0.4.ebuild)
Code:
RDEPEND="
....
nsplugin? ( >=net-libs/xulrunner-1.8 x11-libs/libXpm x11-libs/libXt     <net-libs/xulrunner-1.9.2 )
....
benötigt,
also eine xulrunner Version von
>=net-libs/xulrunner-1.8
bis
<net-libs/xulrunner-1.9.2

Josef
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3651
Location: Germany

PostPosted: Wed Feb 24, 2010 2:58 pm    Post subject: Reply with quote

Falls noch von Interesse...
es gibt inzwischen auch ein Patch

siehe zb:
https://bugs.gentoo.org/290318
oder auch
http://git.overlays.gentoo.org/gitweb/?p=dev/anarchy.git;a=tree;f=media-video/vlc;h=68e5589824bb3db92edbb494b203123d23b31365

Damit klappt es auch wieder mit xulrunner-1.9.2 und VLC mit nsplugin
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3651
Location: Germany

PostPosted: Sun Feb 28, 2010 7:18 pm    Post subject: Reply with quote

Ich werde dich solange nerven bis hier ein "[solved]" vorm Titel steht :wink:
Als Moderator sollte man das doch noch hinbekommen, oder?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Feb 28, 2010 7:32 pm    Post subject: Reply with quote

Josef.95 wrote:
Ich werde dich solange nerven bis hier ein "[solved]" vorm Titel steht :wink:
Als Moderator sollte man das doch noch hinbekommen, oder?


Da hast Du wohl recht.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum