Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ solved ] mysql-5.0.84-r1 undefined reference to...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message

Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Mar 08, 2010 10:17 am    Post subject: [ solved ] mysql-5.0.84-r1 undefined reference to... Reply with quote


ich bin mit meinem Latein an ende, eventuell findet jemand von euch eine Lösung.
Mein emerge bricht mit folgender Meldung ab. etc-update habe ich erledigt.


libtool: link: i686-pc-linux-gnu-g++ -DDBUG_OFF -march=athlon-xp -Os -DHAVE_ERRNO_AS_DEFINE=1 -fno-exceptions -fno-strict-aliasing -felide-constructors -fno-rtti -fno-implicit-templates -fno-strict-aliasing -fno-implicit-templates -fno-exceptions -fno-rtti -Wl,-O1 -rdynamic -o .libs/mysqld sql_lex.o sql_handler.o item.o item_sum.o item_buff.o item_func.o item_cmpfunc.o item_strfunc.o item_timefunc.o thr_malloc.o item_create.o item_subselect.o item_row.o item_geofunc.o field.o strfunc.o key.o sql_class.o sql_list.o net_serv.o protocol.o sql_state.o lock.o my_lock.o sql_string.o sql_manager.o sql_map.o mysqld.o password.o hash_filo.o hostname.o set_var.o sql_parse.o sql_yacc.o sql_base.o table.o sql_select.o sql_insert.o sql_prepare.o sql_error.o sql_locale.o sql_profile.o sql_update.o sql_delete.o uniques.o sql_do.o procedure.o item_uniq.o sql_test.o log.o log_event.o init.o derror.o sql_acl.o unireg.o des_key_file.o discover.o time.o opt_range.o opt_sum.o records.o filesort.o handler.o ha_heap.o ha_berkeley.o ha_innodb.o ha_ndbcluster.o ha_ndbcluster_cond.o sql_db.o sql_table.o sql_rename.o sql_crypt.o sql_load.o mf_iocache.o field_conv.o sql_show.o sql_udf.o sql_analyse.o sql_cache.o slave.o sql_repl.o sql_union.o sql_derived.o client.o sql_client.o mini_client_errors.o pack.o stacktrace.o repl_failsafe.o sql_olap.o sql_view.o gstream.o spatial.o sql_help.o sql_cursor.o tztime.o my_time.o my_user.o my_decimal.o sp_head.o sp_pcontext.o sp_rcontext.o sp.o sp_cache.o parse_file.o sql_trigger.o ha_example.o ha_archive.o ha_tina.o ha_blackhole.o ha_federated.o ha_myisam.o ha_myisammrg.o  ../innobase/.libs/ -lrt ../myisam/.libs/libmyisam.a -lpthread -lpthread -lpthread -lpthread -lrt ../myisammrg/.libs/libmyisammrg.a -lpthread -lpthread -lpthread -lpthread -lrt ../heap/.libs/ -lpthread -lpthread -lpthread -lpthread -lrt -lpthread -lpthread -lpthread -lpthread -lrt ../vio/.libs/ -lpthread -lpthread -lpthread -lpthread -lrt -lpthread -lpthread -lpthread -lpthread -lrt ../mysys/.libs/ -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lrt -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lpthread -lrt ../regex/.libs/libregex.a -lpthread -lpthread -lpthread -lpthread -lrt -lz -ldl -L/usr/lib -lssl -lcrypto -lpthread -lcrypt -lnsl -lm -lpthread -lrt -Wl,-rpath -Wl,/usr/lib/mysql/ib -Wl,-rpath -Wl,/usr/lib/mysql
/usr/lib/gcc/i686-pc-linux-gnu/4.3.4/ undefined reference to `_Unwind_GetIPInfo@GCC_4.2.0'

und folgendes habe ich bereits versucht.

revdep-rebuild --library -- -av


emerge -1v binutils gcc


gcc-config -f i686-pc-linux-gnu-4.3.4
env-update && source /etc/profile

Hat jemand noch eine Idee?


CFLAGS="-march=athlon-xp -Os"
FEATURES="sandbox candy fixpackages parallel-fetch"
USE="-* 3dnow 3dnowext apache2 attachment authfile bash-completion berkdb
     clamav cli cracklib crypt ctype custom-cflags dbus dedicated dropmsg gd
     gif glibc-omitfp hal hpn imap jpeg latin1 logrotate mailwrapper mmx
     mmxext mudflap mysql nls nptl nptlonly pam passthru pcre perlsuid png
     posix qmail qmail-spp received sasl session sha512 sockets spamassassin
     spl sse ssl symlink threads threadsafe tools udev urandom vpopmail xml
     xmlreader zlib"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"

gcc info

[I] sys-devel/gcc
     Available versions:
        (2.95)  2.95.3-r9 ~2.95.3-r10!s
        (3.1)   3.1.1-r2
        (3.2)   **3.2.2!s 3.2.3-r4
        (3.3)   ~3.3.6-r1!s
        (3.4)   3.4.6-r2!s
        (4.0)   ~*4.0.4!s
        (4.1)   4.1.2!s
        (4.2)   ~4.2.4-r1!s
        (4.3)   4.3.2-r3!s ~4.3.2-r4!s ~4.3.3-r2!s 4.3.4!s
        (4.4)   ~4.4.1!s ~4.4.2!s ~4.4.3!s
        {altivec bootstrap boundschecking build d doc fixed-point fortran gcj graphite gtk hardened ip28 ip32r10k java libffi mudflap multilib multislot n32 n64 nls nocxx nopie nossp nptl objc objc++ objc-gc openmp static test vanilla}
     Installed versions:  4.3.4(4.3)!s(22:05:36 03/04/10)(mudflap nls nptl -altivec -bootstrap -build -doc -fixed-point -fortran -gcj -gtk -hardened -libffi -multilib -multislot -n32 -n64 -nocxx -nopie -objc -objc++ -objc-gc -openmp -test -vanilla)
     Description:         The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking

[I] sys-devel/gcc-config
     Available versions:  1.3.16 1.4.0-r4 1.4.1 **1.5
     Installed versions:  1.4.1(09:55:14 06/12/09)
     Description:         Utility to change the gcc compiler being used

Last edited by 69719 on Tue Mar 09, 2010 9:40 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 20 Sep 2004
Posts: 865

PostPosted: Tue Mar 09, 2010 9:40 am    Post subject: Reply with quote

Ich konnte es durch löschen folgender 2 Dateien lösen:


Diese stammen wohl aus einer älteren gcc version, die nicht sauber aus dem System entfernt wurde.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum