Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] VMware Mouse grab/ungrab Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
coolone
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 278

PostPosted: Thu Mar 11, 2010 3:21 am    Post subject: [solved] VMware Mouse grab/ungrab Problem Reply with quote

I have been using vmware workstation 6.5 on gentoo almost 1 year.
today it suddenly doesn't work properly, mouse in VMware switches grab and ungrab itself, also sometimes it affects on my mouse & keyboard on X Environment
I reinstalled Vmware Tool, but still doesnt work .

I have tried "revdep-rebuild", but nothing wrong with library, and re-emerged vmware workstation and modules, but everything stays the same

I updated system yesterday and today, I cannot figure out what package affected on VMware, sys-fs/udev-149 ??

Could someone please help on this? thanks a lot in advance.

genlop --list --date 2 days ago

Code:
 Wed Mar 10 09:36:07 2010 >>> x11-libs/gtk+-2.18.7

_________________
No Rolex on my wrist Or platinum on my chest 'Cause I don't need that shit to impress


Last edited by coolone on Thu Mar 11, 2010 9:35 am; edited 3 times in total
Back to top
View user's profile Send private message
coolone
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 278

PostPosted: Thu Mar 11, 2010 9:32 am    Post subject: Reply with quote

here is the solution could help.
The reason is I have upgraded GTK library

need to edit /etc/vmware/bootstrap
export VMWARE_USE_SHIPPED_GTK="yes"
or
export VMWARE_USE_SHIPPED_GTK="force"
_________________
No Rolex on my wrist Or platinum on my chest 'Cause I don't need that shit to impress
Back to top
View user's profile Send private message
jfp
Apprentice
Apprentice


Joined: 08 Jul 2007
Posts: 279
Location: Virginia, USA

PostPosted: Sat Mar 13, 2010 5:28 pm    Post subject: Reply with quote

coolone,
Just want to thank you for your post. I was experiencing this problem as well, but was at a complete loss as to how to describe it.
I guess there a many ways to cause the setting of "VMWARE_USE_SHIPPED_GTK="yes"", for me, I added the setting to /etc/env.d/90vmware-workstation.
Code:
zippy linux # cat /etc/env.d/90vmware-workstation
PATH=/opt/vmware/workstation/bin
ROOTPATH=/opt/vmware/workstation/bin
MANPATH=/opt/vmware/workstation/man
VMWARE_USE_SHIPPED_GTK="yes"

_________________
jfp
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43072
Location: 56N 3W

PostPosted: Sat Mar 13, 2010 5:39 pm    Post subject: Reply with quote

The mouse grab/ungrab works properly in 640x480 resolution, or in to top left of most peoples vmware windows.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
coolone
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 278

PostPosted: Sun Mar 14, 2010 9:55 am    Post subject: Reply with quote

Also have a look here @ https://bugs.gentoo.org/show_bug.cgi?id=291241
seems the problem caused due to gtkmm is missing the "accessibility" use flag
_________________
No Rolex on my wrist Or platinum on my chest 'Cause I don't need that shit to impress
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 550
Location: USA

PostPosted: Mon Mar 15, 2010 4:11 pm    Post subject: Reply with quote

NeddySeagoon wrote:
The mouse grab/ungrab works properly in 640x480 resolution, or in to top left of most peoples vmware windows.

That's exactly the symptom I have with vmware-server-2.0.2.203138. I tried coolone's and jfp's solution but neither worked.

Any other suggestions?

Thanks.

[SOLVED] I fixed this by editing the VMware GTK wrapper script as described by jules98 here. This seems to work with VMware Server 2.0.2. See coolone's better solution, below.[/SOLVED]


Last edited by cfgauss on Tue Mar 16, 2010 3:51 am; edited 1 time in total
Back to top
View user's profile Send private message
coolone
Apprentice
Apprentice


Joined: 14 Nov 2006
Posts: 278

PostPosted: Mon Mar 15, 2010 9:13 pm    Post subject: Reply with quote

cfgauss wrote:
NeddySeagoon wrote:
The mouse grab/ungrab works properly in 640x480 resolution, or in to top left of most peoples vmware windows.

That's exactly the symptom I have with vmware-server-2.0.2.203138. I tried coolone's and jfp's solution but neither worked.

Any other suggestions?

Thanks.

[SOLVED] I fixed this by editing the VMware GTK wrapper script as described by jules98 here. This seems to work with VMware Server 2.0.2. [/SOLVED]


I am using vmware workstation, but for server I recommend you to have a look this one: http://ubuntuforums.org/showpost.php?p=8168791&postcount=6
Also another option, you could try to set "export VMWARE_USE_SHIPPED_GTK=yes" to your environment variable, hopefully this helps.
_________________
No Rolex on my wrist Or platinum on my chest 'Cause I don't need that shit to impress
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 550
Location: USA

PostPosted: Tue Mar 16, 2010 3:50 am    Post subject: Reply with quote

coolone wrote:
Also another option, you could try to set "export VMWARE_USE_SHIPPED_GTK=yes" to your environment variable, hopefully this helps.

I added "export VMWARE_USE_SHIPPED_GTK=force" to .bash_profile and the firefox plugin uses this to produce the correct behavior. This seems to be a clean solution as any updates to vmware won't affect this variable.

Thanks.
Back to top
View user's profile Send private message
kimmie
Guru
Guru


Joined: 08 Sep 2004
Posts: 531
Location: Australia

PostPosted: Wed Mar 24, 2010 9:33 am    Post subject: Reply with quote

I'm running vmware server 2.0.2. On my system I couldn't start the console with VMWARE_USE_SHIPPED_GTK=yes, I got the following error:
Code:
Couldn't recognize the image file format for file '/home/<myuser>/.mozilla/firefox/<paranoid>.default/extensions/VMwareVMRC@vmware.com/plugins/bin/../share/pixmaps/upgrade-hw.png'

The solution was to uninstall the VMware remote console extension from the firefox add-ons, then reinstall it from the web interface. Now I can start with VMWARE_USE_SHIPPED_GTK=yes, and the mouse problem goes away.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum