Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[qt3support]Peut-il être retiré ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Thu Mar 11, 2010 12:43 pm    Post subject: [qt3support]Peut-il être retiré ? Reply with quote

Bonjour,

Dans mon make.conf j'avais le use qt3support.
N'utilisant à ma connaissance que KDE4 je me suis dis que j'allais l'enlever.
J'ai donc supprimé qt3support de ma variable USE et j'ai relancer un emerge à blanc pour l'impact de cette modification.
Code:
ataualpa ben # nice emerge -DuvaN world --with-bdeps y

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No]


Est-ce suffisant comme test pour conclure que qt3support ne me sert à rien et que je peux l'enlever définitivement de ma variable USE ?


Last edited by BENJI on Wed Apr 21, 2010 5:45 am; edited 2 times in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7942
Location: ~Brussels - Belgique

PostPosted: Thu Mar 11, 2010 1:07 pm    Post subject: Reply with quote

Oui, tu as bien agi.

Si un paquet en avait besoin, il aurait hurlé.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
brubru
Tux's lil' helper
Tux's lil' helper


Joined: 14 May 2008
Posts: 109
Location: France

PostPosted: Sun Mar 14, 2010 6:16 pm    Post subject: Reply with quote

Heu, d'après gentoo-portage (mais je vois pareil faisant paludis -qD =kde-base/kdelibs-4.3.5::gentoo), kdelibs dépend clairement de qt-qt3support et requiert que qt-core soit compiler avec le use flags qt3support.

D'ailleurs, qt3support, n'apporte pas une compatibilité binaire pour les applications réalisées avec Qt3, c'est plus une bibliothèque facilitant le port des applications Qt3 vers Qt4. Et d'apprès les dépendances de kdelibs, KDE4 en fait parti.

Bruno
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Sun Mar 14, 2010 7:41 pm    Post subject: Reply with quote

Ce que donne ta commande c'est surtout qu'aucun paquet n'a a être recompilé, donc l'useflag ne sera pas viré !
Il est surement définit autre pars, par défaut dans le profil peut-être ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Mar 15, 2010 7:40 pm    Post subject: Reply with quote

justement en parlant de profile, je viens de mettre à jour mon arbre et à la fin j'ai ça :
Code:
Performing Global Updates: /usr/portage/profiles/updates/1Q-2010
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  #='/var/db update'  @='/var/db move'
  s='/var/db SLOT move'  %='binary move'  S='binary SLOT move'
  p='update /etc/portage/package.*'
.................................................................

D'habitude je passe à autre chose et là j'ai cherché à comprendre.
J'ai regardé le guide des profiles mais je vois pas si c'est un problème ou pas ce message
Code:

ataualpa ben # eselect profile list
Available profile symlink targets:
  [1]   default/linux/x86/10.0
  [2]   default/linux/x86/10.0/desktop *
  [3]   default/linux/x86/10.0/developer
  [4]   default/linux/x86/10.0/server
  [5]   hardened/linux/x86/10.0
  [6]   selinux/2007.0/x86
  [7]   selinux/2007.0/x86/hardened
  [8]   selinux/v2refpolicy/x86
  [9]   selinux/v2refpolicy/x86/desktop
  [10]  selinux/v2refpolicy/x86/developer
  [11]  selinux/v2refpolicy/x86/hardened
  [12]  selinux/v2refpolicy/x86/server

J'ai le dernier profile donc je suis up to date, non ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7942
Location: ~Brussels - Belgique

PostPosted: Mon Mar 15, 2010 8:14 pm    Post subject: Reply with quote

question hors-sujet ;-)

Pas de souci pour le message, cela arrive plusieurs fois par an ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Zoboulo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2007
Posts: 97

PostPosted: Tue Mar 16, 2010 8:00 am    Post subject: Re: [qt3support]Peut-il être retiré ?[resolu] Reply with quote

BENJI wrote:
Bonjour,

Dans mon make.conf j'avais le use qt3support.
N'utilisant à ma connaissance que KDE4 je me suis dis que j'allais l'enlever.
J'ai donc supprimé qt3support de ma variable USE et j'ai relancer un emerge à blanc pour l'impact de cette modification.
Code:
ataualpa ben # nice emerge -DuvaN world --with-bdeps y

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; would you like to auto-clean packages? [Yes/No]


Est-ce suffisant comme test pour conclure que qt3support ne me sert à rien et que je peux l'enlever définitivement de ma variable USE ?


Salut !

Si rien n'est recomplilé, c'est que tu n'as pas vraiment enlevé le use qt3support ! Vérifies que tu as bien "USE = ... -qt3support" dans le make.conf et que le package.use ne l'écrase pas.

Que te donne
Code:
emerge -pv qt-core
?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Apr 19, 2010 8:57 am    Post subject: Reply with quote

Code:
ataualpa ben # emerge -pv qt-core

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/qt-core-4.6.2-r1  USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 0 kB
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Mon Apr 19, 2010 9:33 am    Post subject: Reply with quote

On voit bien que qt3support est encore là.

T'as bien vérifié /etc/portage/package.use ?

Et pour le make.conf, il ne suffit peut-être pas d'enlever qt3support. Il se peut que ce flag soit activé par défaut. Il faut mettre explicitement -qt3support dans USE
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Apr 19, 2010 10:27 am    Post subject: Reply with quote

effectivement il n'y a rien dans mon make.conf je vais donc rajouter -qt3support et voir ce qu'il se passe.
Back to top
View user's profile Send private message
Zoboulo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Apr 2007
Posts: 97

PostPosted: Mon Apr 19, 2010 5:51 pm    Post subject: Reply with quote

Quote:

Code:
ataualpa ben # emerge -pv qt-core

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/qt-core-4.6.2-r1 USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 0 kB


Quote:

BENJI
Guru


:lol: 8O :lol:
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Mon Apr 19, 2010 5:55 pm    Post subject: Reply with quote

Zoboulo wrote:
Quote:

Code:
ataualpa ben # emerge -pv qt-core

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/qt-core-4.6.2-r1 USE="exceptions glib iconv qt3support ssl (-aqua) -debug -doc -optimized-qmake -pch" 0 kB


Quote:

BENJI
Guru


:lol: 8O :lol:


C pô bien de se moquer des autres :)
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Apr 20, 2010 9:45 am    Post subject: Reply with quote

Oui pas ma faute si celui qui a codé tout ça a lié la prise de galons aux nombres de messages ou à la date d'inscription.
En ce qui me concerne je suis un vieux du forum : Inscrit le: 10 Sep 2003 (c'est écrit en dessous de Guru !)... c'est un peu comme la légion d'honneur ça ne veut plus rien dire.

J'ai peu de temps a consacrer à cette distribution mais je m'accroche depuis toutes ces années ou j'ai complètement abandonné XP.
Je ne maîtrise pas tout faute de temps et j'en découvre tous les jours mais grâce à cette Gentoo j'ai toujours le même PC depuis 2003 et pas de pb de performance pour ce que j'en fais.

L'important pour moi c'est de rester au contact de Linux sinon dans 10 ans je serai comme mes grand-parents qui ne savent même pas comment on lit un DVD.
Merci à tous ceux qui sont sur ce forum et qui aident ceux qui comme moi pataugent ; sans cette générosité les jours du monde du logiciel libre aurait des soucis à se faire. :wink:
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Apr 21, 2010 5:50 am    Post subject: Reply with quote

Je viens d'ajouter -qt3support et ça coince (je savais bien qu'il y avait quelquechose de pas propre):
Code:

ataualpa ben # nice emerge -DuvN world --with-bdeps y

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] sys-devel/gnuconfig-20100122 [20090819] 563 kB
[ebuild     U ] dev-libs/nspr-4.8.4 [4.8] USE="-debug (-ipv6%*)" 1,169 kB
[ebuild     U ] dev-libs/nss-3.12.6-r1 [3.12.5] USE="-utils" 5,809 kB   
[ebuild   R   ] x11-libs/qt-core-4.6.2-r1  USE="exceptions glib iconv ssl (-aqua) -debug -doc -optimized-qmake -pch -qt3support*" 0 kB
[ebuild     U ] www-client/firefox-bin-3.6.3 [3.5.8] USE="startup-notification" LINGUAS="fr -af -ar -be -bg -bn -bn_IN -ca -cs -cy -da -de -el -en -en_GB -en_US -eo -es -es_AR -es_ES -et -eu -fa -fi -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hu -id -is -it -ja -ka -kk -kn -ko -ku -lt -lv -mk -mr -nb -nb_NO -nl -nn -nn_NO -oc -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -ta -te -th -uk -vi -zh -zh_CN -zh_TW" 10,084 kB                                                                                         
[ebuild   R   ] x11-libs/qt-gui-4.6.2  USE="accessibility cups dbus exceptions glib gtk mng tiff (-aqua) -debug -nas -nis -pch -qt3support* -raster -xinerama" 0 kB                   
[ebuild   R   ] x11-libs/qt-opengl-4.6.2  USE="exceptions (-aqua) -debug -pch -qt3support*" 0 kB                                                                                     
[ebuild     U ] app-emulation/wine-1.1.43 [1.1.42] USE="X alsa cups dbus gecko hal jpeg lcms ldap mp3 ncurses opengl oss perl png samba ssl threads truetype xml -capi -custom-cflags -esd -fontconfig -gnutls -gphoto2 -gsm -jack -nas -openal -pulseaudio -scanner -test -win64 -xcomposite -xinerama" 16,368 kB                                                         

Total: 8 packages (5 upgrades, 3 reinstalls), Size of downloads: 33,990 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

x11-libs/qt-core:4

  ('installed', '/', 'x11-libs/qt-core-4.6.2-r1', 'nomerge') pulled in by
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/kappfinder-4.3.5', 'nomerge')
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/knetattach-4.3.5', 'nomerge')
    >=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('installed', '/', 'kde-base/khelpcenter-4.3.5', 'nomerge')
    (and 108 more)                                                                                                   

  ('ebuild', '/', 'x11-libs/qt-core-4.6.2-r1', 'merge') pulled in by
    ~x11-libs/qt-core-4.6.2[-debug,-qt3support,-aqua] required by ('ebuild', '/', 'x11-libs/qt-opengl-4.6.2', 'merge')
    ~x11-libs/qt-core-4.6.2[glib,-debug,-aqua,-qt3support] required by ('ebuild', '/', 'x11-libs/qt-gui-4.6.2', 'merge')
    (and 13 more)                                                                                                       

x11-libs/qt-gui:4

  ('installed', '/', 'x11-libs/qt-gui-4.6.2', 'nomerge') pulled in by
    ~x11-libs/qt-gui-4.6.2[qt3support,accessibility,-debug,-aqua] required by ('installed', '/', 'x11-libs/qt-qt3support-4.6.2', 'nomerge')
    ~x11-libs/qt-gui-4.6.2[qt3support,-aqua] required by ('installed', '/', 'x11-libs/qt-core-4.6.2-r1', 'nomerge')
    (and 108 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.6.2', 'merge') pulled in by
    ~x11-libs/qt-gui-4.6.2[-debug,-qt3support,-aqua] required by ('ebuild', '/', 'x11-libs/qt-opengl-4.6.2', 'merge')
    (and 108 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum