Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] /dev/ttyUSB0 wird nicht erzeugt? (I-Blue 747+)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Thu Mar 11, 2010 3:49 pm    Post subject: [SOLVED] /dev/ttyUSB0 wird nicht erzeugt? (I-Blue 747+) Reply with quote

Hallo!

Habe mir jetzt ein gps logger vom typ I-blue 747+ gekauft und soeben erhalten. Laut google muss ich im Kernel den cp210x aktivieren. Dies habe ich getan (als modul).
Wenn ich das Modul einlade erhalten ich folgende Meldung unter dmesg:
Code:
cp210x: v0.09:Silicon Labs CP210x RS232 serial adaptor driver


Laut google sollte das Gerät nun unter /dev/ttyUSB0 ansprechbar sein. Leider ist dem nicht so. Ich besitze kein einziges /dev/ttyUSBx device. Irgendwas fehlt mir vermutlich noch?

Code:
# lsmod
Module                  Size  Used by
cp210x                 16516  0
usbserial              40208  1 cp210x
vboxnetadp              5280  0
vboxnetflt             12688  0
vboxdrv              1742540  2 vboxnetadp,vboxnetflt
nvidia               9617928  38
snd_usb_audio          98208  1
snd_usb_lib            18272  1 snd_usb_audio
snd_rawmidi            25088  1 snd_usb_lib
usbhid                 22032  0
8250_pnp               18208  0
8250                   24776  1 8250_pnp
serial_core            23200  1 8250
ehci_hcd               38480  0
ohci_hcd               25276  0
usbcore               166420  8 cp210x,usbserial,snd_usb_audio,snd_usb_lib,usbhid,ehci_hcd,ohci_hcd


Last edited by BlackEye on Thu Mar 11, 2010 8:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Thu Mar 11, 2010 8:18 pm    Post subject: Reply with quote

Hast du evtl. einen 747A+? Meiner läuft hier einwandfrei mit dem Modul cdc_acm:
Code:
Symbol: USB_ACM [=m]
Prompt: USB Modem (CDC ACM) support
  Defined at drivers/usb/class/Kconfig:7
  Depends on: USB_SUPPORT && USB
  Location:
    -> Device Drivers
      -> USB support (USB_SUPPORT [=y])

die angelegte Gerätedatei heißt
Code:
/dev/ttyACM0
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Thu Mar 11, 2010 8:20 pm    Post subject: Reply with quote

ah stimmt - 747a+
das muss ich dann nochmal testen mit dem Modul von Dir!
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Thu Mar 11, 2010 8:24 pm    Post subject: Reply with quote

okay, damit bekomme ich in der Tat /dev/ttyACM0 angelegt.
Aber mit was kann ich die Daten nun auslesen? bt747 verweigert sich hier scheinbar :(

edit: Hab's hinbekommen. Muss die Entwicklungsversion von bt747 benutzen. Die aktuell im Portage befindliche hat Probleme mit dem ACM0 Device.
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2329
Location: Konradsreuth (Germany)

PostPosted: Thu Mar 11, 2010 9:37 pm    Post subject: Reply with quote

Genau, die Portage-Version kann’s nicht. Zum Download der Daten verwende ich
Code:
gpsbabel -r -t -w -i mtk -f /dev/ttyACM0 -o gpx -F out.gpx

BT747 nur zum Parameter einstellen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum