Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev rules konvertieren [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Mon Mar 15, 2010 1:51 pm    Post subject: udev rules konvertieren [solved] Reply with quote

Hallo,
ich habe vor längerer Zeit mir mal ein paar passende Udev-Rules erstellt, um Devices unter /dev/SYMLINK laden zu können.
Mit dem neustem udev-149 werden aber hiervon Teile als deprecated markiert. Zum einen BUS und NAME
Wie konvertiere ich diese so, dass sie wieder funktionieren?
Code:
BUS=="scsi", ATTRS{model}=="Flexi-Drive EC2", NAME="%k", SYMLINK="crypt%n"
BUS=="scsi", ATTRS{model}=="PDU01-8G 87H2.0", NAME="%k", SYMLINK="stick%n"
BUS=="usb", ATTRS{serial}=="A00000600001", NAME="%k", SYMLINK="music%n"
BUS=="scsi", ATTRS{model}=="SP2514N", NAME="%k", SYMLINK="external%n"

Die Umwandlung von BUS zu SUBSYSTEM hat keinen Erfolg gebracht.
Kann ich NAME einfach entfernen?

Es sind alles Geräte die per USB angeschlossen werden.


Vielen Dank für eure Hilfe

ScytheMan


Last edited by ScytheMan on Thu Apr 01, 2010 1:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
mastacloak
Apprentice
Apprentice


Joined: 01 Aug 2004
Posts: 174
Location: Berlin / Germany

PostPosted: Mon Mar 15, 2010 8:15 pm    Post subject: Reply with quote

NAME kannst Du entfernen. Gab bei mir zumindest keine Probleme. Bei mir sind aber auch alle symlinks SYMLINK+="..." anstelle SYMLINK="...".
Ansonsten solltest Du BUS durch SUBSYSTEMS ersetzen können (das S am Ende nicht vergessen!).

Gruß
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Tue Mar 16, 2010 9:37 am    Post subject: Reply with quote

danke das hat funktioniert.

udev beschwert sich jetzt noch über /dev/mapper/control und nämlich dieses bereits existiert.

genaue meldung liefere ich nach :)
Back to top
View user's profile Send private message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Thu Apr 01, 2010 11:33 am    Post subject: Reply with quote

Mein Problem ist fast das gleiche mit dem neuen UDEV.

Meine alte rules-Datei:
Code:
BUS=="usb", SYSFS{product}=="USB Mass Storage Device", KERNEL=="ub?*", SYMLINK="usbstick1"
BUS=="usb", SYSFS{product}=="?USB PRODUCT?", KERNEL=="ub?*", SYMLINK="usbstick2"
BUS=="usb", SYSFS{product}=="DISK 2.0", KERNEL=="ub?*", SYMLINK="usbstick3"
BUS=="usb", SYSFS{product}=="SA21xx", KERNEL=="ub?*", SYMLINK="usbstick2"
BUS=="usb", SYSFS{product}=="USB2.0 Card Reader", KERNEL=="ub?*", SYMLINK="usb-cardreader"

Und hier die neue rules-Datei, welche aber keinen Symlink erstellt:
Code:
SUBSYSTEMS=="usb", ATTR{product}=="USB Mass Storage Device", KERNEL=="ub?*", SYMLINK+="usbstick1"
SUBSYSTEMS=="usb", ATTR{product}=="DISK 2.0", KERNEL=="ub?*", SYMLINK+="usbstick3"
SUBSYSTEMS=="usb", ATTR{product}=="?USB PRODUCT?", KERNEL=="ub?*", SYMLINK+="usbstick2"
SUBSYSTEMS=="usb", ATTR{product}=="SA21xx", KERNEL=="ub?*", SYMLINK+="usbstick2"
SUBSYSTEMS=="usb", ATTR{model}=="USB2.0 Card Reader", KERNEL=="ub?*", SYMLINK+="usb-cardreader"

Was ist falsch daran?
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Thu Apr 01, 2010 11:54 am    Post subject: Reply with quote

Versuche es mal mit ATTRS{product}
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Thu Apr 01, 2010 12:15 pm    Post subject: Reply with quote

ScytheMan wrote:
danke das hat funktioniert.

udev beschwert sich jetzt noch über /dev/mapper/control und nämlich dieses bereits existiert.

genaue meldung liefere ich nach :)


falls jemand das problem auch hatte, hilft ein update von lvm2
Back to top
View user's profile Send private message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Thu Apr 01, 2010 12:32 pm    Post subject: Reply with quote

Polynomial-C wrote:
Versuche es mal mit ATTRS{product}


Danke das wars.
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748
Back to top
View user's profile Send private message
kriz
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 231

PostPosted: Tue Jun 01, 2010 1:47 pm    Post subject: Reply with quote

mastacloak wrote:
NAME kannst Du entfernen. Gab bei mir zumindest keine Probleme. Bei mir sind aber auch alle symlinks SYMLINK+="..." anstelle SYMLINK="...".
Ansonsten solltest Du BUS durch SUBSYSTEMS ersetzen können (das S am Ende nicht vergessen!).

Gruß


Herr im Himmel..... ;)

dank dir
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum