Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eclipse-sdk auf deutsch?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Mon Mar 15, 2010 9:41 pm    Post subject: eclipse-sdk auf deutsch? Reply with quote

Irgendwie stehe ich wieder auf dem Schlauch. Ich habe eclipse-sdk mit emerge installiert und würde es gerne eindeutschen. Das Sprachpaket kann ich nicht finden und auch keinen Hinweis auf das richtige Vorgehen...

Bitte Wink mit Zaunpfahl...


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Tue Mar 16, 2010 1:07 am    Post subject: Reply with quote

Hallo,

bisher habe ich meistens die Erfahrung gemacht, dass die Übersetzung von Eclipse nicht gerade sehr hilfreich war. Unter Anderem deshalb hätte ich erstmal noch zwei Gegenfragen:

- Ist die Übersetzung echt notwenidig?
- Käme eventuell auch eine aktuellere Version direkt von eclipse.org in Frage? Dann könnten wir die Übersetzung nämlich ohnehin gleich auch dort suchen. Ich habe mal auf Anhieb auch nichts dazu im portage gefunden.

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
Gucky_der_Mausbiber
Guru
Guru


Joined: 10 Apr 2005
Posts: 359
Location: Wetzlar, Hessen

PostPosted: Tue Mar 16, 2010 1:20 pm    Post subject: Reply with quote

Lokalisierung läuft in Eclipse über das "Babel-Projekt" -> http://www.eclipse.org/babel/

Dort muss man einfach die der Eclipse-Version entsprechende Babel-Site suchen, diese in Eclipse zu den Update-Seiten hinzufügen und dann einfach das deutsche Sprachpaket per Eclipse-Update/Install-Funktion installieren.

Aber, ich habe das ganze noch nie(!) unter Linux zum laufen gebracht. Unter Windows kein Problem, Eclipse installiert, Babel installiert, Deutsch ausgewählt, installiert und alles super!
Unter Linux (egal welches Ubuntu,gentoo,32Bit,64Bit,etc...) geht das gar nicht. Okay, die entsprechende Seite eintragen bei Eclipse geht noch, aber schon wenn ich per Update-Funktion versuche die Lokalisierung zu installieren geht nichts mehr. Das erste Problem ist das er unter Linux gar nicht auf die entsprechende Babel-Seite zugreifen kann, gibt jedesmal Fehler.
Und nachdem es mir dann irgendwie doch mal gelungen ist gibt es danach nur noch Fehlermeldungen in allen Programmteilen, bzw. manche Eclipse-Teile scheinen dann vollkommen zu fehlen.

Fazit: In der Theorie müsste es auch unter Linux kein Problem sein Eclipse "einzudeutschen", in der Praxis funktioniert das leider nicht sehr gut. Und noch schlimmer, ich muss sagen das hier Windows einfach besser funktioniert.
_________________
intel quad core, nvidia 8800gts, intel hd audio+sb live, gnome 2.24
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Tue Mar 16, 2010 3:07 pm    Post subject: Reply with quote

Ob das auf die Sprache genau so zutrifft, kann ich nicht sicher sagen, aber es könnte daran liegen: Eclipse benutzt diese eigene Updateverwaltung, hat aber nach der Installation über portage nicht die nötigen Rechte, um die hinzugefügten Teile zu installieren. Ich benutze dehsalb eigentlich fast immer eine von Hand heruntergeladene Version, die dann irgendwo läuft, wo sie tun und lassen kann, was sie für nötig hält, vielleicht klappt damit auch das Hinzufügen der deutschen Sprache. Auch wenn die deutsche Sprache ja fast schon ein bisschen zu lyrisch umfangreich ist, um in die Nähe von Quellcode gebracht zu werden :-P

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Thu Mar 18, 2010 3:14 pm    Post subject: Reply with quote

Schinkencroissant wrote:
Ob das auf die Sprache genau so zutrifft, kann ich nicht sicher sagen, aber es könnte daran liegen: Eclipse benutzt diese eigene Updateverwaltung, hat aber nach der Installation über portage nicht die nötigen Rechte, um die hinzugefügten Teile zu installieren.


Das hat sich mit den letzten ebuilds geändert. Iirc werden jetzt die Plugins unter ~/.eclipse gespeichert.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Thu Mar 18, 2010 3:41 pm    Post subject: Reply with quote

Oh, dann werde ich das mal ausprobieren, wäre ja an sich praktisch, sonst fällt mir aber nichts ein zu den Sprachen.

Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
uhai
Veteran
Veteran


Joined: 23 Aug 2007
Posts: 1158
Location: Eppingen, Germany

PostPosted: Tue Mar 23, 2010 10:02 pm    Post subject: Reply with quote

ok, jetzt habe ich meine Funkmaus wieder....

Babel habe ich verstanden. Leider bricht er immer ab, weil irgendwelche Abhängigkeiten fehlen. Schade, unter Ubuntu läuft das...

Mal sehen...

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum