Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cp: reguläre Datei kann nicht angelegt werden
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Tue Mar 16, 2010 12:01 am    Post subject: cp: reguläre Datei kann nicht angelegt werden Reply with quote

Hey leute,
ich hab mal wieder ein Problem ;). Per google findet man nur sachen bezüglich Deffekter Platte, aber meine Arbeitet bisher top ist sie ist noch neu.

Ich bin gerade beim Installieren von meinem Gentoo und hab nun meinen Kernel Kompiliert.
Speziell am Punkt 7.c Installieren und Kompilieren.
Dort soll ich meinen Kompilierten Kernel mit folgenden Befehl Kopieren und es kommt folgende Fehlermeldung:
Und warum ausm i386 ordner? und nicht ausm x86?
Code:
cp arch/i386/boot/bzImage /boot/kernel-2.6.31-gentoo-r10
cp: Erzeugen der symbolischen Verknüpfung "/boot/kernel-2.6.31-gentoo-r10" nicht möglich: Eingabe-/Ausgabefehler


Ich finde dazu auch nix Hilfreiches :/

Grüße
Criseas
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue Mar 16, 2010 2:45 am    Post subject: Reply with quote

Hi criseas,

es ist egal ob du das bzImage von i386 oder x86 nimmst, da es sich bei i386 nur um einen Link auf die andere Datei handelt.

Code:
ls -l /usr/src/linux/arch/i386/boot/bzImage
lrwxrwxrwx 1 root root 22 Jan 31 18:23 /usr/src/linux/arch/i386/boot/bzImage -> ../../x86/boot/bzImage


Die Fehlermeldung von cp ist merkwürdig, aber ich würde auch auf ein Fehler mit dem Dateisystem/Festplatte tippen überprüfe doch mal folgendes:

1. Ist /boot gemountet?
2. Ist die Boot Partition beschreibbar? Einfach mit touch /boot/rw-test-irgendwas, dies legt eine leere Datei rw-test-irgendwas im boot Verzeichnis an.
3. Vielleicht ist der Kernel ja auch zu groß für deine Boot-Partition?

Kopiere auch mal den Kernel in deinem Kernelverzeichnis, vielleicht liegt der Fehler ja doch in der Quelle, aber dann hätte es bestimmt Fehler bei der Erzeugung des Kernels gegeben.

Grüße

Chris
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Tue Mar 16, 2010 9:38 am    Post subject: Reply with quote

Hi

Er versucht den Symbolischen Link zu kopieren. Das wird nicht gehen, da es verschiedene Partitionen sind. Warum er das macht, ist ne gute Frage.

Versuch mal cp -L oder

cp arch/x86/boot/bzImage /boot/kernel-2.6.31-gentoo-r10

Sebastian
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Tue Mar 16, 2010 11:27 am    Post subject: Re: cp: reguläre Datei kann nicht angelegt werden Reply with quote

criseas wrote:
Hey leute,
ich hab mal wieder ein Problem ;). Per google findet man nur sachen bezüglich Deffekter Platte, aber meine Arbeitet bisher top ist sie ist noch neu.

Ich bin gerade beim Installieren von meinem Gentoo und hab nun meinen Kernel Kompiliert.
Speziell am Punkt 7.c Installieren und Kompilieren.
Dort soll ich meinen Kompilierten Kernel mit folgenden Befehl Kopieren und es kommt folgende Fehlermeldung:
Und warum ausm i386 ordner? und nicht ausm x86?
Code:
cp arch/i386/boot/bzImage /boot/kernel-2.6.31-gentoo-r10
cp: Erzeugen der symbolischen Verknüpfung "/boot/kernel-2.6.31-gentoo-r10" nicht möglich: Eingabe-/Ausgabefehler


Ich finde dazu auch nix Hilfreiches :/

Grüße
Criseas

Du kannst auch ein
Code:

make install -C /usr/src/linux

eingeben, dann wird der Kernel automatisch nach /boot kopiert und die Symlinks (wenn vorhanden) in /boot aktualisiert.
Back to top
View user's profile Send private message
papahuhn
l33t
l33t


Joined: 06 Sep 2004
Posts: 623

PostPosted: Tue Mar 16, 2010 11:36 am    Post subject: Reply with quote

Hollowman wrote:
Er versucht den Symbolischen Link zu kopieren. Das wird nicht gehen, da es verschiedene Partitionen sind.


Symbolische Links über Partitionen hinweg sollten kein Problem sein, wenn das Dateisystem diese überhaupt unterstützt.
_________________
Death by snoo-snoo!
Back to top
View user's profile Send private message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Tue Mar 16, 2010 8:54 pm    Post subject: Reply with quote

Hmm nach einem Rechner neustart und neu Mounten hab ich den Zielordner mal angeschaut. Dort war eine Verlinkung auf . also sich selber. So hab ich dann den gelöscht und einfach nochmal versucht, es hat funktioniert, aber ob es daran gelegen hat weiß ich nicht.

Auf dem Ziellaufwerk hab ich ext2 laufen.

Vielen grüße
Criseas
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed Mar 17, 2010 1:12 am    Post subject: Reply with quote

criseas wrote:
Hmm nach einem Rechner neustart und neu Mounten hab ich den Zielordner mal angeschaut. Dort war eine Verlinkung auf . also sich selber. So hab ich dann den gelöscht und einfach nochmal versucht, es hat funktioniert, aber ob es daran gelegen hat weiß ich nicht.

Hat es nicht, der Link ist normal (damit man in der grub.conf nicht überall drauf achten muss ob /boot ne eigene Partition ist), allerdings hat das Löschen das Dateisystem verändert wodurch der Fehler vielleicht (momentan) nicht mehr auftritt, oder der Neustart hat ein fsck ausgelöst dass den Fehler repariert hat. Und Ein-/Ausgabefehler sind Fehler, bei denen der Kernel nicht wirklich weiss was eigentlich das Problem ist, sprich meistens kaputte Dateisysteme oder Hardware. Also besser nochmal ne Dateisystem- und/oder Festplattendiagnose laufen lassen bevor noch wichtige Daten verschwinden (und natürlich Backups nicht vergessen).
Back to top
View user's profile Send private message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Wed Mar 17, 2010 7:14 am    Post subject: Reply with quote

Genone wrote:

Und Ein-/Ausgabefehler sind Fehler, bei denen der Kernel nicht wirklich weiss was eigentlich das Problem ist, sprich meistens kaputte Dateisysteme oder Hardware. Also besser nochmal ne Dateisystem- und/oder Festplattendiagnose laufen lassen bevor noch wichtige Daten verschwinden (und natürlich Backups nicht vergessen).


Okey danke, werd ich gleich mal tun :).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum