Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Adobe Flash Versionswirrwar [SOLVED]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Tue Mar 16, 2010 6:05 pm    Post subject: Adobe Flash Versionswirrwar [SOLVED] Reply with quote

Servus,

vielleicht könnt ihr mir das erklären: habe auf meinem Desktop und dem Laptop jeweils www-plugins/adobe-flash-10.0.45.2 installiert.

Der Firefox zeigt unter Plugins: Shockwave Flash 9.0, der Laptop zeigt an 7.4.

Adobe Flash Test (http://www.adobe.com/software/flash/about/) zeigt bei beiden Rechnern an: 10.0.45.2.
Mit dem Laptop habe ich immer wieder Seiten, die mir sagen ich hätte kein Flash installiert.

Flashblocker habe ich auf beiden Rechnern installiert, das habe ich auf dem Laptop auch schon mal deinstalliert, es scheint nicht der Übeltäter zu sein.

Wie hängt das FF-Plugin mit dem installierten Flash zusammen? ISt das evtl der Grund für die Probleme auf dem Laptop?

Grüße
Mattes


Last edited by mattes on Wed Mar 17, 2010 6:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue Mar 16, 2010 6:30 pm    Post subject: Reply with quote

Welchen Browser hast du denn? Und vielleicht hast du vor einiger Zeit mal Flash von der Webseite runter geladen und in das Pluginverzeichnis kopiert? Bei Mozilla z.B. ~/.mozilla/plugins

Wenn du z.B. Mozilla-Firefox verwendest, was wird denn bei about:plugins aufgelistet? Sonst suche mal nach der Datei.. oder schau in deinem Userverzeichnis nach welche Datei dort liegt. Mit dem Ebuild sollte da ein Symlink sein..

Code:
./.mozilla/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Wed Mar 17, 2010 5:53 am    Post subject: Reply with quote

ChrisJumper wrote:
Mit dem Ebuild sollte da ein Symlink sein..

Code:
./.mozilla/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so


Das muss nicht sein, bei mir läuft Flash problemlos ohne diesen Symlink. Bei mir liegt libflashplayer.so in /opt/netscape/plugins und in /opt/netscape/plugins32/, symlinks darauf in/usr/lib64/nsbrowser/plugins und /usr/lib32/nsbrowser/plugins.

@mattes: Was sagt denn bei Dir locate libflashplayer.so? Sind da evtl. verschiedene Versionen in verschiedenen Verzeichnissen vorhanden?
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Wed Mar 17, 2010 2:52 pm    Post subject: Reply with quote

schachti wrote:
ChrisJumper wrote:
Mit dem Ebuild sollte da ein Symlink sein..

Code:
./.mozilla/plugins/libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so


Das muss nicht sein, bei mir läuft Flash problemlos ohne diesen Symlink. Bei mir liegt libflashplayer.so in /opt/netscape/plugins und in /opt/netscape/plugins32/, symlinks darauf in/usr/lib64/nsbrowser/plugins und /usr/lib32/nsbrowser/plugins.
[....]
Hm.. schon richtig, es ist nicht in jeden fall nötig, doch ich finde den Vorschlag von ChrisJumper gar nicht so schlecht, und schaden sollte er in keinen Fall,
bzw ist mir keiner bekannt wo es Komplikationen geben könnte.
Beachte das es Anwendungen gibt die das Flash Plugin in ~/.mozilla/plugins erwarten, zb Cooliris...
Quote:
If you've installed Adobe Flash® version 10 or greater in a non-standard location on your system, Cooliris may be unable to recognize it. To help Cooliris find it, run the following commands in a terminal:

1. Find the Adobe Flash® library
find /usr/lib /opt -name libflashplayer.so
2. Create Mozilla's plugins directory if it doesn't already exist
mkdir ~/.mozilla/plugins
3. Create a symlink to the Adobe Flash® library in
ln -s /path/to/libflashplayer.so ~/.mozilla/plugins/libflashplayer.so
Quelle: http://www.cooliris.com/help/desktop/?p=linux

Es sollte dann so ausschauen
Code:
$ ls -l ~/.mozilla/plugins
insgesamt 0
lrwxrwxrwx 1 phine users 39  2. Jul 2009  libflashplayer.so -> /opt/netscape/plugins/libflashplayer.so
Back to top
View user's profile Send private message
mattes
Apprentice
Apprentice


Joined: 23 Jul 2008
Posts: 255
Location: München, Bavaria, Germany

PostPosted: Wed Mar 17, 2010 6:37 pm    Post subject: Reply with quote

Hallo,

ja super, das wars. in ~/.mozilla/plugins lagen Dateien aus aus dem Jahre 2006 :-) Nachdem ich die gelöscht habe zeigt der Fiefox unter Plugins die richtige Version an. Ein Symlink scheint nicht notwendig, das Verzeichnis ist nun leer, aber alle Plugins werden geladen.

Da hätte ich auch selbst drauf kommen können..

mal sehen ob nun keine Meldungnen zu fehlendem Flash kommen...

Vielen Dank und Grüße
Mattes
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum