Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] eclipse hangs with libpyloader.so error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Thu Mar 18, 2010 11:35 pm    Post subject: [solved] eclipse hangs with libpyloader.so error Reply with quote

I ran an update to my system last night, and today eclipse IDE hangs when launching.

I launched eclipse from the console, and just after the main splash screen closes, I see this on the console:
Code:
Registering '@mozilla.org/module-loader/python;1' (libpyloader.so)
Registering '@mozilla.org/network/protocol/about;1?what=python' (pyabout.py)

and then an empty dialog box opens, titled "Eclipse" that hangs there until I kill eclipse.

Searching around I reinstalled these to no effect:
Code:
net-libs/xulrunner-1.8.1.19
net-libs/xulrunner-1.9.1.8


I need to use eclipse-3.4.2 (from tar ball eclipse-SDK-3.4.2-linux-gtk.tar.gz), as the eclipse:3.4 package in portage has the old problem with Help->software Update, that was fixed in 3.4.2, and my group has decided to synchronize on this specific version.

A fresh unpack and run of eclipse-SDK-3.4.2-linux-gtk.tar.gz did not solve it.
I can run gentoo packaged eclipse-3.4 and 3.5.

emerge --info
Code:
Portage 2.1.7.17 (default/linux/x86/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 i686)
=================================================================                                   
System uname: Linux-2.6.31-gentoo-r6-i686-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-1.12.13
Timestamp of tree: Tue, 16 Mar 2010 04:45:01 +0000                                                     
distcc 3.1 i686-pc-linux-gnu [disabled]                                                                 
ccache version 2.4 [disabled]                                                                           
app-shells/bash:     4.0_p35                                                                           
dev-java/java-config: 1.3.7-r1, 2.1.10                                                                 
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.4-r1                                                         
dev-python/pycrypto: 2.1.0_beta1                                                                       
dev-util/ccache:     2.4-r7                                                                             
dev-util/cmake:      2.6.4-r3                                                                           
sys-apps/baselayout: 1.12.13                                                                           
sys-apps/sandbox:    1.6-r2                                                                             
sys-devel/autoconf:  2.13, 2.63-r1                                                                     
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1                         
sys-devel/binutils:  2.18-r3                                                                           
sys-devel/gcc:       4.1.2, 4.3.4                                                                       
sys-devel/gcc-config: 1.4.1                                                                             
sys-devel/libtool:   2.2.6b                                                                             
virtual/os-headers:  2.6.33                                                                             
ACCEPT_KEYWORDS="x86"                                                                                   
ACCEPT_LICENSE="*"                                                                                     
CBUILD="i686-pc-linux-gnu"                                                                             
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"                                                 
CHOST="i686-pc-linux-gnu"                                                                               
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"                                   
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"                                                                               
DISTDIR="/usr/portage/distfiles"                                                                                                         
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"                                                                                                                                   
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                             
LANG="en_US.UTF-8"                                                                                                                       
LC_ALL="en_US.UTF-8"                                                                                                                     
LDFLAGS="-Wl,-O1"                                                                                                                       
LINGUAS="en"                                                                                                                             
MAKEOPTS="-j2"                                                                                                                           
PKGDIR="/usr/portage/packages"                                                                                                           
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl acpi addc alsa apache2 arts avahi avi bash-completion berkdb bitmap-fonts bluetooth bookmarks branding bzip2 cairo cdr cjkcodecs cleartype cli commons-codec consolekit corefonts cracklib crypt cups cxx dbus divx4linux dri dsk dts dv dvd dvdnav dvdr dvdread eds emboss encode evo evolution exif exscalibar faacc faad fam ffmpeg fftw firefox flac fontconfig foomaticdb fortran frame fuse gd gdbm gif gimpprint gnome gpm gs gstreamer gtk gtk2 hal iconv iconvcodec ipv6 jasper java jpeg kde kde-meta kdexdeltas kerberos krb5 ldap libdv libnotify libtheora mad madwifi midi mikmod mmx mng modules mp3 mp4 mpeg mppe-mppc mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pda pdf perl png ppds pppd python qt3support qt4 quicktime rar readline reflection samba sdl session spell spl sql sse ssl startup-notification subtitles svg svga sysfs tcpd tga theora thunar tiff truetype truetypelive type1 unicode usb v4l v4l2 vorbis webkit win32codecs x264 x86 xcomposite xext ximian-connector xml xml2 xmms xorg xulrunner xv xvid zlib zvbi" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias perl" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Hunting around someone suggested installing dev-python/psycopg.
But psycopg
This fails to install on my system:
emerge zpsycopgda
Code:
>> Emerging (2 of 3) dev-python/psycopg-1.1.21
 * psycopg-1.1.21.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                          [ ok ]
 * checking ebuild checksums ;-) ...                                                                                              [ ok ]
 * checking auxfile checksums ;-) ...                                                                                             [ ok ]
 * checking miscfile checksums ;-) ...                                                                                            [ ok ]
 * CPV:  dev-python/psycopg-1.1.21                                                                                                     
 * REPO: gentoo                                                                                                                         
 * USE:  elibc_glibc kernel_linux userland_GNU x86                                                                                     
>>> Unpacking source...                                                                                                                 
>>> Unpacking psycopg-1.1.21.tar.gz to /var/tmp/portage/dev-python/psycopg-1.1.21/work                                                 
>>> Source unpacked in /var/tmp/portage/dev-python/psycopg-1.1.21/work                                                                 
>>> Preparing source in /var/tmp/portage/dev-python/psycopg-1.1.21/work/psycopg-1.1.21 ...                                             
>>> Source prepared.                                                                                                                   
>>> Configuring source in /var/tmp/portage/dev-python/psycopg-1.1.21/work/psycopg-1.1.21 ...                                           
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-mxdatetime-includes=/usr/include/python2.6/mx --with-postgres-includes=/usr/include/postgresql/server                                                                                                               
checking for python... /usr/bin/python                                                                                                   
checking python version... 2.6                                                                                                           
checking python installation prefix... /usr                                                                                             
checking python installation exec_prefix... /usr                                                                                         
checking definitions in Python library makefile... done                                                                                 
checking location of python library... $(prefix)/lib/python2.6/site-packages                                                             
checking location of python shared modules... $(exec_prefix)/lib/python2.6/site-packages                                                 
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc -pthread                                                                     
checking for C compiler default output file name... a.out                                                                               
checking whether the C compiler works... yes                                                                                             
checking whether we are cross compiling... no                                                                                           
checking for suffix of executables...                                                                                                   
checking for suffix of object files... o                                                                                                 
checking whether we are using the GNU C compiler... yes                                                                                 
checking whether i686-pc-linux-gnu-gcc -pthread accepts -g... yes                                                                       
checking for i686-pc-linux-gnu-gcc -pthread option to accept ANSI C... none needed                                                       
checking how to run the C preprocessor... i686-pc-linux-gnu-gcc -pthread -E                                                             
checking whether make sets $(MAKE)... yes                                                                                               
checking for inline... inline                                                                                                           
checking PostgreSQL version... configure: error: missing PostgreSQL headers                                                             

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-python/psycopg-1.1.21/work/psycopg-1.1.21/config.log
 * ERROR: dev-python/psycopg-1.1.21 failed:                                 
 *   econf failed                                                           
 *                                                                           
 * Call stack:                                                               
 *     ebuild.sh, line   54:  Called src_configure                           
 *   environment, line 2589:  Called econf '--with-mxdatetime-includes=/usr/include/python2.6/mx' '--with-postgres-includes=/usr/include/postgresql/server'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-python/psycopg-1.1.21',
 * the complete build log and the output of 'emerge -pqv =dev-python/psycopg-1.1.21'.
 * The complete build log is located at '/var/log/portage/dev-python:psycopg-1.1.21:20100319-005931.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/psycopg-1.1.21/temp/environment'.
 * S: '/var/tmp/portage/dev-python/psycopg-1.1.21/work/psycopg-1.1.21'


Last edited by johnny99 on Fri Apr 09, 2010 7:03 pm; edited 2 times in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7078
Location: Saint Amant, Acadiana

PostPosted: Fri Mar 19, 2010 9:59 am    Post subject: Reply with quote

Quote:
dev-lang/python: 2.4.6, 2.5.4-r3, 2.6.4-r1

That's a few too many to look good.
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Fri Mar 19, 2010 3:51 pm    Post subject: Reply with quote

I don't understand what you mean. I have one version in each slot. Please explain.
eix dev-lang/python
Code:
[U] dev-lang/python
     Available versions:
        (2.4)   2.4.6
        (2.5)   2.5.4-r4
        (2.6)   2.6.4 2.6.4-r1
        (3.1)   ~3.1.1-r1
        {berkdb bootstrap build cxx doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl threads tk wide-unicode wininst xml}
     Installed versions:  2.4.6(2.4)(11:00:41 PM 12/20/2009)(berkdb cxx doc examples gdbm ipv6 ncurses readline ssl threads tk wide-unicode xml -bootstrap -build -elibc_uclibc -wininst) 2.5.4-r3(2.5)(04:13:34 PM 10/06/2009)(berkdb doc examples gdbm ipv6 ncurses readline ssl threads tk xml -build -elibc_uclibc -sqlite -ucs2 -wininst) 2.6.4-r1(2.6)(07:32:59 AM 03/17/2010)(berkdb doc examples gdbm ipv6 ncurses readline ssl threads tk wide-unicode xml -build -elibc_uclibc -sqlite -wininst)
     Homepage:            http://www.python.org/
     Description:         Python is an interpreted, interactive, object-oriented programming language.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7078
Location: Saint Amant, Acadiana

PostPosted: Fri Mar 19, 2010 3:54 pm    Post subject: Reply with quote

Just use eselect to set python-2.6 and run python-updater. Afterward remove old python installs.
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Fri Mar 19, 2010 7:44 pm    Post subject: Reply with quote

Removing the other 2 python installs, didn't help.

I thought package slots have the purpose of making it safe to install multiple versions of a package.
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Fri Mar 19, 2010 8:14 pm    Post subject: Reply with quote

Trying to just reinatall python is giving me hell

The build errors with final words like
Code:

...
>>> Compiling source in /var/tmp/portage/dev-python/psycopg-2.0.13/work/psycopg2-2.0.13
 * Building of dev-python/psycopg-2.0.13 with CPython 2.6...             
python2.6 setup.py build -b build-2.6
running build
running build_py   
creating build-2.6
creating build-2.6/lib.linux-i686-2.6
creating build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/tz.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/errorcodes.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/psycopg1.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/extensions.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/extras.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/__init__.py -> build-2.6/lib.linux-i686-2.6/psycopg2
copying lib/pool.py -> build-2.6/lib.linux-i686-2.6/psycopg2       
warning: build_py: byte-compiling is disabled, skipping.
running build_ext                           
error: No such file or directory
 * ERROR: de-python/psycopg-2.0.13 failed:
 *   Building failed with CPython 2.6 in distutils_building() function
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 4293:  Called distutils_src_compile
 *   environment, line 1118:  Called python_execute_function 'distutils_building'
 *   environment, line 3226:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *       
 * If you need support, post the output of 'emerge --info =dev-python/psycopg-2.0.13',
 * the complete build log and the output of 'emerge -pqv =dev-python/psycopg-2.0.13'.
 * The complete build log is located at '/var/log/portage/dev-python:psycopg-2.0.13:20100319-200622.log'. 
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/psycopg-2.0.13/temp/environment'.
 * S: '/var/tmp/portage/dev-python/psycopg-2.0.13/work/psycopg2-2.0.13'

>>> Failed to emerge dev-python/psycopg-2.0.13, Log file:
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Sat Mar 20, 2010 12:49 am    Post subject: Reply with quote

More Background: I recall during the package update (that lead to this problem), the emerge process dropped to a python shell, but I didn't know what to do, so I exited and resumed the update.

For most of today, I tried to downgrade python by a minor version, re-run python-updater, and re-run revdep-rebuild.
emerge =dev-lang/python-2.6.4
Finsihed without error

python-updater
Code:
 * Starting Python Updater from 2.4 to 2.6 :
  *   Adding to list: x11-libs/vte:0
 *     check: manual [Added to list manually, see CHECKS in manpage for more information.]
 *   Adding to list: app-office/dia:0
 *     check: manual [Added to list manually, see CHECKS in manpage for more information.]
 *   Adding to list: dev-libs/boost:0
 *     check: manual [Added to list manually, see CHECKS in manpage for more information.]
 *   Adding to list: dev-libs/boost:1.41
 *     check: manual [Added to list manually, see CHECKS in manpage for more information.]
  * emerge -vD1 x11-libs/vte:0 app-office/dia:0 dev-libs/boost:0 dev-libs/boost:1.41

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
...
[ebuild   R   ] dev-libs/boost-1.35.0-r5  USE="eselect python -doc -expat -icu -mpi -test -tools" 0 kB
[ebuild   R   ] dev-libs/boost-1.41.0-r3  USE="eselect python -debug -doc -expat -icu -mpi -test -tools" 0 kB
[ebuild   R   ] x11-libs/vte-0.22.5  USE="python -debug -doc -glade" 0 kB
[ebuild   R   ] app-office/dia-0.97.1  USE="cairo gnome png python zlib -debug -doc" 0 kB


revdep-rebuild -- -ta
nothing to rebuilt

And the error still persists launching eclipse

Does anyone have info on what the cause or meaning of this?/?
Code:
Registering '@mozilla.org/module-loader/python;1' (libpyloader.so)
Registering '@mozilla.org/network/protocol/about;1?what=python' (pyabout.py)


I ran this though strace, but can't make heads or tails of it.
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Wed Mar 24, 2010 4:43 pm    Post subject: Reply with quote

I am trying to get a version bump to the dev-util/eclipse-sdk 3.4 slot, so that maybe I can get some help.
Bug reference https://bugs.gentoo.org/show_bug.cgi?id=229609
Back to top
View user's profile Send private message
johnny99
Apprentice
Apprentice


Joined: 24 Oct 2005
Posts: 248
Location: Berkeley, California

PostPosted: Fri Apr 09, 2010 7:02 pm    Post subject: Reply with quote

While I wasn't able to solve this problem, I have moved on to using eclipse-3.5.
So the solution is to upgrade to 3.5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum