Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grub Konfigurationsproblem ;)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Sat Mar 20, 2010 3:28 pm    Post subject: Grub Konfigurationsproblem ;) Reply with quote

Hey Leuts, ich weiß nicht irgendwie tritt bei mir Ziemlich häufig ein Problem auf :D

Hier wollte ich mein Grub Konfigurieren, aber sobald ich Neustarte seh ich auf den ersten Bildschirm wo man den Kernel auswählt garnichts. Nur ein eingabe Prompt der auf nix reagiert, nach dem Eingabe Tasten drücken will er dann Booten und er wirft einen fehler aus. Das er das Splash Logo nicht nicht finden kann. Ebenso kann er meine Rescue Definition nicht finden.

Ich vermute es liegt an meiner grub.conf bin mir aber nicht sicher, grub-install hab ich mit folgenden optionen ausgeführt:
Code:
grub-install --no-floppy /dev/sdc1

sdc1 ist der USB Stick auf dem /boot/ liegt. Ich Kopiere euch hier alle Daten rein von welchen ich denke das diese Relevant sind :).

Code:

# grub.conf
##############
default 0
timeout 3
splashimage=(hd2,0)/grub/splash.xpm.gz
# Standart boot
title Gentoo Linux 2.6.31-r10
# Partition in der das Betriebssystem sein müsste.
root (hd1,0)
kernel (hd2,0)/kernel-2.6.31-gentoo-r10 root=/dev/sdb1
#video=uvesafb:mtrr:3,ywrap,1024x600-32@60

#initrd /boot/initramfs-genkernel-x86-2.6.24-gentoo-r5
# Rescue
title Gentoo Linux 2.6.31-r10 (Rescue)
# Partition in der das Betriebssystem sein müsste.
root (hd1,0)
kernel (hd2,0)/kernel-2.6.31-gentoo-r10 root=/dev/sdb1 init=/bin/bb
# vim:ft=conf:
############
############
# devices.map
############
(fd0)   /dev/fd0
(hd0)   /dev/sda
(hd1)   /dev/sdb
(hd2)   /dev/sdc
############
############
# einmal "df -h" mit den gemounteten Partitionen
############
/dev/sdb1             7,1G 1009M  5,8G  15% /mnt/gentoo
/dev/sda1              76G  265M   72G   1% /mnt/gentoo/home
/dev/sdc1             237M  7,3M  217M   4% /mnt/gentoo/boot
/dev/sda2             9,4G  783M  8,2G   9% /mnt/gentoo/usr/src
/dev/sda3             9,4G  750M  8,2G   9% /mnt/gentoo/usr/portage
############
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Sat Mar 20, 2010 5:20 pm    Post subject: Reply with quote

a) exakte Fehlermeldungen wären hilfreich
b) "root (hdX,Y)" in grub.conf bezeichnet die Partition, wo die Dateien für grub liegen (normalerweise /boot), nicht die Root-Partition für den Kernel (die wird über den Kernel-Parameter root=/dev/xy übergeben)
c) nimm mal den USB Stick aus der ganzen Sache raus, hab so ein Gefühl das grub damit nicht ohne weiteres klarkommt.
Back to top
View user's profile Send private message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Sat Mar 20, 2010 11:38 pm    Post subject: Reply with quote

So hab die beiden punkte angepasst
root (hd2,0)
Folgend die neue conf
Code:
default 0
timeout 3
splashimage=(hd2,0)/grub/splash.xpm.gz
title Gentoo Linux 2.6.31-r10
root (hd2,0)
kernel (hd2,0)/kernel-2.6.31-gentoo-r10 root=/dev/sdb1
#video=uvesafb:mtrr:3,ywrap,1024x600-32@60
initrd (hd2,0)/kernel-2.6.31-gentoo-r10
title Gentoo Linux 2.6.31-r10 (Rescue)
root (hd2,0)
kernel (hd2,0)/boot/kernel-2.6.31-gentoo-r10 root=/dev/sdb1 init=/bin/bb


Die Fehlermeldung schreib ich euch nun mal 1 zu 1 auf:
Code:
    Booting 'Gentoo Linux 2.6.31-r10'

root (hd2,0)
Filesystem type is ext2fs, partition type 0x83
kernel (hd2,0)/kernel-2.6.31-gentoo-r10 root=/dev/sdb1

Error 15: File not found

Press any key to continue...


Wenn ich Rescue verwende ist wie aus der Config ersichtlich noch /boot mit vor die Pfade geschrieben, dies ändert nichts an der Fehlermeldung ausser das /boot mit davor steht.

Warum sollte Grub damit Probleme haben? Wenn ich die geführte Installation von ubuntu oder debian nutze, ist das Auslagern auf einen Stick samt grub eigtl auch kein Problem.

Aber wenn du meinst das es etwas bringt, könnt ich es trotzdem probieren :)?

Grüße
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Sat Mar 20, 2010 11:45 pm    Post subject: Reply with quote

Ist nur so ein Gefühl. Natürlich könnte auch einfach die Nummerierung beim Booten anders sein als im laufenden System., das Problem hatte ich glaub ich in der Vergangenheit mal.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun Mar 21, 2010 12:00 am    Post subject: Reply with quote

Nur ein Schnellschuss zwischendurch...

mir ist aufgefallen das dein Kernel Image und initrd gleich benannt sind, das kann idR nicht gutgehen...
Code:
kernel (hd2,0)/kernel-2.6.31-gentoo-r10 root=/dev/sdb1
initrd (hd2,0)/kernel-2.6.31-gentoo-r10


Ansonsten versuche doch auch mal mit der TAB-Komplettierung von GRUB das zu startende Kernel Image zu finden.

Viel Erfolg!
Back to top
View user's profile Send private message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Sun Mar 21, 2010 10:17 am    Post subject: Reply with quote

Genone wrote:
Ist nur so ein Gefühl. Natürlich könnte auch einfach die Nummerierung beim Booten anders sein als im laufenden System., das Problem hatte ich glaub ich in der Vergangenheit mal.


Kann gut sein, wurde so im Handbuch auch geschrieben das sich das ändern kann wenn man die Bootreihenfolge ändert. Kann ich das irgendwie feststellen?
Back to top
View user's profile Send private message
criseas
n00b
n00b


Joined: 12 Mar 2010
Posts: 41

PostPosted: Sun Mar 21, 2010 3:29 pm    Post subject: Reply with quote

Hey Leuts,

kann man als Gelöst betrachten :).

Ich hatte einen hilfreichen Tipp aus #gentoo.de bekommen!
Bei der Auswahl in Grub per c in die Grub Konsole und dort mit "find /boot/kernel-2.6.31-gentoo-r10" herausgefunden das es nicht (hd2,0) sondern (hd0,0) ist. :)

Danke für eure Unterstützung
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum