Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
alsa Lautstärke in KDE nach reboot stets auf Maximum[solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Mar 23, 2010 9:15 pm    Post subject: alsa Lautstärke in KDE nach reboot stets auf Maximum[solved] Reply with quote

Abend miteinander.

Nach einem Neustart auf meinem Laptop und dem einloggen unter KDE 4.4.1, brüllt mich das Teil stets mit Max. Lautstärke an. Reduziere ich mit kmix dann die Lautstärke, logge mich aus u. wieder ein, bleibt sie erhalten. Nach einem reboot ist sie jedoch wieder auf max. gestellt. Ansonsten verhält sich der Sound aber korrekt.

Auch mit einem frisch erzeugten Test-account hab ich das gleiche Verhalten.

Am beginn des KDE einloggens erscheint das Lautsprechersymbol erstmal reduziert (z.B. Zwei Schallwellen), dann springt er rauf auf auf 3=max. und dann brüllt es wieder.

So als ob es erst durch KDE auf max gestellt würde, Wo kann ich das beeinflussen / konfigurieren. Unter Kmix Lauststärke beim anmelden wiederherstellen hat bei mir keinen Einfluss.

Den Alsa Guide bin ich auch schon mehrfach durchgegangen ohne dass mir Fehler auffielen, und mit den Settings der
alsasound hab ich auch schon diverse Varianten durchgespielt

Code:

cat /etc/conf.d/alsasound
# ENABLE_OSS_EMUL:
# Do you want to enable in-kernel oss emulation?
# no - Do not load oss emul drivers
# yes - Load oss emul drivers if they're found

ENABLE_OSS_EMUL="yes"

# RESTORE_ON_START:
# Do you want to restore your mixer settings?  If not, your cards will be
# muted.
# no - Do not restore state
# yes - Restore state

RESTORE_ON_START="yes"

# SAVE_ON_STOP:
# Do you want to save changes made to your mixer volumes when alsasound
# stops?
# no - Do not save state
# yes - Save state

SAVE_ON_STOP="yes"

# LOAD_ON_START:
# Do you want to load sound modules when alsasound starts?
# Note: The Gentoo ALSA developers encourage you to build your sound
#       drivers into the kernel unless the device is hotpluggable or
#       you need to supply specific options (such as model= to HD-Audio).
# no - Do not load modules
# yes - Load modules
#LOAD_ON_START="yes"


Code:

rc-update show
              keymaps |                                   boot       
             net.eth0 |                 default                       
            syslog-ng |                 default                       
             bootmisc |                                   boot       
                 ntpd |                 default                       
            savecache |        shutdown                               
               sysctl |                                   boot       
           localmount |                                   boot       
            killprocs |        shutdown                               
                  gpm |                 default                       
                 hald |                 default                       
                 sshd |                 default                       
          consolefont |                                   boot       
                 fsck |                                   boot       
                devfs |                                        sysinit
                 mtab |                                   boot       
             hostname |                                   boot       
              urandom |                                   boot       
           consolekit |                 default                       
                local |                 default nonetwork             
             netmount |                 default                       
               net.lo |                                   boot       
                 udev |                                        sysinit
              modules |                                   boot       
       udev-postmount |                 default                       
                 root |                                   boot       
                dmesg |                                        sysinit
                  nfs |                 default                       
             mount-ro |        shutdown                               
              hwclock |                                   boot       
               procfs |                                   boot       
                  xdm |                 default                       
                 swap |                                   boot       
            alsasound |                                   boot       
         termencoding |                                   boot


Was hab ich übersehen, woran könnt's noch liegen?

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Wed Mar 31, 2010 3:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Mar 23, 2010 9:28 pm    Post subject: Reply with quote

Vielleicht hilft es, mit alsamixer die Lautstärke richtig einzustellen und dann mit alsactl store zu speichern.
Oder im KMix gibt es "Restore volumes on login".

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Tue Mar 23, 2010 10:28 pm    Post subject: Reply with quote

Hi,

öffne mal den Hauptmixer (also nicht den einzelnen Regler, der beim Anklicken des Lautsprechersymbols im Systray erscheint, sondern den "großen" Mixer), gehe dort auf Einstellungen -> KMix einrichten und nimm dann bei der Option "Lautstärken beim Anmelden wiederherstellen" den Haken raus.
So konnte ich KMix abgewöhnen von selbst an der Lautstärke rumzupfuschen.

[EDIT]
Wer lesen kann ist klar im Vorteil... hast du ja schon versucht :roll:

Okay, noch ne Möglichkeit... logge dich aus KDE aus und lösche dann die Datei ${HOME}/.kde4/share/config/kmixrc. Falls das hilft, dann trotzdem nachträglich den Haken bei "Lautstärken beim Anmelden wiederherstellen" rausnehmen, denn das ist meistens für das von dir beschriebene Verhalten verantwortlich und du hast ja schon bei Alsa die Möglichkeit die Mixereinstellungen speichern zu lassen.
[/EDIT]
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)


Last edited by Polynomial-C on Tue Mar 23, 2010 10:33 pm; edited 1 time in total
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Mar 23, 2010 10:30 pm    Post subject: Reply with quote

Danke Tobi,

das hatte ich noch vergessen zu erwähnen dass ich das schon versucht hatte, jedoch ohne Erfolg.
Das mit den kmix settings hatte ich mit dem deutschen Wortlaut bereits erwähnt, präziser:

Das Häkchen unter kmix /Einstellungen/Kmix Einrichten/Lautstärken beim Anmelden Wiederherstellen mal gesetzt mal nicht bringt keine Änderung.

Hab jetzt nochmal ganz genau hingesehen, und nach einem Neustart, vor dem Einloggen per kdm (also noch auf der konsole) alsamixer aufgerufen, und die settings sind noch ok, also auf ca. 50 %.
Nach einloggen in KDE erhöhen sich Master und PCM auf 100%, was dann sogar machmal zum abschalten der Karten führen kann, mindestens jedoch zum krächzen /aussetzten.

Was stellt in KDE die Lautstärke ein, welche Dateien spielen da noch mit rein?
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Tue Mar 23, 2010 11:14 pm    Post subject: Reply with quote

Ungewöhnlich....!
habe ich so noch nie erlebt..

Eine Idee wäre noch, wie du deine Session beendest,
AFAIK ist doch Standard das die Session beim abmelden gespeichert, und beim wieder anmelden fortgeführt wird,
hast du das evtl. geändert?
also das immer mit einer neuen Session begonnen wird?
Aber auch das wäre leicht ungewöhnlich, soweit ich mich erinnere startet kde eine ganz neue Session doch als default mit etwa 70% des Master Reglers...

/edit:
Ahhrg.., das kann es auch nicht sein, du schriebst ja
Quote:
Auch mit einem frisch erzeugten Test-account hab ich das gleiche Verhalten.
Also sorry, vergiss es..

/edit:2 Mein erster Edit kam gleichzeitig mit deiner Antwort.


Last edited by Josef.95 on Tue Mar 23, 2010 11:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Mar 23, 2010 11:35 pm    Post subject: Reply with quote

Ja Josef,
ich kenn das von meinen anderen KDE Gentoo Kisten auch nicht,

Die von Dir angespreochene Voreinstellung ist bei mir gegeben. Nun schön übersichtlich einzustellen unter:
Systemeinstellungen/Sitzungsverwaltung/Bei der Anmeldung/vorige Sitzung Wiederherstellen.

Für Heute klinke ich mich mal aus, bis später mit hoffentlich weiteren Ideen,

Gut's Nächtle
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Wed Mar 24, 2010 4:54 pm    Post subject: Reply with quote

Ansonsten führe doch auch noch mal
Code:
# alsaconf
neu aus,
dies kann zb hilfreich/nötig sein wenn zuvor ein Kernel Upgrade vorgenommen wurde und es im Kernel neue alsa Treiber gab.

(Es können zb die Module Optionen oder/und die Bezeichnung des Sound Chipsatzes nicht mehr stimmen wenn die Treiber gewechselt oder aktualisiert wurden)
Back to top
View user's profile Send private message
XMath
Guru
Guru


Joined: 14 Aug 2004
Posts: 435
Location: Germany, Gaimersheim

PostPosted: Wed Mar 24, 2010 6:47 pm    Post subject: Reply with quote

Hi,
schau doch mal in
Code:
~/.kde4/share/config/kmixctrlrc
nach, welche Werte dort gespeichert sind.

Ich erinnere mich dunkel, dass ich beim Umstieg von KDE3 auf KDE4 ein ähnliches Problem hatte.

HTH
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Mar 30, 2010 8:44 am    Post subject: Reply with quote

Sorry an alle Helfer für meine lahme Antwort,

aber die Frau hat den Schleppi meist im Gebrauch, weshalb ich da nur gelegentlich dran rumspielen kann :roll:

"Was ich in der Zwischenzeit so alles ausprobiert habe:"

Code:

alsaconf durchgeführt
~/.kde4/share/config/kmixrc und
~/.kde4/share/config/kmixctrlrc gelöscht
KMix einrichten und bei der Option "Lautstärken beim Anmelden wiederherstellen" den Haken raus/rein ausprobiert.


Zwischendrin immer wieder neu gebootet um zu sehen ob sich was verbessert hat.
Nach den ganzen Änderungen nochmal einen Testaccaount angelegt - das gleiche Spiel, d.h.:
Dann hab ich noch ein im Homeverzeichnis bestehendes kde3.5 Verzeichnis und den Link von .kde --> auf kde3.5 gelöscht.
Wie ihr seht hab ich die Kiste (wie alle anderen auch) von kde3.5 auf kde4 migriert.

Übrig ist also nur noch das .kde4 Verzeichnis. Das obige Spiel (siehe Code) nochmal durchgeführt.

Nach dem booten sind meine alsamixer settings noch i.o., z.B. Master u. PCM Lautstärke auf 50%.
Beim einloggen in KDE-4.x (User1) werden diese dann auf 100% erhöht. Stell ich per KMIX GUI die Lautstärke wieder runter auf 50%, logge mich aus und wieder ein bleibt's erhalten.
Logge ich mich aus, und melde mich in KDE4 als User2 an, Lautstärke wieder auf 100%. Reduzieren auf 50%, ausloggen.
Dann wieder als User 1 einloggen, und ich hab wieder 100% Volume!

Visuell hat sich für mich folgendes geändert:

In den systemsettings unter dem Lautsprechersymbol hatte ich zu Anfang mal ein internes Audiogerät und ein dummy device (ausgegraut).
Nach den Änderungen s.o. gab's mal für eine bootphase ein pulseaudio device dort, das danach aber wieder verschwand.
Zwischenzeitlich hab ich nur noch das interne Audiodevice (hab die genaue Bez. gerade nicht am Start), so wie auch bei meinem funktionierenden Desktop PC.

Da ich Pulseaudio auf dem Laptop nicht wirklich brauche, würde ich das zur Sicherkeit mal rausschmeissen (Paket+Flag) und mein world mit --newuse mal neucompilieren, fall ihr nicht eine bessere / zielführendere Idee für mich habt.

Bin gespannt, vielen Dank an alle.

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Mar 31, 2010 3:12 pm    Post subject: Reply with quote

So Leute, ich hab's! :lol:

Folgendes hab ich gemacht um das Problem zu beseitigen:

Code:

emerge -Ca media-sound/pulseaudio
emerge --depclean
die make.conf editiert und ein minus vor pulseaudio gesetzt
pump emerge -DuvaN world || until pump emerge --resume --skipfirst; do pump emerge --resume --skipfirst; done && revdep-rebuild


Und nun geht's! Interessant finde ich folgendes:
In den systemsettings unter Audio (Lautsprecher-Symbol) steht nun nicht mehr wie zuvor "Internes Audio Analog Stereo" sondern stattdessen:
ESS ES1938 (Solo-1) rev0, irq5 ()
Esound (ESD)


Was also exact meiner im Kernel konfigurierten Hardware entspricht, und somit präzisere Angaben darstellt.

Künftig bin ich also etwas vorsichtiger mit pulseaudio, wenn ich's nicht wirklich benötige....

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum