Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
vmware-server , fails to configure (vix-api fails to insta)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rbalasus
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2004
Posts: 90

PostPosted: Wed Mar 24, 2010 7:29 am    Post subject: vmware-server , fails to configure (vix-api fails to insta) Reply with quote

Hello, I try to install and configure vmware-server in the gentoo way.

I was unmasking the latest versions of all packages.
All seems to work, but when I go to configure with:

emerge vmware-server --config
I get:
Code:

The  VMware VIX API failed to install. Please correct the problem and run
vmware-config.pl again.

Starting VMware services:
   Virtual machine monitor                                            failed
   Virtual machine communication interface                            failed
   VM communication interface socket family:                          failed
   Virtual ethernet                                                   failed
Module vmnet is not loaded.  Please verify that it is loaded before
running this script.


The configuration of VMware Server 2.0.2 build-203138 for Linux for this
running kernel completed successfully.



emerge -s vmware-vix shows:
Code:

Searching...   
[ Results for search key : vmware-vix ]
[ Applications found : 1 ]

*  app-emulation/vmware-vix
      Latest version available: 1.6.2.156745-r2
      Latest version installed: 1.6.2.156745-r2
      Size of files: 40,107 kB
      Homepage:      http://www.vmware.com/
      Description:   VMware VIX for Linux
      License:       vmware




and
emerge vmware-vix

is running without an error.

Any Ideas where I can search the problem? Where ist vmware checking that vix is installed, where can I fix it?

Regards rbalasus
Back to top
View user's profile Send private message
ursusca
Apprentice
Apprentice


Joined: 10 Sep 2008
Posts: 284
Location: Toronto ON, CANADA

PostPosted: Wed Mar 24, 2010 10:09 pm    Post subject: Reply with quote

Hi,

Vmware-server doesn't support newer versions of the Linux kernel. Try this links
http://risesecurity.org/2010/01/10/vmware-server-2-0-2-update-patch/
http://www.ubuntugeek.com/how-to-install-vmware-server-2-0-x-in-ubuntu-9-10-karmic.html
_________________
You deserve free software!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum