Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chroot install on Powerbook 5,8 G4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
helcim
n00b
n00b


Joined: 26 Mar 2010
Posts: 5

PostPosted: Fri Mar 26, 2010 10:22 am    Post subject: Chroot install on Powerbook 5,8 G4 Reply with quote

Sorry if this is answered to elsewhere. I couldn't find. Just tried to install Gentoo in chroot according to http://www.wikihow.com/Install-Gentoo-Linux-from-Ubuntu , but when I try to emerge something else than vim I am getting error that my portage supports only EAPI 1 but EAPI 2 is expected. How can I upgrade to EAPI 2?

Many thanks for reply

Piotr[/url]
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Mar 26, 2010 2:44 pm    Post subject: Reply with quote

Sounds like you need to emerge portage, which would probably update portage.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
helcim
n00b
n00b


Joined: 26 Mar 2010
Posts: 5

PostPosted: Fri Mar 26, 2010 4:43 pm    Post subject: Reply with quote

I did try. But I could not for the above reason.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Mar 26, 2010 6:27 pm    Post subject: Reply with quote

I looked at the link you provided. Do you want to create a dual boot with Ubuntu, or do you just want to switch over to Gentoo?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
helcim
n00b
n00b


Joined: 26 Mar 2010
Posts: 5

PostPosted: Fri Mar 26, 2010 8:31 pm    Post subject: Reply with quote

OK, now I tried the other way. I downloaded stage3-g4-2008.0.tar.bz2 and instead of the latest portage this file: portage-2008.0.tar.bz2. After chrooting I did
Code:
emerge --sync
and
Code:
emerge portage
This time I'm getting two errors about python
Code:
  *
 * ERROR: dev-lang/python-2.5.4-r4 failed.
 * Call stack:
 *                ebuild.sh, line   49:  Called pkg_setup
 *   python-2.5.4-r4.ebuild, line   64:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *            eutils.eclass, line 1862:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   sys-devel/gcc-4.1.2 does not actually support the libffi USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/die.env'.
 *

 * Messages for package sys-devel/libtool-2.2.6b:

 * Old versions of installed libraries were detected on your system.
 * In order to avoid breaking packages that depend on these old libs,
 * the libraries are not being removed.  You need to run revdep-rebuild
 * in order to remove these old dependencies.  If you do not have this
 * helper program, simply emerge the 'gentoolkit' package.
 *
 *   # revdep-rebuild --library libltdl.so.3
 *
 * Once you've finished running revdep-rebuild, it should be safe to
 * delete the old libraries.  Here is a copy & paste for the lazy:
 *   # rm '/usr/lib/libltdl.so.3'

 * Messages for package dev-lang/python-2.5.4-r4:

 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.
 *
 * ERROR: dev-lang/python-2.5.4-r4 failed.
 * Call stack:
 *                ebuild.sh, line   49:  Called pkg_setup
 *   python-2.5.4-r4.ebuild, line   64:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *            eutils.eclass, line 1862:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   sys-devel/gcc-4.1.2 does not actually support the libffi USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.5.4-r4/temp/die.env'.
 *




But revdep-rebuild is not installed. So I tried to emerge revdep-rebuild and then was told
Code:

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/powerpc/ppc32/10.0

Calculating dependencies -
emerge: there are no ebuilds to satisfy "revdep-rebuild".


Does it make any sense to you?

Piotr
_________________
okle.pl
Back to top
View user's profile Send private message
Znook
n00b
n00b


Joined: 09 Dec 2009
Posts: 3

PostPosted: Fri Mar 26, 2010 8:39 pm    Post subject: Reply with quote

revdep-rebuild is part of the gentoolkit so emerge that.
Back to top
View user's profile Send private message
helcim
n00b
n00b


Joined: 26 Mar 2010
Posts: 5

PostPosted: Fri Mar 26, 2010 8:58 pm    Post subject: Reply with quote

Sorry, I haven't replied to earlier email. I just want to use gentoo in chroot. No dual boot, no kernel compilation. When I tried to emerge gentoolkit I got again the message
Code:

!!! Your current profile is deprecated and not supported anymore.
!!! Please upgrade to the following profile if possible:
        default/linux/powerpc/ppc32/10.0

Calculating dependencies -
!!! All ebuilds that could satisfy "app-portage/gentoolkit" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-portage/gentoolkit-9999 (masked by: EAPI 2)
- app-portage/gentoolkit-0.3.0_rc9 (masked by: EAPI 2)
- app-portage/gentoolkit-0.3.0_rc8-r1 (masked by: EAPI 2)
- app-portage/gentoolkit-0.3.0_rc8 (masked by: EAPI 2)
- app-portage/gentoolkit-0.3.0_rc7 (masked by: EAPI 2)
- app-portage/gentoolkit-0.2.4.6.1 (masked by: EAPI 2)
- app-portage/gentoolkit-0.2.4.5 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
I saw there are fresher stage3 tarballs. Maybe I'll be better off with them?
_________________
okle.pl
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Mar 26, 2010 10:19 pm    Post subject: Reply with quote

Why not use sysresccd (http://www.sysresccd.org/) or a live CD? It's a lot easier.

An honest question: what are the benefits of using Gentoo only in chroot?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
helcim
n00b
n00b


Joined: 26 Mar 2010
Posts: 5

PostPosted: Fri Mar 26, 2010 10:27 pm    Post subject: Reply with quote

I don't know yet :) I hope for bigger number of programs with altivec support than in debian. Anyway, it seems the way to go was to download most current stage3.
_________________
okle.pl
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6316
Location: /usr/lib64/lv2

PostPosted: Fri Mar 26, 2010 11:12 pm    Post subject: Reply with quote

Whatever works. The wonderful thing about Gentoo is maximum choice! 8)
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum