Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xserver startet nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
rizor
n00b
n00b


Joined: 25 Jul 2008
Posts: 18

PostPosted: Wed Mar 31, 2010 11:53 am    Post subject: xserver startet nicht Reply with quote

Hallo zusammen,

ich habe ein paar Probleme mit dem XServer.
Wenn der X-Server gestartet wird, dann wird der Bildschrim schwarz und ich kann den Serer nicht killen.
Die Version des XServers ist 1.6.5 und der Kernel ist 2.6.33.1.
Ich arbeite mit der HAL und xorg.conf.
Das Config-File brauche ich umdie busID des Framebuffers zu definieren.
Kann ich das auch über HAL machen?
Wenn ich mir das Logfile anschaue, fallen mir da drei Dinge auf:
Code:

(WW) AllowEmptyInput is on, devices using driver 'kbd', 'mouse' or 'vmmouse' willbe disabled
(WW) Disabling Mouse0
(WW) Disabling Keyboard0


Und am Ende entlädt er auch noch den eGalax-Treiber.

Ich würde ma vermuten, dass es an den Warnings liegt.
Wie kann ich das beheben?

Danke.

Gruß,
rizor
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Wed Mar 31, 2010 12:00 pm    Post subject: Reply with quote

Hi

Hast du neu installiert und nur X drauf? Wie startest du X?

Sebastian
Back to top
View user's profile Send private message
rizor
n00b
n00b


Joined: 25 Jul 2008
Posts: 18

PostPosted: Wed Mar 31, 2010 12:02 pm    Post subject: Reply with quote

Ja, habe neu installiert und nur X auf dem System.
Allerdings nicht den xorg-server sondern das komplette Paket
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Wed Mar 31, 2010 4:43 pm    Post subject: Reply with quote

rizor wrote:
Wenn der X-Server gestartet wird, dann wird der Bildschrim schwarz und ich kann den Serer nicht killen.
Dann ist eigentlich alles in Ordnung sofern kein WindowMaker mit gestartet wird.

Und killen kannst du ihn idR zb via "Magic SysRQ-Key"
zb Alt+SysRQ+i
(vermeide bitte hart Resets oder Stecker ziehen!!)

Also installiere dir am besten ein Window Maker, oder eine gewünschte Desktop Environment, nutze eine ~/.xinitrc
oder ein DisplayManager zum starten deiner Session.

Weiteres hilfreiches findet sich auch in den Gentoo Dokumentationen, siehe zb
http://www.gentoo.org/doc/de/list.xml

Viel Erfolg
Back to top
View user's profile Send private message
rizor
n00b
n00b


Joined: 25 Jul 2008
Posts: 18

PostPosted: Thu Apr 01, 2010 7:41 am    Post subject: Reply with quote

Okay, jetzt habe ich noch einen WindowManager installiert.
Nun habe ich allerdings das Problem, dass der xserver die Tastatur und die Maus deaktiviert, wie es im Log steht.
Wie kann ich das verhindern?

Danke.

Gruss,
Sven
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3628
Location: Germany

PostPosted: Thu Apr 01, 2010 9:21 am    Post subject: Reply with quote

rizor wrote:
Ich arbeite mit der HAL und xorg.conf.

rizor wrote:
[....]Nun habe ich allerdings das Problem, dass der xserver die Tastatur und die Maus deaktiviert, wie es im Log steht.
Wie kann ich das verhindern?[...]
Das ist "normal" auch gewünscht wenn xorg-server mit HAL Unterstützung gebaut wurde (Use-Flag)
Es werden die Eingabegeräte in Xorg deaktiviert um sie dann via hotplugging an HAL weiterzuleiten,
damit das korrekt funktioniert muss natürlich dann auch der hal-Dämon gestartet sein
Code:
# /etc/init.d/hald start && rc-update add hald default


Wenn du die Nutzung von HAL für die Eingabegeräte aber wirklich verhindern möchtest:
1) Möglichkeit: xorg-server ohne HAL Unterstützung bauen, (USE="-hal")
2) Möglichkeit: in der xorg.conf
Code:
 Section "ServerFlags"
    Option         "AllowEmptyInput" "false"
    Option         "AutoAddDevices"  "false"
    Option         "AutoEnableDevices"  "false"
EndSection
zu setzen.
Wenn du wirklich HAL für die Eingabegeräte nicht nutzen möchtest würde ich die erste Methode bevorzugen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum