Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
insmod error tijdens boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
gondolin
Apprentice
Apprentice


Joined: 09 Apr 2003
Posts: 158

PostPosted: Tue Sep 09, 2003 11:56 am    Post subject: insmod error tijdens boot Reply with quote

Hoi,

ik heb m'n laptop moeten herformateren, er moest (helaas) een windows partitie op.

Nu krijg ik bij het booten een error dat er i810_auto.o insmod failed.
Ik heb dezelfde kernel config gebruikt, en dezelfde /etc/modules.autoload.
ik heb bij /etc/modules.d/alsa: alias snd-card-0 snd-intel8x0

iemand een idee wat er fout is?
Back to top
View user's profile Send private message
WHiZZi
n00b
n00b


Joined: 09 Sep 2003
Posts: 24
Location: Rosmalen City

PostPosted: Tue Sep 09, 2003 2:03 pm    Post subject: Reply with quote

Misschien de module opnieuw compilen. Ik weet niet wat je precies gedaan hebt (Linux opnieuw geinstalleerd of Windows er bij gezet), maar als je Linux opnieuw hebt geinstalleerd heb je kans dat de module niet goed gecompiled is of gewoon niet in de kernel zit.
_________________
Professioneel Gentoo gebruiker
Grootste drumforum van NL
Weird Al Yankovic forum
Back to top
View user's profile Send private message
_hesoez_
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2003
Posts: 103
Location: Belgium-Duffel/Leuven

PostPosted: Tue Sep 09, 2003 4:58 pm    Post subject: Reply with quote

is het dezelfde kernel versie?
misschien zit de driver in de kernel zelf ipv een module.
is het i810_audio.o?
als je met alsa wil werken moet je geen geluidsdriver selecteren in de kernel.

grtz
Back to top
View user's profile Send private message
gondolin
Apprentice
Apprentice


Joined: 09 Apr 2003
Posts: 158

PostPosted: Tue Sep 09, 2003 5:04 pm    Post subject: Reply with quote

De config file is van r5 en ik heb de r6 gemaakt, en het is inderdaad de i810_audio.o.

Ik zal het eens deselcteren in de kernel config.
Back to top
View user's profile Send private message
_hesoez_
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2003
Posts: 103
Location: Belgium-Duffel/Leuven

PostPosted: Tue Sep 09, 2003 5:11 pm    Post subject: Reply with quote

ik heb zelf i810_audio gecompileerd als module, maar niet geladen.
ik gebruik alsa met snd-intel8x0 driver. alsasound laad de module bij het opstarten.
i810_audio kan ik altijd nog laden met modprobe als mijn alsa het laat afweten voor een of andere reden(hopelijk nooit). maar er kan maar 1 driver de geluidskaart aanspreken, de andere zal geweigerd worden.

normaal zou een overgang van r5 naar r6 niet veel verschil mogen maken, mja ge weet nooit.

veel succes
grtz
Back to top
View user's profile Send private message
gondolin
Apprentice
Apprentice


Joined: 09 Apr 2003
Posts: 158

PostPosted: Wed Sep 10, 2003 11:09 am    Post subject: Reply with quote

Wel, ik heb dezelfde instelingen als jij, als module gecompileerd maar niet geladen.
Ik heb nu m'n kernel gehercompileerd, en de module weggelaten en alles werkt weer prima .

Bizar maar ja.
Het enige wat ik anders doe is het gebruiken van genkernel --config.

Vroeger deed ik met de hand en nu laat ik dingen over aan genkernel. Ik heb op het engelse forum al slechte dingen over genkernel gelezen, misschien is was m'n probleem hier ook aan te wijten.

Alvast bedankt voor alle hulp
Back to top
View user's profile Send private message
_hesoez_
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jun 2003
Posts: 103
Location: Belgium-Duffel/Leuven

PostPosted: Wed Sep 10, 2003 12:12 pm    Post subject: Reply with quote

genkernel heb ik nog niet gebruikt, misschien staat dit nog ni op punt.

grtz
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum