Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Grafik weg seit Versuch mit eigenem Kernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
bierbauchangsthase
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jun 2009
Posts: 102

PostPosted: Mon Apr 05, 2010 9:02 pm    Post subject: Grafik weg seit Versuch mit eigenem Kernel Reply with quote

Hallo.

Ihr möchtet jetzt bitte lieb und verständnisvoll sein. Denkt einfach, ich sei der Osterhase.

Ich habe vor einiger Zeit (zu Neujahr, glaube ich) versucht, mit einem eigenen Kernel mein Wlan zu aktivieren. Das ging irgendwie schief. Jedenfalls habe ich seither - auch mit dem alten automatischen Kernel - keine graphische Oberfläche mehr.
Ich habe erst jetzt wieder Zeit zum Computerspielen, daher ist das Problem nicht mehr so ganz frisch für mich.

Wenn ich (egal ob als user oder root) "startx" tippe, kommt eine riesige Anzahl von Fehlermeldungen. Es geht los mit
"Failed to initialize the GLX module"
dann
"Fatal: Error inserting nvidia ... unknown symbol in module or unknown parameter"
dann
"Failed to load the nvidia kernel module"
dann
"Screens found", aber ohne brauchbare Konfiguration,
dann
"Fatal server Error: no screens found"
dann
"xinit: Connection refused (errno 111) ... und (errno 3)"

Verzeiht wenn das jetzt blöd aussieht, aber ich kann nicht diese ganze Seite abtippen.

Was ist passiert? Habe ich den Treiber vergessen? Aber: Das kommt auch mit dem alten genkernel. Kann einem ein schlechter Kernel noch irgendwas zerstören? Was könnte ich versuchen? Als nächstes werde ich mal das logfile suchen und hier mit ranhängen. Dazu muß ich aber erst mit dem anderen System booten, um vernünftig ins Netz zu kommen.

Danke!
Der Osterhase (auch: bierbauchangsthase) ':roll:'


Last edited by bierbauchangsthase on Mon Apr 05, 2010 9:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Mon Apr 05, 2010 9:10 pm    Post subject: Reply with quote

Richtig wahrscheinlich ist ein Update für X reingekommen. Und du hast nicht bedacht den Treiber neuzubaun. Ich empfehle deinen neuen Kernel zu verwenden /usr/src/linux auf die Quellen des KErnels zeigen zu lassen und dann die nvidia-drivers neuzubaun.
(genauso wie die installierten xf86-input-*)

(Wegen dem "ohne X vernünftig ins Netz rein", probiers mit lynx oder links.)
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
bierbauchangsthase
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jun 2009
Posts: 102

PostPosted: Mon Apr 05, 2010 9:28 pm    Post subject: Reply with quote

Vielen Dank Max.

Ja, links ging schon, aber Wlan ging eben nicht. Und an dem alten Notebook, auf dem ich dann den ersten Post getippt habe, ist irgendein Schaden (wohl am Motherboard), so daß jede Berührung das Ding ausmacht - und da wollte ich nicht ranfassen, um das kabel rauszuziehen. Ich bin sogar ein großer Fan von links und w3m.

Das logfile sagt nichts entscheidend Neues, oder?
Code:
(II) Loading /usr/lib64/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
   compiled for 1.5.3, module version = 1.0.0
   ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
   [0] -1   0   0xffffffff - 0xffffffff (0x1) MX[B]
   [1] -1   0   0x000f0000 - 0x000fffff (0x10000) MX[B]
   [2] -1   0   0x000c0000 - 0x000effff (0x30000) MX[B]
   [3] -1   0   0x00000000 - 0x0009ffff (0xa0000) MX[B]
   [4] -1   0   0x0000ffff - 0x0000ffff (0x1) IX[B]
   [5] -1   0   0x00000000 - 0x00000000 (0x1) IX[B]
(==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found


Sollte ich an anderer Stelle im Logfile was Bestimmtes suchen? Über deinen Vorschlag werde ich nachdenken. Ganz lange und ganz tief. (Hört sich ein bißchen an, als könnte der Osterhase wieder einmal eine Menge dabei dazulernen, wenn Du verstehst ...)

Vielleicht mache ich lieber eine Neuinstallation ("Waaas? Freiwillig eine Gentoo-Neuinstallation? Bist du des Wahnsinns?" Naja. Immerhin vielleicht die Gelegenheit, ein paar Sachen besser zu machen als beim ersten Mal.)
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon Apr 05, 2010 9:54 pm    Post subject: Re: Grafik weg seit Versuch mit eigenem Kernel Reply with quote

Manchmal reicht es aus, kleine Teile im Kernel zu ändern und Treiber wie die von nvidia oder ati müssen neu gegen den kernel kompiliert werden, ebenso beim Kernel update.
Dafür gibt es aber auch sys-kernel/module-rebuild.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3631
Location: Germany

PostPosted: Mon Apr 05, 2010 10:01 pm    Post subject: Reply with quote

Quote:
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!



Du baust den nVidia Treiber vermutlich gegen die falschen Kernel Sources
Schau welcher Kernel läuft
Code:
uname -r

Dann prüfe ob der Symlink auf die selbe Version zeigt, zb
Code:
ls -l /usr/src/linux
oder mit
Code:
# eselect kernel list

Denn der nvidia-drivers muss gegen die Kernel Sources gebaut werden dessen Kernel du auch lädst. :wink:
Wenn der Symlink korrekt ist sollte ein neu bauen der nvidia-drivers und ein neuladen des Treiber Moduls dein X wieder starten lassen.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Tue Apr 06, 2010 10:33 am    Post subject: Reply with quote

Soweit ich weiß müssen die Module sogar mit der selben GCC-Version gebaut werden wie der KErnel. (Also Kernelmodule, wie der NVidia-Gluecode).
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
bierbauchangsthase
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jun 2009
Posts: 102

PostPosted: Mon Jul 19, 2010 9:19 pm    Post subject: Reply with quote

Ich habe soeben beschlossen, mit dem Gentoo-Abenteuer aufzuhören. Ich brauche ein System, das ich auch mal alleine lassen kann. Das ging mit gentoo schief.

Gerade habe ich mal wieder stundenlang gebastelt: einen alten Kernel mit eth0 finden und in grub2 eintragen, nvidia-drivers und xorg-x11 emergen ... ging nicht wegen maskierter Pakete ... portage-update nötig ... gemacht ... oje: python-update nötig ... gemacht ... unmaskieren immer noch kritisch ... emerge-Handbuch lesen ...

und all das ohne X in einer shell ohne copy-paste.

Ich habe festgestellt, dass es mich nervt, weil ich in dieser Zeit weder produktiv noch sportlich noch für meine Familie oder meinen Job da bin ... und künstlerisch tätig bin ich dabei schon gar nicht. Schade, aber so soll es nicht sein. Schade, weil ich Gentoo sooo sexy fand. Aber diese vertane Zeit is nich sexy.

:cry: :cry: :cry:

Danke Euch allen für die viele Hilfe! :lol:
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Mon Jul 19, 2010 9:39 pm    Post subject: Reply with quote

Bye Hase :)

Aber ich weiß schon das du zu Ostern wieder da bist.

Gentoo ist nicht immer einfach und auch nicht "praktisch", wenn man gerade nicht weiß was man tut. Wenn der platz stimmt dann installiere dir ein Ubuntu "nebenan". So kannst du immer wenn etwas kaputt ist dieses Starten und an deinem Gentoo weiterspielen. Die Grafikkarten Sache ist immer sehr ärgerlich und mit Abstand das ätzenste Fehler den man haben kann.

Aber wenn man ein alternatives System hat von dem man sich via SSH verbinden kann oder per Chroot von einer Live-CD, ist es kein Problem wenn auch mal solche Fehler auftreten. Das gemeine ist, das man wissen muss oder eine wage Vorstellung haben muss wo der Fehler liegt.

Alles Gute!
Back to top
View user's profile Send private message
Jimini
Guru
Guru


Joined: 31 Oct 2006
Posts: 590
Location: Germany

PostPosted: Tue Jul 20, 2010 5:50 am    Post subject: Reply with quote

Um Gentoo zu nutzen, braucht man entweder von Anfang an ein immenses Wissen über den Aufbau eines (Linux-)Systems oder eine gewisse Menge Geduld. Bis meine erste Gentoo-Installation durchbootete, vergingen rund 2 Wochen. Seitdem habe ich Gentoo sicherlich an die 100mal installiert und auch heute passierts mir noch, dass ich nach der Installation feststelle, dass ich kein root-Passwort gesetzt oder den falschen Controller in den Kernel gebaut habe.
Gentoo bedeutet vor allem Freiheit und Flexibilität - und diese beiden Dinge erkauft man sich auf Kosten von zeitweisen Konfigurations- und Frickelorgien. Und diese werden mit der Zeit weniger beziehungsweise beherrscht man die Dinge irgendwann einfach besser. Der Konfigurationsmoloch "Gentoo" wird irgendwann ziemlich transparent, glaub mir :)

MfG Jimini
_________________
"The most merciful thing in the world, I think, is the inability of the human mind to correlate all its contents." (H.P. Lovecraft: The Call of Cthulhu)
Back to top
View user's profile Send private message
schachti
Advocate
Advocate


Joined: 28 Jul 2003
Posts: 3765
Location: Gifhorn, Germany

PostPosted: Tue Jul 20, 2010 7:30 am    Post subject: Reply with quote

bierbauchangsthase wrote:

und all das ohne X in einer shell ohne copy-paste.


sys-libs/gpm hilft. :wink:

bierbauchangsthase wrote:

Ich habe festgestellt, dass es mich nervt, weil ich in dieser Zeit weder produktiv noch sportlich noch für meine Familie oder meinen Job da bin ... und künstlerisch tätig bin ich dabei schon gar nicht. Schade, aber so soll es nicht sein. Schade, weil ich Gentoo sooo sexy fand. Aber diese vertane Zeit is nich sexy.


Aus eigener Erfahrung: Das legt sich mit der Zeit, wenn man "sattelfest" mit gentoo geworden ist. Es bleibt zugegebenermaßen mehr täglicher Administrationsaufwand als zum Beispiel bei openSUSE, dafür hast Du mit vielen anderen Distris oft wirklich garstige Probleme beim Update auf eine neue Version - da schätze ich doch das Rolling-Release-Prinzip von gentoo.
_________________
Never argue with an idiot. He brings you down to his level, then beats you with experience.

How-To: Daten verschlüsselt auf DVD speichern.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Tue Jul 20, 2010 8:00 am    Post subject: Reply with quote

Ich denke, du machst den Fehler, dass bei dir Kernel, Module und Sources nicht zusammenpassen. Du sagtest ja, du nimmst irgendeinen alten Kernel. Die nvidia Treiber z.B. werden in Abhängigkeit von der Konfiguration deiner Kernelquellen gebaut. Und du musst den davon erzeugten Kernel und die Module nehmen und auch die nvidia Treiber neu übersetzen und installieren.
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Tue Jul 20, 2010 8:52 am    Post subject: Reply with quote

Ich versuch mich grad in Arch einzuarbeiten. Ehrlichgesagt kann ich den Hype und Coolnessfaktor um Arch nicht verstehen. Die Paketverwaltung ist einfach nur Scheiße. Genau dasselbe Problem hatte ich bei Ubuntu/Debian.

Btw. versuch mal bei Arch irgendwo die Kernelsourcen (z.B. zum Bauen der VMWare-Module) irgendwo aufzutreiben.

Würgaround soweit: Ohne jetzt das ABS-Zeux zu installieren, was irgendwie mehr schlecht als recht emerge nachbilden will, zieht man sich den Vanilla-Kernel neu, kopiert die /proc/config.gz als .config in die Vanilla-Sources rein. Anschließend kann man den Kernel mit dem ganzen Geraffel bauen, baut noch die Ramdisk für die Module beim Booten, startet die Kiste neu und erhält einen Fehler, dass sda3 nicht gefunden werden konnte.

Ich bau jetzt den Vanilla-Kernel manuell. Und damit bin ich beim selben Aufwand wie bei Gentoo.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Jul 23, 2010 7:03 am    Post subject: Reply with quote

Bye Osterhasi,

liegt sicher am heissen Wetter, das setzt ja bekanntlich euer MHD stark herab, und dann gibt's schonmal 'n Satz Weisse Ohren. :wink:
Naja, aber das nächste Ostern kommt bestimmt, und dann gibt's wieder Frische, gell. :lol:

Schade dass du gefrustet bist, und die Flinte ins Korn werfen willst.

Aber wie heisst es doch hier stets: Gentoo ist nicht für jeden.
oder.
Ist es zu stark, bist du zu schwach

Dabei hattest du doch alles am laufen, und hast somit die schwierigsten Hürden schon einmal genommen. Wenn ich mir mein Gentoo mal aus lauter Spieltrieb zerkonfiguriere, dann suczh ich den Fehler bei mir, nicht beim System.
War's ne andere DISTRO, und ich habe lediglich über die vorhanden Update-Mechanismen upgedated, und danach läuft nichts mehr, dann lag's natürlich an der DISTRO! :wink:

Vielleicht hättest du einfach eine andere Sicherheitsstrategie wählen sollen, besonders wenn du dein System so selten anpackst, und daher wenig geübt im troubleshoooten bist.

Z.B. dein laufendes Gentoo auf 'ne andere Partition clonen, als lauffähiges Backupsystem zum Arbeiten, an dem anderen kann mann dann in Ruhe experimentieren.
So bleibst du Produktiv/ creativ, or whatever you want.

Ich finde es jedenfall mittlerweile gerade gut, dass man sich auf der CLI stets weiterhelfen kann, weil man ja gelernt hat, sein System auf diese Art zu erstellen.
Es fiel mir am Anfang auch schwer zu akzeptieren dass es keinen vernünftigen installer gibt, aber mittlerweile habe ich den Sinn des Gentoo-Way, darauf bewusst zu verzichten, als konsequent und richtig angenommen.
Hab daher am Anfang auch gerne mal versucht mir das leben mit nem Sabayon, Ututo, Nova, Calculate und wie die ganzen Gentoo-Derivate heissen, leichter zu machen.
Aber je tiefer man durchblickt, desto mehr erkennt man, dass tatsächlich nichts über das Original geht. Binäre Distributionen sind zu diesem Zeitpunkt dann eh keine Alternative mehr...(zumindest für mich) :wink:

@ Schachti - hey, den sys-libs/gpm Tipp wollte ich doch geben.

@ musv - hört man immer wieder gern auch mal von anderen, quasi als Bestätigung für die eigene Sichtweise.

So, genug geschwafelt, ist ja mittlerweile der reinste Chat-Thread geworden das.

Vergnügliche Grüße,

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum