Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU][X-ORG]Problème de clavier au démarrage de XDM
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Miorg
n00b
n00b


Joined: 15 Nov 2009
Posts: 18

PostPosted: Sat Apr 10, 2010 2:03 pm    Post subject: [RESOLU][X-ORG]Problème de clavier au démarrage de XDM Reply with quote

Bonjour a tous...

Voila j'ai un petit soucis de clavier au démarrage de xdm.

Hier soir comme tout les soirs je lance mon petit script a 2 francs 6 sous afin de mettre a jour ma Gentoo a jour. Je regarde vite fait les maj a faire et m'appercois qu'une maj X-org et de rigueur.. Bref... Je part me coucher normalement et passe une trés bonne nuit (meme si on s'en fou :) )

Ce matin je me leve normalement et comme tout bon vieux geek/nolife la premiere chose aue je fait et de demarrer mon pc (Laptop HP pavillon DV7)

Il démarre correctement jusqu'a arriver sur l'ecran de login ou je m'appercois qu'il m'est impossible de saisir mon identifiant... En effet mon clavier de repond plus... Direct mon cerveau semi reveiller fait tilt avec la maj x-org de cette nuit...

Bon je procede a un arret brutal du PC et le redemarre.

Pendant le boot de celui j'appui sur [i] afin de passer en boot interactif, rentre mon pass root et accede au "mode console". (Je m'appercois donc que au démarrage mon clavier fonctionne trés bien mais pas au demarrage de xfce4)

A l'époque ou j avais installer ma gentoo j'avais deja eu se probleme et apres certaine recherche j avais pu découvrir que en rajoutant
Code:

Section "ServerFlags"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
    Option         "AutoAddDevices" "false"
    Option         "Xinerama" "0"
EndSection


dans mon x-org avais resolu le probleme.

Bref je decide de commenter ces lignes pour verifier si le soucis ne viennent pas d'elle depuis la mise a jour du x-org... FAIL c'est pas ca...

Je viens de faire pas mal de recherche sans solution définitive d'ou mon post et mon apel a l'aide :)

Voici mon x-org.conf

http://www.toofiles.com/fr/oip/documents/txt/xorg_conf.html

Cordialement..


Last edited by Miorg on Sat Apr 10, 2010 9:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7936
Location: ~Brussels - Belgique

PostPosted: Sat Apr 10, 2010 3:41 pm    Post subject: Reply with quote

Salut,

Que donnent les elog (les messages à l'issue d'un emerge) ?
As-tu fait un dispatch-conf ?

Essaie de recompiler la base :
Code:
emerge -1av mesa xorg-server `qlist -C x11-drivers/`

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
jcTux
Apprentice
Apprentice


Joined: 29 Dec 2009
Posts: 276
Location: Tours, France

PostPosted: Sat Apr 10, 2010 5:12 pm    Post subject: Reply with quote

XavierMiller wrote:
Salut,

Que donnent les elog (les messages à l'issue d'un emerge) ?
As-tu fait un dispatch-conf ?

Essaie de recompiler la base :
Code:
emerge -1av mesa xorg-server `qlist -C x11-drivers/`

Effectivement je pense que il n'a pas pensé à lancer après la mis-à-jour de Xorg :
Code:
emerge `qlist -C x11-drivers/`
Back to top
View user's profile Send private message
Miorg
n00b
n00b


Joined: 15 Nov 2009
Posts: 18

PostPosted: Sat Apr 10, 2010 9:11 pm    Post subject: Reply with quote

Bon bah bravo... Probleme resolu. Je vous écris de ma Gentoo... Surement que suite a la maj emerge avais du me dire qu'il fallais que je fasse cette manip... Mais j'étais deja au lit et mon PC c'est éteint donc le lendemain je n'est pas spécialement fait attention...

Un GRAND merci a vous deux...

Cordialement
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7936
Location: ~Brussels - Belgique

PostPosted: Mon Apr 12, 2010 8:44 am    Post subject: Reply with quote

Moralité : installe d'urgence elogv et lance-le après un emerge ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
RaX
Apprentice
Apprentice


Joined: 16 Aug 2007
Posts: 166

PostPosted: Tue Apr 13, 2010 7:35 pm    Post subject: Reply with quote

Pour ceux qui utilise eix:

Code:
emerge -1 `eix -CI --only-names x11-drivers`


Bonne soirée.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum