Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Tastaturlayout im KDE Anmeldebild xorg-server 1.8
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 71

PostPosted: Wed Apr 14, 2010 8:31 pm    Post subject: [solved]Tastaturlayout im KDE Anmeldebild xorg-server 1.8 Reply with quote

ich bin inzwischen beim Xorg Server 1.8 angekommen. Gemäß Installationshinweis alle Treiber (-evdev, -mouse, -keyboard, -ati) sind neu gebaut.
Anschließend war für KDE das deutsche Tastaturlayout verschwunden - an sich über eine entsprechende hal.fdi gesetzt. geholfen hat hier insoweit der Hinweis und die Internetrecherche, dass der Server 1.8 konsequent ohne hal daherkommt. Also nochmal ohne HAL Flag übersetzt. Keine Besserung.

Zustand vor 1.8
Nutzung einer passenden hal.fdi für das Tastaturlayout. KDE Systemeinstellung für Tastaturlayout war deaktiviert. Konsolenlogin funktioniert korrekt durch entsprechende keymap Einstellung

Zustand mit 1.8
Hal ist von den Programmierern nicht mehr verwendet, alles läuft über udev.
Mit den Systemeinstellungen in KDE (setxkbkeymap) kann ich zumindest innerhalb von kde korrekt mit deutscher Belegung arbeiten. Konsolenlogin geht auch mit korrekter Belegung.
Offen ist der KDE-Anmeldebildsschirm. Da läuft noch nicht die Einstellung der setxkbkeymap, und damit liegt hierfür die Eingaben noch die US-Tastaturbelegung vor. Im "abgesicherten" Modus mit dem einfachen xorg-fenster gibt es auch kein deutsches Tastaturlayout mehr. Vom Grunde her logisch, da ohne Benutzung von hal durch den X-Server die hal.fdi für die Tastatur ja nicht mehr verarbeitet wird.

Wer hat eine Idee wo es etwas zum Nachlesen gibt. Ich bin mit meinen Recherche auch auf den Entwicklerseiten nicht fündig geworden.
_________________
Kernel 5.xx-gentoo
GCC 9.xx
Profile amd64/17.1/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F31
ATI RX580


Last edited by demiurg on Thu Apr 15, 2010 5:43 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Apr 15, 2010 12:03 am    Post subject: Reply with quote

Hi

"-evdev" würde ich nicht setzen..
Ich bin hier selbst aber auch noch am am forschen,
mit meiner guten alten Logitech diNovo (Maus Tastatur Set) funkt es jedoch schon einwandfrei.

Für weiteres siehe zb auch: https://forums.gentoo.org/viewtopic-t-820551-postdays-0-postorder-asc-start-0.html

Viel Erfolg
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1422
Location: germany

PostPosted: Thu Apr 15, 2010 1:45 am    Post subject: Reply with quote

Also ich habe (dieser Anleitung folgend) das hier in die /etc/X11/xorg.conf eingetragen und habe damit wieder ein deutsches Tastaturlayout:
Code:
Section "InputClass"
    Identifier  "keyboard-all"
    Driver      "evdev"
    Option      "XkbLayout"  "de"
    Option      "XkbVariant" "nodeadkeys"
    MatchIsKeyboard "on"
EndSection

Man Beachte, daß der Abschnitt "InputClass" und nicht wie bei älteren xorg-server Versionen "InputDevice" heißt. Die nodeadkeys Zeile muß nicht mit rein, falls man die "toten" Tasten braucht ;)
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 71

PostPosted: Thu Apr 15, 2010 5:25 am    Post subject: Reply with quote

Josef.95 wrote:
Hi

"-evdev" würde ich nicht setzen..
Ich bin hier selbst aber auch noch am am forschen,
mit meiner guten alten Logitech diNovo (Maus Tastatur Set) funkt es jedoch schon einwandfrei.

Für weiteres siehe zb auch: https://forums.gentoo.org/viewtopic-t-820551-postdays-0-postorder-asc-start-0.html

Viel Erfolg


Das minus vor evdev und den anderen Treibern sollten nicht Use Flags repräsentieren, sondern meine Schreibfaulheit unterstützen - anstelle von xf86-input-evdev, xf86-input-mouse etc. :-). Aber danke für den Link. Da kommt die xorg.conf demnach wieder zu Ehren, allerdings mit neuem Inhalt. Mit den xorg server Versionen 1.7 hatte ich schon komplett auf evdev umgestellt und die xorg.conf gelöscht.

für das 32 Bit System
xorg-server Installed versions: 1.8.0(07:22:07 15.04.2010)(ipv6 nptl udev xorg -dmx -doc -hal -kdrive -minimal -static-libs -tslib)
und dem Eintrag in der xorg.conf klappt jetzt alles wie gewohnt bei abgeschaltetem setxkbkeymap.
_________________
Kernel 5.xx-gentoo
GCC 9.xx
Profile amd64/17.1/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F31
ATI RX580
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Apr 15, 2010 11:55 am    Post subject: Reply with quote

demiurg wrote:
Das minus vor evdev und den anderen Treibern sollten nicht Use Flags repräsentieren, sondern meine Schreibfaulheit unterstützen - anstelle von xf86-input-evdev, xf86-input-mouse etc. :-).
Das war schon klar, denn USE="evdev" gibt es ja so gar nicht, ich bin also nur deiner Schreibfaulheit gefolgt...;-)
(ich dachte erst du hättest nun "evdev" aus der INPUT_DEVICES="XXX" Variable raus genommen,
es wahr also doch ein Missverständnis meinerseits) :roll:

Doch ich würde nun eher auch den guten Beispiel und den Link den Polynomial-C nannte folgen,
ich hatte den offiziellen Xorg-server 1.8 Upgrade Guide bisher auch noch nicht entdeckt...
Danke auch!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum