Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Funtoo xorg block [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 8:18 am    Post subject: Funtoo xorg block [SOLVED] Reply with quote

I have a Funtoo system and I saw a xorg block in my world update:
Code:
localhost drphibes # emerge -uDNav world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fglrx vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi" 0 kB
[ebuild  N    ] x11-base/xorg-server-1.7.6  USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib" 4,813 kB
[ebuild  N    ] x11-drivers/ati-drivers-9.11  USE="modules -debug (-multilib)" 0 kB
[ebuild     U ] x11-drivers/xf86-video-ati-6.12.6 [6.12.5] USE="-debug" 900 kB
[blocks B     ] >=x11-base/xorg-server-1.7.0 (">=x11-base/xorg-server-1.7.0" is blocking x11-drivers/ati-drivers-9.11)

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 5,713 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-drivers/ati-drivers-9.11', 'merge') pulled in by
    x11-drivers/ati-drivers required by ('ebuild', '/', 'x11-base/xorg-drivers-1.7', 'merge')

  ('ebuild', '/', 'x11-base/xorg-server-1.7.6', 'merge') pulled in by
    >=x11-base/xorg-server-1.2[-minimal] required by ('ebuild', '/', 'x11-drivers/xf86-video-ati-6.12.6', 'merge')
    >=x11-base/xorg-server-1.6.3 required by ('installed', '/', 'x11-drivers/xf86-input-evdev-2.3.2', 'nomerge')
    >=x11-base/xorg-server-1.0.99 required by ('installed', '/', 'x11-drivers/xf86-video-vesa-2.3.0', 'nomerge')
    (and 6 more)


eix shows no 1.7.6 edition:

Code:
localhost drphibes # eix x11-base/xorg-server
* x11-base/xorg-server
     Available versions:  [M]1.5.3-r6 1.6.5-r1 ~1.7.4 ~1.7.4.901 {3dfx debug dmx hal input_devices_acecad input_devices_aiptek input_devices_citron input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_mutouch input_devices_penmount input_devices_synaptics input_devices_tslib input_devices_virtualbox input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl tslib video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_dummy video_cards_epson video_cards_fbdev video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_via video_cards_virtualbox video_cards_vmware video_cards_voodoo video_cards_xgi xorg}
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


I try to emerge ati-drivers:

Code:
localhost drphibes # emerge x11-drivers/ati-drivers
Calculating dependencies... done!
[ebuild  N    ] x11-base/xorg-server-1.7.6  USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib"
[ebuild  N    ] x11-drivers/ati-drivers-9.11  USE="modules -debug (-multilib)"
[ebuild  N    ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fglrx vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi"
[blocks B     ] >=x11-base/xorg-server-1.7.0 (">=x11-base/xorg-server-1.7.0" is blocking x11-drivers/ati-drivers-9.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-drivers/ati-drivers-9.11', 'merge') pulled in by
    x11-drivers/ati-drivers required by ('ebuild', '/', 'x11-base/xorg-drivers-1.7', 'merge')
    x11-drivers/ati-drivers


eix says that I there is no ati-drivers:

Code:
localhost drphibes # eix ati-drivers
* x11-drivers/ati-drivers
     Available versions: 
   (0)   [M]8.552-r2 [M]~8.593
   (1)   9.9-r2 9.10 9.11
   {acpi debug kernel_linux modules multilib}
     Homepage:            http://www.ati.com
     Description:         Ati precompiled drivers for r600 (HD Series) and newer chipsets


I try to emerge xorg-drivers:

Code:
localhost drphibes # emerge x11-base/xorg-drivers
Calculating dependencies... done!
[ebuild  N    ] x11-base/xorg-drivers-1.7  INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -joystick -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fglrx vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -geode -glint -i128 -i740 (-impact) -intel -mach64 -mga -neomagic (-newport) -nv -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -via -virtualbox -vmware (-voodoo) -xgi"
[ebuild  N    ] x11-base/xorg-server-1.7.6  USE="hal ipv6 nptl sdl xorg -debug -dmx -kdrive -minimal -tslib"
[ebuild  N    ] x11-drivers/ati-drivers-9.11  USE="modules -debug (-multilib)"
[blocks B     ] >=x11-base/xorg-server-1.7.0 (">=x11-base/xorg-server-1.7.0" is blocking x11-drivers/ati-drivers-9.11)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'x11-drivers/ati-drivers-9.11', 'merge') pulled in by
    x11-drivers/ati-drivers required by ('ebuild', '/', 'x11-base/xorg-drivers-1.7', 'merge')


eix shows nothing:

Code:
localhost drphibes # eix xorg-drivers
* x11-base/xorg-drivers
     Available versions:  1.6 ~1.7 {input_devices_acecad input_devices_aiptek input_devices_citron input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_mutouch input_devices_penmount input_devices_synaptics input_devices_tslib input_devices_virtualbox input_devices_vmmouse input_devices_void input_devices_wacom video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_via video_cards_virtualbox video_cards_vmware video_cards_voodoo video_cards_xgi}
     Homepage:            http://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers



I must say that I unmerged the above files, so I can re-emerge. But, now, I'm trapped!
Any ideas? I'm not so experienced in Blocked packages... :oops:


Last edited by rpil on Thu Apr 15, 2010 1:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5724

PostPosted: Thu Apr 15, 2010 9:09 am    Post subject: Reply with quote

You cannot install the ATI binary drivers with 1.8.
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 9:59 am    Post subject: Reply with quote

So, what I'm doing with this block? :?
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Apr 15, 2010 11:18 am    Post subject: Reply with quote

i dont use the ati crap myself but probably adding >=x11-base/xorg-server-1.7.0 to /etc/portage/package.mask will let you install a xorg-server package that works with the binary drivers from ati.
If you really dont care about 3d stuff, which also includes the fancy desktop animations, and your ati card is more or less well supported i would suggest you to use the open driver instead.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 11:25 am    Post subject: Reply with quote

I don't care about 3d stuff either, but right now, eix xorg-server shows nothing

Code:
localhost drphibes # eix xorg-server
* x11-base/xorg-server
     Available versions:  [M]1.5.3-r6 1.6.5-r1 ~1.7.4 ~1.7.4.901 {3dfx debug dmx hal input_devices_acecad input_devices_aiptek input_devices_citron input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_mutouch input_devices_penmount input_devices_synaptics input_devices_tslib input_devices_virtualbox input_devices_vmmouse input_devices_void input_devices_wacom ipv6 kdrive minimal nptl sdl tslib video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_dummy video_cards_epson video_cards_fbdev video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_via video_cards_virtualbox video_cards_vmware video_cards_voodoo video_cards_xgi xorg}
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org X servers


and I don't have xorg-drivers as well:
Code:
localhost drphibes # eix xorg-drivers
* x11-base/xorg-drivers
     Available versions:  1.6 ~1.7 {input_devices_acecad input_devices_aiptek input_devices_citron input_devices_elographics input_devices_evdev input_devices_fpit input_devices_hyperpen input_devices_joystick input_devices_keyboard input_devices_mouse input_devices_mutouch input_devices_penmount input_devices_synaptics input_devices_tslib input_devices_virtualbox input_devices_vmmouse input_devices_void input_devices_wacom video_cards_apm video_cards_ark video_cards_ast video_cards_chips video_cards_cirrus video_cards_dummy video_cards_epson video_cards_fbdev video_cards_fglrx video_cards_geode video_cards_glint video_cards_i128 video_cards_i740 video_cards_impact video_cards_intel video_cards_mach64 video_cards_mga video_cards_neomagic video_cards_newport video_cards_nv video_cards_nvidia video_cards_r128 video_cards_radeon video_cards_radeonhd video_cards_rendition video_cards_s3 video_cards_s3virge video_cards_savage video_cards_siliconmotion video_cards_sis video_cards_sisusb video_cards_sunbw2 video_cards_suncg14 video_cards_suncg3 video_cards_suncg6 video_cards_sunffb video_cards_sunleo video_cards_suntcx video_cards_tdfx video_cards_tga video_cards_trident video_cards_tseng video_cards_v4l video_cards_vesa video_cards_via video_cards_virtualbox video_cards_vmware video_cards_voodoo video_cards_xgi}
     Homepage:            http://www.gentoo.org/
     Description:         Meta package containing deps on all xorg drivers


What do I need to install to have a normal boot, next time I start my PC?
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Apr 15, 2010 11:54 am    Post subject: Reply with quote

Maybe you should try the OpenSource driver : xf86-video-ati.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Thu Apr 15, 2010 12:06 pm    Post subject: Reply with quote

if you don care about 3d then adjust the VIDEO_CARDS var in your make.conf accordingly and the block should disappear.
what card do you have ?

Quote:
What do I need to install to have a normal boot, next time I start my PC?


depens on what you understand for "normal" ;-)
If you are looking for a graphical interface then at least the X stuff and a windows manager or desktop environment you like.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 12:07 pm    Post subject: Reply with quote

I've got it!
Code:
[D] x11-drivers/xf86-video-ati
     Available versions:  6.12.1-r1 6.12.4 ~6.12.4-r1 {debug}
     Installed versions:  6.12.5(11:20:31 03/14/10)(-debug)
     Homepage:            http://xorg.freedesktop.org/
     Description:         ATI video driver


But, I guess I need xorg-server and xorg-drivers installed.
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Thu Apr 15, 2010 12:07 pm    Post subject: Reply with quote

Indeed, can you post this :

Code:

# lspci -n
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 1:09 pm    Post subject: Reply with quote

Code:
localhost drphibes # lspci -n
00:00.0 0600: 1106:0305 (rev 03)
00:01.0 0604: 1106:8305
00:04.0 0601: 1106:0686 (rev 40)
00:04.1 0101: 1106:0571 (rev 06)
00:04.2 0c03: 1106:3038 (rev 16)
00:04.3 0c03: 1106:3038 (rev 16)
00:04.4 0680: 1106:3057 (rev 40)
00:04.5 0401: 1106:3058 (rev 50)
00:0b.0 0200: 10ec:8139 (rev 10)
00:11.0 0180: 105a:0d30 (rev 02)
01:00.0 0300: 1002:5046
Back to top
View user's profile Send private message
rpil
Guru
Guru


Joined: 23 May 2008
Posts: 314

PostPosted: Thu Apr 15, 2010 1:43 pm    Post subject: Reply with quote

SOLVED! I deleted "fglrx" from VIDEO_CARDS in etc/make.conf and it makes a normal emerge now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum