Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
layman -a cwiid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
acomputerdood
n00b
n00b


Joined: 14 May 2006
Posts: 26

PostPosted: Mon Apr 19, 2010 5:09 am    Post subject: layman -a cwiid Reply with quote

so, i'm trying to get cwiid working, and all of the documentation for it points to the layman overlay, which seems to no longer exist. am i missing something?


ALTERNATIVELY, i can't seem to get it installed manually, either. i've gotten as far as:

Code:
./configure --libdir=/usr/lib
make
make install



but then i get:

Code:
poppa-serve abstrakraft-cwiid-3163ded # wminput -d
unable to open uinput



what gives?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9220

PostPosted: Mon Apr 19, 2010 7:45 am    Post subject: Re: layman -a cwiid Reply with quote

acomputerdood wrote:
Code:
poppa-serve abstrakraft-cwiid-3163ded # wminput -d
unable to open uinput



what gives?
Try checking for the existence of and suitable permissions on the device nodes.

Moved from Multimedia to Unsupported Software, as the package is from an unsupported overlay.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5724

PostPosted: Mon Apr 19, 2010 7:47 am    Post subject: Reply with quote

modprobe uinput
Back to top
View user's profile Send private message
acomputerdood
n00b
n00b


Joined: 14 May 2006
Posts: 26

PostPosted: Mon Apr 19, 2010 1:54 pm    Post subject: Re: layman -a cwiid Reply with quote

desultory wrote:
Moved from Multimedia to Unsupported Software, as the package is from an unsupported overlay.


by chance can you tell me which overlay it's from? it's not in layman anymore (unless i'm missing something).
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 9220

PostPosted: Tue Apr 20, 2010 6:18 am    Post subject: Reply with quote

acomputerdood wrote:
by chance can you tell me which overlay it's from?
I know of no such overlay. That it was in an overlay was implied by the title, it not being available through any of the canonical overlays (those listed in layman-global.txt/repositories.xml) implied that you had created at least the metadata entry for the overlay locally.
acomputerdood wrote:
it's not in layman anymore (unless i'm missing something).
Which overlay was it in?
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Apr 20, 2010 2:58 pm    Post subject: Reply with quote

I think you are somewhat confused. Layman isn't an overlay, it's a tool for installing overlays.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4668
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Jul 03, 2010 4:39 pm    Post subject: Reply with quote

to have cwiid overlay active in your layman system, insert this xml-tag in /var/lib/layman/overlays.xml :
Code:

<repo priority="50" quality="experimental">
    <name>cwiid</name>
    <description>Collection of Linux tools written in C for interfacing to the Nintendo Wiimote.</description>
    <homepage>http://abstrakraft.org/cwiid/</homepage>
    <owner>
      <email>cwiid@abstrakraft.org</email>
    </owner>
    <source type="tar">http://abstrakraft.org/cwiid/downloads/cwiid-portage.tgz</source>
  </repo>

and add these lines in make.conf (or in an equivalent place):
Code:

PORTDIR_OVERLAY="
/var/lib/layman/cwiid
$PORTDIR_OVERLAY
"

_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
andorreJr
n00b
n00b


Joined: 05 Nov 2008
Posts: 42
Location: Italy

PostPosted: Tue Nov 23, 2010 9:11 pm    Post subject: Reply with quote

I know this post is half a year old, but maybe this info will be usefull for someone (like me) who still wants to use wiimote on his/her gentoo box :)

Actually package downloaded from abstrakraft.org are still dependant on net-wireless/bluez-libs.

I've found another overlay containing cwiid, you can add it as usual with:
Code:
layman -a pd-overlay


Unfortunately on my machine I was not able to complete the installation due to an error ... but maybe it will work for you. At least it has up to date dependency.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum