Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dbus Fehler beim Anmelden in KDE-4.4.2 seit Update [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Apr 20, 2010 5:58 pm    Post subject: dbus Fehler beim Anmelden in KDE-4.4.2 seit Update [solved] Reply with quote

Hi Mitstreiter,

brauch mal eure Hilfe, denn ich komm hier seit einiger Zeit mit dem ollen Laptop (PIII-500, mit 320MB RAM) für meine Frau nicht weiter.
Hab da zwei verschiedene KDE4 Versionstände drauf, einmal KDE-4.3.5 mit Kernel 2.6.32-r2 auf sda1, was "prima" läuft, und immer erst dann per rsync upgegradet wird, wenn Testversion zwei (auf sda2, mit kernel 2.6.33) zuverlässig upgedated wurde.
Beide Versionen arbeiten mit einer gemeinsamen home-partition auf sda3.

Seit dem update auf KDE Version 4.4.1 hab ich folgendes Problem: Nach dem einloggen per KDM erscheint ein Fehler-Fenster mit folgendem Inhalt:

Code:
Could not start D-Bus. Can you call qdbus?


Damit mach ich schon 'ne ganze Zeit rum, und zwischenzeitlich bin ich bei KDE-4.4.2, xorg-server 1.8, bzw. auf dem aktuellen system/world Stand von Heute angelangt (~x86 arch). Das Problem ist noch das gleiche.

dbus und hal hab ich systemweit noch aktiviert, und ist auch noch im runlevel drin.
Wo kann ich da ansetzten?

Infos hier:

Code:

rc-status
Runlevel: default
 net.eth0                                                                                                                 [  started  ]
 dbus                                                                                                                     [  started  ]
 syslog-ng                                                                                                                [  started  ]
 ntpd                                                                                                                     [  started  ]
 gpm                                                                                                                      [  started  ]
 consolekit                                                                                                               [  started  ]
 hald                                                                                                                     [  started  ]
 sshd                                                                                                                     [  started  ]
 nfs                                                                                                                      [  started  ]
 netmount                                                                                                                 [  started  ]
 xdm                                                                                                                      [  started  ]
 udev-postmount                                                                                                           [  started  ]
 local                                                                                                                    [  started  ]
Dynamic Runlevel: hotplugged
 net.eth0                                                                                                                 [  started  ]
Dynamic Runlevel: needed
 sysfs                                                                                                                    [  started  ]
 udev-mount                                                                                                               [  started  ]
 rpcbind                                                                                                                  [  started  ]
 rpc.statd                                                                                                                [  started  ]
 rpc.idmapd                                                                                                               [  started  ]
 xdm-setup                                                                                                                [  started  ]
Dynamic Runlevel: manual


Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!


Last edited by Randy Andy on Fri Apr 23, 2010 6:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2044
Location: My own world! I and Gentoo!

PostPosted: Tue Apr 20, 2010 6:09 pm    Post subject: Reply with quote

Das Running-system upgraden?
Eigentlich müsste KDE-4.4.2 inzwischen laufen. (Hier gibts keine Probleme).

Allgemein ist es keine allzu gute Idee verschiedene Programmversionen eine Config nutzen zu lassen.

Kommt aber auf die Software drauf an.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Apr 20, 2010 6:40 pm    Post subject: Reply with quote

Hi Max Steel,

nix gemeinsame config (es sei denn du meinst home), sda1 und sda2 sind getrennte systeme mit eigenem bootloader via chainloader.
Hätte den Blödsinn besser nicht geschrieben, verwirrt nur und tut nix zur Sache.

Und KDE 4.4.2 läuft auf meinem x86_64 System auch prima! Nur was nutzt mir das alles?

Also bitte wieder auf das wesentliche konzentrieren, die dbus Fehlermeldung und wie ich dagegen vorgehe.

Dank Euch, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2044
Location: My own world! I and Gentoo!

PostPosted: Tue Apr 20, 2010 7:22 pm    Post subject: Reply with quote

In dem Fall meine ich die home-partition.

Aber um das auszuprobiern kannst ja einfach mal auf dem kde-4.3 System einen testnutzer anlegen.

Ansonsten, steht in einer Log etwas verdächtiges drin?
Also /var/log/messages oder /var/log/Xorg.0.log

Oder sonst etwas?

PS:
Er frägt dich ja ob du qdbus starten kannst, irgendwie. Also mal qdbus(viewer) starten probiern.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Tue Apr 20, 2010 7:43 pm    Post subject: Reply with quote

Kann leider erst Morgen weitermachen,

die Frau hat das Teil nun im Beschlag.

Melde mich dann mit mehr Details.

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Thu Apr 22, 2010 5:17 pm    Post subject: Reply with quote

Hallöle,

hab es zwischenzeitlich mit einem neuen Testaccount ausprobiert, jedoch ohne Erfolg!
Hab ausserdem noch alle dbus und qdbus basierenden Paket remerged, hat auch nix gebracht.
Noch ein bisschen mit der xorg.conf rumgespielt - auch nix.
system und world auf dem aktuellen Stand von Gestern.
revdep-rebuild und lafilefixer --justfixit mehrfach - alles konsistent.


Mir fällt nicht mehr ein, habt ihr noch 'ne Idee?

Hier ein paar logs, die euch vielleicht mehr sagen als mir, denn auch wenn die nicht ganz Fehlerfrei sind, so sehe ich keinen direkten Zusammenhang zu dbus, eher zu evdev input Treibern und fbdv problemen. Aber bisher (bis xorg-server-1.7.6 und kde 4.3.5) lief es doch auch, bzw ne nach bootpartition immer noch?

Ah, was hat es denn damit auf sich?

Code:

qdbus --system
:1.0
 org.freedesktop.ConsoleKit
:1.1
:1.2
 org.freedesktop.Hal
:1.3
:1.4
:1.6
:1.7
org.freedesktop.DBus
mobile log # qdbus
Could not connect to D-Bus server: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.


Hm, aber warum gibt's einen Initialisierungsfehler beim Start von X11,m den graphischen KDM log-in screen hab ich jedenfalls.

Beim booten gibt dbus jedenfalls keine Fehler aus...

:cry: Andy.


Xorg.0.log
http://paste.pocoo.org/show/204968/

dmesg
http://paste.pocoo.org/show/204969/

messages
http://paste.pocoo.org/show/204971/




Dank Euch
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2044
Location: My own world! I and Gentoo!

PostPosted: Thu Apr 22, 2010 5:25 pm    Post subject: Reply with quote

Probier mal ob es funktioniert wenn du einzigst versuchst deine Treibermodule neuzubaun: emerge -a1 $(qlist -IC x11-drivers/)

Ansonsten... Bin ich relativ ratlos. Evtl musst du auch die kdelibs neubaun. Keine Ahnung, ist ein Schuss ins Blaue.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Thu Apr 22, 2010 5:56 pm    Post subject: Reply with quote

Nee, Max Steel,

das hatte ich auch schon ausprobiert, bin schon kurz davor xorg-server mäßig mal downzugraden (ahh, ich liebe diese Wortschöpfungen :roll: )
Andererseits hatte ich das Problem zuvor ja auch schon, bevor es den xorg-server-1.8.0 im tree gab...

Wär klasse wenn's noch ein paar alternative Ideen gäb, schau'mer mal...

Natürlich trotzdem Dank

Gruß, Andy
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Apr 22, 2010 6:45 pm    Post subject: Reply with quote

Hi
schau mal ob dir evtl. https://forums.gentoo.org/viewtopic-p-6247634.html#6247634
weiterhilft
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 23, 2010 8:06 am    Post subject: Reply with quote

Hi Josef,

der Link und somit die Tipps scheinen sich in erster Linie auf ein downgrade von dbus, oder geänderte übernahme der zugehörigen config dateien zu beziehen.

Hab's mal mit einem Downgrade von dbus versucht, und die geänderten configs übernommen.
Nach einem Neustart leider immer noch das gleiche, daher wieder upgegradet, und gleich nochmal gesynced und world upgegradet - wieder nichts.

Un nu? :cry:
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Fri Apr 23, 2010 8:30 am    Post subject: Reply with quote

Hi Andy
Nur ein Verdacht:
Aus deiner X Log
Code:
[    35.527] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
Hast du xorg-server evtl. mit den Use-Flags "udev" und "hal" gebaut?
wenn ja, dann baue xorg-server bitte ohne "hal" Unterstützung
Code:
# echo "x11-base/xorg-server -hal udev" >> /etc/portage/package.use

Siehe auch: http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Fri Apr 23, 2010 8:55 am    Post subject: Reply with quote

Josef.95 wrote:
Hast du xorg-server evtl. mit den Use-Flags "udev" und "hal" gebaut?
wenn ja, dann baue xorg-server bitte ohne "hal" Unterstützung
Code:
# echo "x11-base/xorg-server -hal udev" >> /etc/portage/package.use

Siehe auch: http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml

Das ist eigentlich nicht notwendig, da der xorg-server-1.8.0 ebuild udev den Vorzug gibt, wenn beide Flags aktiviert sind. Man bekommt zwar noch eine Warnung angezeigt beim emergen, aber das hal useflag hat keinerlei Einfluß, wenn das udev useflag ebenfalls gesetzt ist.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Fri Apr 23, 2010 9:00 am    Post subject: Reply with quote

@Polynomial-C
Ah Ok, das war mir so nicht bewusst.
Danke
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 23, 2010 2:04 pm    Post subject: Reply with quote

>> Polynomial-C schrieb
Code:
Das ist eigentlich nicht notwendig, da der xorg-server-1.8.0 ebuild udev den Vorzug gibt, wenn beide Flags aktiviert sind. Man bekommt zwar noch eine Warnung angezeigt beim emergen, aber das hal useflag hat keinerlei Einfluß, wenn das udev useflag ebenfalls gesetzt ist.


Ja, so war auch mein Verständnis, aber davon abgesehen hab ich natürlich xorg-server -hal gebaut da ich es in package.use aufgenommen hatte.

Code:

emerge -pv x11-base/xorg-server
[ebuild   R   ] x11-base/xorg-server-1.8.0  USE="ipv6 nptl udev xorg -dmx -doc -hal -kdrive -minimal -static-libs -tslib" 0 kB


Wenn sonst keine weiteren Vorschläge kommen, wer ich als nächstes mal das downgrade auf xorg-server-1.7.6 versuchen.

Ein bisschen Zeit habt ihr aber noch, werd bei dem schönen Wetter noch ein bisschen raus in den Garten gehen :wink:

Gruß, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 23, 2010 3:15 pm    Post subject: Reply with quote

...schönes Wetter wird ja häufig überbewertet.

Hab während ich draussen 'ne Regenrinne angebracht habe, mal den xorg-server auf Version 1.7.6 downgegradet und das übliche neu gebaut mit:

Code:

pump emerge -DuvaN x11-base/xorg-server && pump emerge -v $(qlist -IC x11-drivers)


Verdammt - ist doch tatsächlich immer noch das gleiche Problem !!!

Was könnte das denn noch sein !?!

Mir fällt nix mehr ein, ich guck jetzt mal auf Bugzilla, und vergleiche mit der laufenden Zweitinstallation auf Unterschiede bzw. weitere möglich Ursachen....
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 23, 2010 6:42 pm    Post subject: Reply with quote

Ich glaub ich werd blond!

Was hab ich nicht in der Zwischenzeit alles neu gebaut,
alle hal pakete, x11-base/xorg-drivers downgrade zu 1.7 gemacht, weil das vorherige System damit noch läuft, alles ohne Erfolg.

Und dann fiel mir folgendes auf:
Das laufende ältere Zweitsystem verwendet sys-apps/dbus-1.3.0-r1, das aktuellere mit dem dbus Startfehler jedoch Version-1.2.24, weil wohl nachträglich Version {M}(~)1.3.0-r1 maskiert wurde! Haha...

Also, mal eben unmasked gesetzt, upgedated, und sieh da, es läuft!!!!!! Jippie

Da ham'se mich aber ganz schön ausgetrickst :wink: Auf dem alten system hab ich den tree nicht mehr gesynced, und da war sie(1.3.0-r1) definitiv nicht maskiert, und meine package.mask ist dort auch leer!
Da soll mal einer drauf kommen!

Naja, nun wisst ihr bescheid. Nu mach ich erst mal ein Backup, bevor ich mich wieder ans updaten begebe, dann läufts bestimmt auch mit xorg-server-1.8.0.
Schau'mer mal, jedenfalls makiere ich den Fall als gelöst.

Dank an alle Helfer, bis zum nächsten mal....

Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Fri Apr 23, 2010 7:37 pm    Post subject: Reply with quote

Gratuliere :wink:

Es ist doch aber schon ne ganze zeit her das dbus-1.3.0-r1 hart maskiert wurde, auch ich hab hier das downgrade auf
Code:
# eix -e dbus
[I] sys-apps/dbus
     Available versions:  1.2.3-r1 1.2.24 [M](~)1.3.0-r1 {X debug doc selinux test}
     Installed versions:  1.2.24(11:44:47 PM 04/04/2010)(X -debug -doc -selinux -test)
     Homepage:            http://dbus.freedesktop.org/
     Description:         A message bus system, a simple way for applications to talk to each other
gemacht, hier funkt aber nach wie vor alles problemlos..
(ist ein ~amd64 System)
Nungut, ich würde dem aber noch mal nachgehen...
Code:
$ emerge -pv =sys-apps/dbus-1.3.0-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=sys-apps/dbus-1.3.0-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/dbus-1.3.0-r1 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Steev Klimaszewski <steev@gentoo.org> (04 Apr 2010)
# Mask dbus-1.3.0 because it is the development version.
# Please use 1.2.24, if you think you need something from 1.3.0

Besonders die Config Files würde ich noch mal nachprüfen
Code:
$ qlist dbus | grep /etc
/etc/X11/xinit/xinitrc.d/30-dbus
/etc/init.d/dbus
/etc/dbus-1/session.d/.keep_sys-apps_dbus-0
/etc/dbus-1/system.conf
/etc/dbus-1/system.d/.keep_sys-apps_dbus-0
/etc/dbus-1/session.conf

Viel Erfolg
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Apr 23, 2010 8:04 pm    Post subject: Reply with quote

Ja Josef,

mach ich wenn wieder ich wieder Zeit habe.

Hier auf meinem 64bit system läuft's ja auch prima mit:
Code:

sys-apps/dbus
     Available versions:  1.2.3-r1 1.2.3-r1[2] 1.2.3-r2[7] (~)1.2.12[2] 1.2.24 [M](~)1.3.0[2] [M](~)1.3.0[5] [M](~)1.3.0-r1 [M](~)1.3.0-r1[2] [M]**9999[2] {X debug doc lib32 selinux test}
     Installed versions:  1.2.24(17:13:28 08.04.2010)(X -debug -doc -selinux -test)
     Homepage:            http://dbus.freedesktop.org/
     Description:         A message bus system, a simple way for applications to talk to each other


Vielleicht finde ich ja eine noch unbekannte regression...

Schönen Abend noch, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1423
Location: germany

PostPosted: Sat Apr 24, 2010 10:22 am    Post subject: Reply with quote

Randy Andy wrote:
Und dann fiel mir folgendes auf:
Das laufende ältere Zweitsystem verwendet sys-apps/dbus-1.3.0-r1, das aktuellere mit dem dbus Startfehler jedoch Version-1.2.24, weil wohl nachträglich Version {M}(~)1.3.0-r1 maskiert wurde! Haha...

Also, mal eben unmasked gesetzt, upgedated, und sieh da, es läuft!!!!!! Jippie

Natürlich freut es mich, daß dein DBus Problem behoben zu sein scheint. Trotzdem möchte ich dir noch einmal nahe legen, daß =sys-apps/dbus-1.3* nicht ohne Grund maskiert wurde. Es handelt sich um den Entwicklungszweig und läuft nicht ganz so reibungslos, wie der momentan als stabil angesehene 1.2.x Zweig. Bei mir gab es zum Beispiel den umgekehrten Effekt wie bei dir. Nach dem Update auf dbus-1.3.0 konnte ich keinerlei kde-Programme mehr über eine ssh-Verbindung aufrufen. Es kam immer nur die lapidare Meldung, daß es ein dbus-Session Problem gäbe. Andere Programme konnten erst gar keine dbus-Session mehr finden, selbst nach Neukompilierung des betroffenen Pakets.
Falls du also Zeit und Lust hast, empfehle ich dir, mal die Ursache zu suchen, warum deine KDE-Installation dbus-1.2* nicht mag und falls du fündig wirst und die Ursache beheben kannst, auf dbus-1.2.x umzustellen.
_________________
The manual said "Requires Windows10 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum