Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Umlaute zwischen tty und X nicht die gleichen (gelöst)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Tue Apr 20, 2010 4:55 pm    Post subject: Umlaute zwischen tty und X nicht die gleichen (gelöst) Reply with quote

Hallo, ich habe unterschiedliche deutsche Umlaute zwischen der tty Konsole und den X-Anwendungen. UTF-8 will ich nicht wegen einiger Anwendungen.

Also dies sind meine momentanen Einstellungen:
/etc/env.d/02locale
Code:
LC_ALL="de_DE@euro"
LANG="de_DE@euro"

/etc/conf.d/keymaps
Code:
KEYMAP="de-latin1-nodeadkeys"
DUMPKEYS_CHARSET="iso-8859-15"

/etc/X11/xorg.conf
Code:

    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "de"
    Option         "XkbVariant" "nodeadkeys"

/etc/rc.conf
Code:
UNICODE="no"

/etc/conf.d/consolefont
Code:
CONSOLEFONT="lat9w-16"


Ist es etwa von Nöten in der fstab eine locale für meine Dateisysteme anzugeben? All die Jahre war ich ohne ausgekommen.

[Edit]
Ich mußte Heute von xorg-x11-7.4-r1 zurück auf 7.2 gehen weil 7.4 ohne Fehlermeldung sich einfach selbst wieder entladen hatte.
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748


Last edited by UTgamer on Thu Apr 22, 2010 2:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Thu Apr 22, 2010 11:08 am    Post subject: Reply with quote

Niemand eine Idee wie ich den gleichen Zeichensatz auf Konsole und X bekomme?

Also ein Dateiname wie Köln auf der Konsole angelegt ergibt unter X Köln
und ein ö unter X angelegt ergibt auf der Konsole ein invertes Fragezeichen. Es ist also unmöglich auf die Datei-/Ordnernamen zuzugreifen.

Wie bekomme ich heraus welcher von beiden der eigentlich falsche Codec ist?
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Thu Apr 22, 2010 1:56 pm    Post subject: Reply with quote

UTgamer wrote:
UTF-8 will ich nicht wegen einiger Anwendungen.
BTW:
Hm..., ich würde doch noch mal drüber nachdenken, UTF-8 ist doch mittlerweile (erwarteter) Standard...
siehe zb in der news Meldung (hier für Python 3.1) von Gentoo
Quote:
It is recommended to use a UTF-8 locale to avoid potential problems. Especially
C and POSIX locales are discouraged. If locale has not been explicitly set,
then POSIX locale is used, so you should ensure that locale has been set.
Back to top
View user's profile Send private message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Thu Apr 22, 2010 2:19 pm    Post subject: Reply with quote

Dank dir Josef das war die Lösung.
X lief die ganze Zeit bereits auf UTF-8, ich mußte nur in der rc.conf Unicode = "yes" setzen damit habe ich auch keine Probleme mit meinen alten X Programmen, die ich vor ein paar Jahren mal hatte. Ich hatte immer im Gedächtniss das meine alten X-Programme nicht mit Unicode liefen, obwohl sie es seit einiger Zeit unbemerkt problemlos taten.
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum