Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[AlpsPS/2 ALPS GlidePoint] Kein Scrollen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Apr 25, 2010 11:46 am    Post subject: [AlpsPS/2 ALPS GlidePoint] Kein Scrollen Reply with quote

Hi,

bei meinem neuen Laptop ist leider viel Arbeit...
Ich nutze den stabilen Zweig, aber mit KDE 4.2.

Das AlpsPS/2 ALPS GlidePoint Touchpad wird erkannt, ich kann auch viel in den Systemsettings einstellen, aber dann kommt die Fehlermeldung, dass das Touchpad nicht konfiguriert werden kann.
Ich habe jetzt mal auf xorg-server-1.8, synaptiks-9999 upgedatet.

$xinput list|grep Alp
â â³ AlpsPS/2 ALPS GlidePoint id=12 [slave pointer (2)]

Code:
$xinput list 12
AlpsPS/2 ALPS GlidePoint                        id=12   [slave  pointer  (2)]
        Reporting 4 classes:
                Class originated from: 12
                Buttons supported: 5
                Button labels: Button Left Button Middle Button Right Button Wheel Up Button Wheel Down
                Button state:
                Class originated from: 12
                Detail for Valuator 0:
                  Label: Abs X
                  Range: 0.000000 - 1023.000000
                  Resolution: 10000 units/m
                  Mode: absolute
                  Current value: 960.000000
                Class originated from: 12
                Detail for Valuator 1:
                  Label: Abs Y
                  Range: 0.000000 - 767.000000
                  Resolution: 10000 units/m
                  Mode: absolute
                  Current value: 540.000000
                Class originated from: 12
                Detail for Valuator 2:
                  Label: Abs Pressure
                  Range: 0.000000 - 127.000000
                  Resolution: 10000 units/m
                  Mode: absolute
                  Current value: 0.000000


Ich weiß leider nicht, was ich noch machen kann.

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Evildad
Guru
Guru


Joined: 15 Apr 2004
Posts: 475

PostPosted: Sun Apr 25, 2010 3:26 pm    Post subject: Reply with quote

Hast du ein System mit hal?
Falls nicht hätte ich eine Config von meinem Dell Laptop...
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun Apr 25, 2010 5:12 pm    Post subject: Reply with quote

Evildad wrote:
Hast du ein System mit hal?
Falls nicht hätte ich eine Config von meinem Dell Laptop...


Ja, hal nutze ich.

Die Config nehme ich gerne.
Testen kann man es ja mal damit

Danke
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ichbins
n00b
n00b


Joined: 25 Mar 2008
Posts: 40

PostPosted: Mon Apr 26, 2010 12:17 pm    Post subject: Reply with quote

du musst wahrscheinlich wieder xorg.conf bzw xorg.conf.d/ einträge erstellen, da xorg-server-1.8 hal nichtmehr verwendet.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Apr 27, 2010 6:07 am    Post subject: Reply with quote

Habe ich auch nichts dagegen, hauptsache, ich kann das Touchpad richtig nutzen.
@Evildad: Kannst du bitte die Datei posten?

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Evildad
Guru
Guru


Joined: 15 Apr 2004
Posts: 475

PostPosted: Tue Apr 27, 2010 7:09 am    Post subject: Reply with quote

Hi,

anbei meine Config. Scrollen ist möglich und wenn du unten rechts aufs Touchpad klickst ist es ein mittlerer Mausklick.

Code:
AlpsPS/2 ALPS DualPoint TouchPad


Installiert ist:

Code:

x11-drivers/xf86-input-synaptics-1.2.1
x11-base/xorg-server-1.7.6


Code:

   Identifier  "Touchpad"
   Driver  "synaptics"
   Option  "Device"   "/dev/input/mouse0"
   Option  "Protocol"   "auto-dev"
   Option  "LeftEdge"   "130"
   Option  "RightEdge"   "915"
   Option  "TopEdge"   "130"
   Option  "BottomEdge"   "640"
   Option  "FingerLow"   "25"
   Option  "FingerHigh"   "30"
   Option  "MaxTapTime"   "180"
   Option  "MaxTapMove"   "110"
   Option  "VertScrollDelta"   "20"
   Option  "HorizScrollDelta"   "20"
   Option  "MinSpeed"   "0.52"
   Option  "MaxSpeed"   "1.8"
   Option  "AccelFactor"   "0.0010"
   Option  "EdgeMotionMinSpeed"   "200"
   Option  "EdgeMotionMaxSpeed"   "200"
   Option  "UpDownScrolling"   "1"
   Option  "CircularScrolling"   "1"
   Option  "CircScrollDelta"   "0.1"
   Option  "CircScrollTrigger"   "2"
   Option  "SHMConfig"   "on"
   Option "TapButton1" "1"
   Option "RBCornerButton" "2"
   Option "RTCornerButton" "4"
   Option "VertEdgeScroll" "true"       
   Option "HorizEdgeScroll" "true"       
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Tue Apr 27, 2010 7:28 am    Post subject: Reply with quote

Hmm.
Könntest du mir die ganze Xorg.con mal posten?

Irgendwie will es bei mir immer noch nicht.

Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Evildad
Guru
Guru


Joined: 15 Apr 2004
Posts: 475

PostPosted: Tue Apr 27, 2010 6:41 pm    Post subject: Reply with quote

Hi,

hier findeste meine Config.
Back to top
View user's profile Send private message
Evildad
Guru
Guru


Joined: 15 Apr 2004
Posts: 475

PostPosted: Sat May 01, 2010 7:47 pm    Post subject: Reply with quote

Und klappt es mit dem scrollen?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Sun May 02, 2010 8:21 am    Post subject: Reply with quote

Evildad wrote:
Und klappt es mit dem scrollen?


Habe es eben erst gesehen und gleich getestet.
Aber es will immer noch nicht :/

Ich weiß nicht mehr weiter, es kommt ja noch nichtmal eine Fehlermeldung.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Sun May 02, 2010 10:41 am    Post subject: Reply with quote

Hi,

bei mir ging das Scrollen mit der Maus auch nicht.
Allerdings funktionierte bei mir die Maus unter xorg.
Ich habe erst versucht per copy & past die Zeilen zu kopieren.
Allerdings funktionierte meine Maus dann nicht.
Danach habe ich nur die Zeilen kopiert die mit dem Scrollen zu tun haben.
Jetzt funktioniert alles. Wenn die Maus garnicht funktioniert, solltest du mal in der xorg.log
schauen, einfach mal nach (EE) suchen und diese mal posten.

Gruss Joerg
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon May 03, 2010 5:10 am    Post subject: Reply with quote

Es geht um das Touchpad, aber der Tip mit EE war gut:

(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(II) Synaptics touchpad driver version 1.2.1
(**) Option "Device" "/dev/input/event7"
(**) Option "VertEdgeScroll" "true"
(**) Option "HorizEdgeScroll" "true"
(**) Option "TapButton1" "1"
(**) Option "TapButton2" "2"
(**) Option "TapButton3" "3"
(**) Option "CoastingSpeed" "20"
(--) AlpsPS/2 ALPS GlidePoint: no supported touchpad found
(EE) AlpsPS/2 ALPS GlidePoint Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "AlpsPS/2 ALPS GlidePoint"
(II) UnloadModule: "synaptics"
(EE) config/hal: NewInputDeviceRequest failed (8)

Ich schaue mal, ob es eine neuere Version der Treiber gibt.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
JoHo42
l33t
l33t


Joined: 14 Feb 2004
Posts: 944
Location: Germany

PostPosted: Mon May 03, 2010 6:02 am    Post subject: Reply with quote

Hi Finswimmer,

vielleicht ist dein /dev/input/event7 falsch.
Ich habe das bei mir auf /dev/input/misc stehen,
versuche es doch mal nur mit den Zeilen:

Driver "synaptics"
Option "Device" "/dev/input/mouse0"
# Option "Device" "/dev/input/misc"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"

So solltest du erstmal ein Maus haben die du ueber den Bildschirm schieben kannst.
Auch mal die Option "Device" umstellen.

Gruss Joerg
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Mon May 03, 2010 6:10 am    Post subject: Reply with quote

JoHo42 wrote:
Hi Finswimmer,

vielleicht ist dein /dev/input/event7 falsch.
Ich habe das bei mir auf /dev/input/misc stehen,
versuche es doch mal nur mit den Zeilen:

Driver "synaptics"
Option "Device" "/dev/input/mouse0"
# Option "Device" "/dev/input/misc"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"

So solltest du erstmal ein Maus haben die du ueber den Bildschirm schieben kannst.
Auch mal die Option "Device" umstellen.

Gruss Joerg


Die Maus konnte ich schon immer bewegen, nur scrollen geht nicht.
Auch nicht mit deinen Code-Zeilen. Es kommt immer noch die Meldung "AlpsPS/2 ALPS GlidePoint: no supported touchpad found "

Ich habe bei x.org einen Bugreport ausgefüllt.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum