Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Compiz start & logout problem - GNOME [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Mon Apr 26, 2010 8:35 am    Post subject: Compiz start & logout problem - GNOME [SOLVED] Reply with quote

hi there.
I am trying to set compiz-fusion. I have it installed, but not emerald.
If I start compiz-manager from a terminal or a startup script, it comes up fine, so it seems to be complete.
The problems are these:
1. If I start compiz-manager from a startup script (with --replace and the necessary INTEL GMA options as per Wiki) and I want to log out, it seems that the WM restarts once, and after that I can log only. I see eg. Wicd applet appearing twice on the panel, and no logout happens only on the second attempt.

2. I do not want to start metacity but compiz from editing gconf. Any entry in WINDOWMANAGER in session ends up WO decoration. (Any means :compiz or compiz manager). The double logout problem is not effected, so I have to log out twice.

Any idea?

(Install fresh, W/o problem.)
_________________
Quis custodiet ipsos, custodes?


Last edited by salmonix on Wed Apr 28, 2010 8:30 am; edited 1 time in total
Back to top
View user's profile Send private message
Raphux
n00b
n00b


Joined: 11 Sep 2004
Posts: 41
Location: Paris

PostPosted: Tue Apr 27, 2010 8:37 pm    Post subject: Reply with quote

Had exactly the same problem here. I put an "compiz in gconf in «/desktop/gnome/session/required_components/windowmanager», but I then didn't have any window decoration.

Had to re-emerge compiz with the +emerald useflag. It works fine now.
Back to top
View user's profile Send private message
salmonix
Guru
Guru


Joined: 16 Jul 2006
Posts: 410

PostPosted: Wed Apr 28, 2010 8:29 am    Post subject: Reply with quote

Raphux wrote:
Had exactly the same problem here. I put an "compiz in gconf in «/desktop/gnome/session/required_components/windowmanager», but I then didn't have any window decoration.

Had to re-emerge compiz with the +emerald useflag. It works fine now.


Thanx.
The first problem was my fault (double logging).
_________________
Quis custodiet ipsos, custodes?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum