Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amarok-1.4
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Tue Apr 27, 2010 7:12 am    Post subject: amarok-1.4 Reply with quote

So I was reading the amarok wiki trying to install the old version, can't stand the new one; turning into I-tunes. I emerged the kde-sunset overlay using layman, no problem there. After that the wiki says to do:

Code:
emerge -av amarok:3.5


Which I did, I've also tried:

Code:
=media-sound/amarok-1.4


Code:
media-sound/amarok-1.4.10_p20090130-r3


Still can't find the package in the tree, do I need to deactivate or activate certian use flags or keywords in order to use it first, the kde-3 section in th gentoo kde was pretty vague about this. Thanx in advance!

Paradox(>")>

Emerge --info:

Code:
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.3, glibc-2.11.1-r0, 2.6.33-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.0.1
Timestamp of tree: Tue, 27 Apr 2010 06:00:01 +0000
app-shells/bash:     4.1_p5
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.6.5-r1, 3.1.2-r2
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 sun-bcla-java-vm"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-msse3 -march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-msse3 -march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/desktop-effects /usr/local/portage/layman/kde-testing /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/kde-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 avi berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread emboss encode exif extras fam fbcondecor firefox flac fortran gcc gdbm gif glib glitz gpm hal iconv ipv6 java java6 jpeg kde kde4 kdm lcms ldap libnotify mad midi mikmod mmx mng modules mozilla mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntfs nvidia ogg opengl openmp oss pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sasl sdl semantic-desktop session spell spl sql sse sse2 ssl startup-notification suid svg symlink sysfs tcpd tiff truetype udev unicode usb utempter vfat vorbis webkit wmv x264 xcb xcomposite xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" NETBEANS_MODULES="*" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri Apr 30, 2010 11:45 am    Post subject: Reply with quote

/etc/portage/package.mask:
media-sound/amarok:4

should do what you want.
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Mon May 03, 2010 6:08 am    Post subject: Reply with quote

Eventually found that layman has changed dir while I was away, updating my make.conf has fixed this problem!

I'm having problems emerging amarok-1.4 as it fails with this error:

Code:

x86_64-pc-linux-gnu-g++: ./.libs/libamarok.so: No such file or directory
make[4]: *** [amarokapp] Error 1
make[4]: Leaving directory `/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10/amarok/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10/amarok/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10/amarok'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10'
make: *** [all] Error 2
 * ERROR: media-sound/amarok-1.4.10_p20090130-r3 failed:
 *   died running emake, kde_src_compile:make
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 4798:  Called kde_src_compile
 *   environment, line 3509:  Called kde_src_compile 'all'
 *   environment, line 3524:  Called kde_src_compile 'make'
 *   environment, line 3516:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *
 * If you need support, post the output of 'emerge --info =media-sound/amarok-1.4.10_p20090130-r3',
 * the complete build log and the output of 'emerge -pqv =media-sound/amarok-1.4.10_p20090130-r3'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/kde-sunset/eclass/kde.eclass
 *   /var/lib/layman/kde-sunset/eclass/kde-functions.eclass
 *   /var/lib/layman/kde-sunset/eclass/qt3.eclass
 * This ebuild is from an overlay named 'kde-sunset': '/var/lib/layman/kde-sunset/'
 * The complete build log is located at '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/temp/environment'.
 * S: '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10'

>>> Failed to emerge media-sound/amarok-1.4.10_p20090130-r3, Log file:

>>>  '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/temp/build.log'

 * Messages for package media-sound/amarok-1.4.10_p20090130-r3:

 * ERROR: media-sound/amarok-1.4.10_p20090130-r3 failed:
 *   died running emake, kde_src_compile:make
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_compile
 *   environment, line 4798:  Called kde_src_compile
 *   environment, line 3509:  Called kde_src_compile 'all'
 *   environment, line 3524:  Called kde_src_compile 'make'
 *   environment, line 3516:  Called die
 * The specific snippet of code:
 *                   emake || die "died running emake, $FUNCNAME:make"
 *
 * If you need support, post the output of 'emerge --info =media-sound/amarok-1.4.10_p20090130-r3',
 * the complete build log and the output of 'emerge -pqv =media-sound/amarok-1.4.10_p20090130-r3'.
 * This ebuild used the following eclasses from overlays:
 *   /var/lib/layman/kde-sunset/eclass/kde.eclass
 *   /var/lib/layman/kde-sunset/eclass/kde-functions.eclass
 *   /var/lib/layman/kde-sunset/eclass/qt3.eclass
 * This ebuild is from an overlay named 'kde-sunset': '/var/lib/layman/kde-sunset/'
 * The complete build log is located at '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/temp/environment'.
 * S: '/var/tmp/portage/media-sound/amarok-1.4.10_p20090130-r3/work/amarok-1.4.10'


emerge --info:

Code:
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.3, glibc-2.11.1-r0, 2.6.33-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5600+-with-gentoo-2.0.1
Timestamp of tree: Mon, 03 May 2010 06:30:01 +0000
app-shells/bash:     4.1_p5
dev-java/java-config: 1.3.7-r1, 2.1.10
dev-lang/python:     2.6.5-r1, 3.1.2-r2
dev-util/cmake:      2.8.1-r1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-eula dlj-1.1 sun-bcla-java-vm"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-msse3 -march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-msse3 -march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset /var/lib/layman"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 avi berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread emboss encode exif extras fam fbcondecor firefox flac fortran gcc gdbm gif glib glitz gpm hal iconv ipv6 java java6 jpeg kde kde4 kdm lcms ldap libnotify mad midi mikmod mmx mng modules mozilla mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntfs nvidia ogg opengl openmp oss pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sasl sdl semantic-desktop session spell spl sql sse sse2 ssl startup-notification suid svg symlink sysfs tcpd tiff truetype udev unicode usb utempter vfat vorbis webkit wmv x264 xcb xcomposite xine xml xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" NETBEANS_MODULES="*" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Fri May 07, 2010 9:21 pm    Post subject: Reply with quote

Man anyone can help me out on this, I've looked all over the Internet for a solution but haven't found anything, if this was another app I wouldn't care and would just emerge the newer version. I hate Amarok 2 tho, and Amarok 1 is one of my favorite apps; Amarok 2 is becoming too much like crap-tunes or windows crap player, so any help would be greatly appreciated.
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Fri May 07, 2010 10:21 pm    Post subject: Reply with quote

Hmm, this error message doesn't say much about the cause of the problem. And I have nearly the same configuration like you (Athlon X2 6000, gcc-4.4). In my case amarok compiled without any problems. My installed kde3-packages:

Code:
 qlist kde-base -ICv | grep 3.5
kde-base/kcminit-3.5.10
kde-base/kcontrol-3.5.10-r1
kde-base/kde-i18n-3.5.10
kde-base/kdebase-data-3.5.10-r1
kde-base/kdebase-kioslaves-3.5.10-r2
kde-base/kdelibs-3.5.10-r8
kde-base/kdemultimedia-kioslaves-3.5.10
kde-base/kdeprint-3.5.10
kde-base/kdesdk-kioslaves-3.5.10
kde-base/kdesu-3.5.10
kde-base/kdialog-3.5.10
kde-base/kfind-3.5.10
kde-base/kghostview-3.5.10
kde-base/khelpcenter-3.5.10
kde-base/khexedit-3.5.10
kde-base/khotkeys-3.5.10
kde-base/kicker-3.5.10-r3
kde-base/kmenuedit-3.5.10
kde-base/konqueror-3.5.10
kde-base/kwin-3.5.10-r1
kde-base/libkcddb-3.5.10
kde-base/libkonq-3.5.10
kde-base/quanta-3.5.10-r1


Beside Amarok I have the problem, that k3b:4 doesn't recognize any drive without hal. And hal I've banned since a few years already. And the third app I was using a lot is Quanta. So decide what libs of the listed ones do you need.

Another thing I've recognized is the incompatibility between Amarok-2 and Amarok-1.4. Means if you install Amarok-2 you can break your Amarok-1.4 installation.

My advice:
First try the consistency stuff:
Code:
revdep-rebuild
lafilefixer --justfixit
emerge -p --depclean

If you don't get shown any errors, post the compile errors including a few lines above.
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Fri May 07, 2010 11:03 pm    Post subject: Reply with quote

Here's the entire log of the error, just so I don't post what is not relevant:

http://paste.pocoo.org/show/211357/

I also wanted to know if I can make --depclean not search for certain packages like kdelibs-3.5 or any other dependent package like ones for amarok.

P.S. I did try the fixes that you posted: revdep-rebuild, emerge --depclean, and libfixit, but none worked.

EDIT: I found Songbird which will work in the meantime until Clementine-player is more stable, thx for the help tho!

Thanx Paradox(>")>
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3254
Location: de

PostPosted: Sat May 08, 2010 5:37 pm    Post subject: Reply with quote

Ok, I'll check your build.log later.

"emerge -p --depclean" should show you if there are any dependencies missing. Sometimes this helps to find broken packages additionally to "revdep-rebuild". "lafilefixer" fixes the la-files, that sometimes have wrong paths in references.

What didn't work exactly?
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Mon May 10, 2010 5:29 am    Post subject: Reply with quote

musv wrote:
Ok, I'll check your build.log later.

"emerge -p --depclean" should show you if there are any dependencies missing. Sometimes this helps to find broken packages additionally to "revdep-rebuild". "lafilefixer" fixes the la-files, that sometimes have wrong paths in references.

What didn't work exactly?


Well ya I know what they all do, I was just saying that running those programs didn't fix the portage fail problem. I emerged amarok-1.4 again and it still failed at the same point.
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
LordLethis
n00b
n00b


Joined: 10 Sep 2006
Posts: 4

PostPosted: Fri May 14, 2010 10:10 am    Post subject: Reply with quote

Should anyone else, like me, stumble upon this thread while searching for a solution to the same problem:

I was able to resolve it by temporarily emerging a version autoconf <2.64. Amarok 1.4 from kde-sunset then built just fine :-)

EDIT: I wrote "autotools" instead of "autoconf" :oops:


Last edited by LordLethis on Sat May 22, 2010 5:50 pm; edited 1 time in total
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Fri May 14, 2010 11:33 am    Post subject: Reply with quote

Why not use clementine?

# emerge -pv clementine
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Tue May 18, 2010 4:05 am    Post subject: Reply with quote

ssuominen wrote:
Why not use clementine?

# emerge -pv clementine


I was thinking about doing that, because it was built like Amarok 1, but from my reading, it seemed that it was very unstable. If anyone has used it before and can shed some light on this, that would be great, I'll try getting an earlier version of auto-tools as well.
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
LordLethis
n00b
n00b


Joined: 10 Sep 2006
Posts: 4

PostPosted: Tue May 18, 2010 7:51 am    Post subject: Reply with quote

ssuominen wrote:
Why not use clementine?


I usually have my whole collection as a playlist, and then type in some filter to get a subset that reflects the music I wish to listen to.

Clementine does currently not provide a means to do such filtering (though it should be supported at some point, according to their bug tracker), and lacks a comfortable way to load the whole collection, too.

Clementine is still young, and it is very promising, but right now, amarok 1.4 caters my needs better than anything else I've tried so far. :-)
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Wed May 19, 2010 10:27 pm    Post subject: Reply with quote

LordLethis wrote:
ssuominen wrote:
Why not use clementine?


I usually have my whole collection as a playlist, and then type in some filter to get a subset that reflects the music I wish to listen to.

Clementine does currently not provide a means to do such filtering (though it should be supported at some point, according to their bug tracker), and lacks a comfortable way to load the whole collection, too.

Clementine is still young, and it is very promising, but right now, amarok 1.4 caters my needs better than anything else I've tried so far. :-)


Agreed, but I will use Clementine some day when it is more stable! :)
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
Gankfest
l33t
l33t


Joined: 01 Aug 2007
Posts: 946
Location: Miami Beach, FL

PostPosted: Wed May 19, 2010 11:52 pm    Post subject: Reply with quote

LordLethis wrote:
Should anyone else, like me, stumble upon this thread while searching for a solution to the same problem:

I was able to resolve it by temporarily emerging a version of autotools <2.64. Amarok 1.4 from kde-sunset then built just fine :-)


Well since there isn't an autotools-2.64, I figured you meant autoconf-2.64, which didn't fix the problem. Seriously how do I fix this. It's the only unsupported app I want to use or will ever use, so some help would be fantastic, because Amarok 2 sucks and I refuse to use it. So seriously help me out!

Thanx
_________________
Gankfest™ (>")> ~*

Everyone has to start somewhere, it depends on where you end up that counts! (>")>
Back to top
View user's profile Send private message
LordLethis
n00b
n00b


Joined: 10 Sep 2006
Posts: 4

PostPosted: Sat May 22, 2010 5:47 pm    Post subject: Reply with quote

Yes, I actually did mean autoconf :oops:

However, I did write <2.64, meaning a version prior to 2.64 - 2.63-r1 for instance (which is what worked for me :) )
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Fri Jun 04, 2010 9:22 am    Post subject: Reply with quote

Thanks for posting this. I can confirm this fixed my issue as well; I was on autoconf-2.65 and downgraded to autoconf-2.63-r1 for the build to work. Does anyone know what changes are necessary for Amarok 1.4 to build with the newer versions of autoconf?

On a side note, I needed to add "#include <cstring>" to mp4properties.cpp & taglib_mp4filetyperesolver.cpp in order to compile with GCC 4.4.3.

Regarding Clementine, it's a good start, but definitely not there yet. It does at least look a lot better than Amarok 2 to me. Some significant features from Amarok 1.4 which it's missing are:
1. Being able to queue tracks
2. Being able to use an external DB
3. Wikipedia
4. Lyrics
5. DBUS

I find it sad how far Amarok has slid. Amarok 1.x use to be the app that I'd showcase Linux with; most folks who saw it were blown away. Amarok 2 on the other hand is only recently becoming feature comparable, and I find it ugly and buggy. I gave every major iteration of it a try, but I keep going back to Amarok 1.4.10.
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Sat Jun 05, 2010 7:29 pm    Post subject: Reply with quote

The offending code which has been breaking autoconf-2.64+ is:
--- amarok-1.4.10/admin/configure.in.min
+++ amarok-1.4.10/admin/configure.in.min
@@ -43,6 +43,11 @@ KDE_SET_PREFIX
dnl generate the config header
AM_CONFIG_HEADER(config.h) dnl at the distribution this done

+AC_PROG_CC
+AC_PROG_CXX
+AC_EXEEXT
+AC_OBJEXT
+
dnl Checks for programs.
AC_CHECK_COMPILERS
AC_ENABLE_SHARED(yes)

Based on http://sisyphus.ru:1080/en/srpm/Sisyphus/amarok/patches/0

How do I get this into kde-sunset?
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Sat Jun 05, 2010 8:01 pm    Post subject: Reply with quote

SDNick484 wrote:
The offending code which has been breaking autoconf-2.64+ is:
--- amarok-1.4.10/admin/configure.in.min
+++ amarok-1.4.10/admin/configure.in.min
@@ -43,6 +43,11 @@ KDE_SET_PREFIX
dnl generate the config header
AM_CONFIG_HEADER(config.h) dnl at the distribution this done

+AC_PROG_CC
+AC_PROG_CXX
+AC_EXEEXT
+AC_OBJEXT
+
dnl Checks for programs.
AC_CHECK_COMPILERS
AC_ENABLE_SHARED(yes)

Based on http://sisyphus.ru:1080/en/srpm/Sisyphus/amarok/patches/0

How do I get this into kde-sunset?


Use the gentoo-desktop mailinglist[1] to report kde-sunset issues.

[1] http://www.gentoo.org/main/en/lists.xml
Back to top
View user's profile Send private message
SDNick484
Apprentice
Apprentice


Joined: 05 Dec 2005
Posts: 212

PostPosted: Sat Jun 05, 2010 10:25 pm    Post subject: Reply with quote

ssuominen wrote:


Use the gentoo-desktop mailinglist[1] to report kde-sunset issues.

[1] http://www.gentoo.org/main/en/lists.xml


Ok, cool, I did see the, "owner" listed as gentoo-desktop+subscribe@lists.gentoo.org on the KDE Sunset GIT site, but I wasn't sure if overlay issues for stuff outside of the main portage tree should go to that address.

Thanks,
Nick
Back to top
View user's profile Send private message
Nicias
Guru
Guru


Joined: 06 Dec 2005
Posts: 444

PostPosted: Mon Jun 21, 2010 3:46 pm    Post subject: Reply with quote

same problem, emerging the lower autoconf fixed it.
Back to top
View user's profile Send private message
theotherjoe
Guru
Guru


Joined: 22 Nov 2003
Posts: 368

PostPosted: Sat Jun 26, 2010 4:34 pm    Post subject: Reply with quote

just another confirmation, downgrading to autoconf-2.63-r1 fixed
the problem with missing libamarok.so and installs properly.
Back to top
View user's profile Send private message
serghei
n00b
n00b


Joined: 26 Jun 2010
Posts: 3

PostPosted: Sat Jun 26, 2010 9:28 pm    Post subject: Reply with quote

The patch for >=autoconf-2.65 was added to kde-sunset overlay
Back to top
View user's profile Send private message
theotherjoe
Guru
Guru


Joined: 22 Nov 2003
Posts: 368

PostPosted: Sun Jun 27, 2010 7:16 am    Post subject: Reply with quote

thanks for the message serghei.
synced kde-sunset, re-installed autoconf-2.65-r1
and rebuild amarok-1.4_p20090130-r4
compiles, links and installs properly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum