Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Tastaturprobleme nach xorg update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sat May 01, 2010 10:47 am    Post subject: [solved] Tastaturprobleme nach xorg update Reply with quote

Seit dem letzten Update von Xorg (1.7.6) habe ich Probleme mit meiner Tastatur und meiner Maus.

Ich habe Probleme Sonderzeichen zu setzen oder die PgUp Taste zu benutzen.
Wenn ich z.b. "Alt Gr" drücke um das '@' zu erzeugen, wird ein <enter> in das aktive Fenster eingefügt bevor ich irgend etwas anderes machen kann. Oder bei der PgUp Taste wird ein '/' an der Cursorstelle eingefügt bevor das PgUp tatsächlich ausgeführt wird. Extrem nervig!

Außerdem ist meine Maus schneller als zuvor und ich kann sie in KDE nicht mehr langsamer einstellen. Hart an der Grenze dessen was zuvor als bequem für mich galt. Gerade noch akzeptabel - aber kann nicht normal sein, da ich schon ein User bin der die Maus relativ schnell eingestellt hat. Manch andere Anwender wären hiermit total überfordert...

Ich frage mich wieso ein Update nicht mal einfach nur funktionieren kann. Ständig ist was anderes 'kaputt' ... :(


Last edited by BlackEye on Sun May 09, 2010 1:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat May 01, 2010 11:37 am    Post subject: Reply with quote

hast du im nachhinein mal folgendes ausgeführt:

emerge -a1 $(qlist -I -C x11-driver)

bei mir hat anfangs auch nichts funktioniert, bis ich das nutzte.

deine tastatur/maus konfigurierst du über HAL?
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sat May 01, 2010 11:53 am    Post subject: Reply with quote

ScytheMan wrote:
hast du im nachhinein mal folgendes ausgeführt:

emerge -a1 $(qlist -I -C x11-driver)

Japp, das habe ich getan

ScytheMan wrote:
deine tastatur/maus konfigurierst du über HAL?

ähm, keine Ahnung?
Ich habe nur einen Eintrag in der xorg.conf. Sonst hab ich nirgends meine Tastatur oder Maus eingetragen

Code:
Section "InputDevice"
    Identifier  "Keyboard"
    Driver      "kbd"

    Option      "CoreKeyboard"
    Option      "XkbRules" "xorg"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "de"
    Option      "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"
    Identifier  "Logitech USB"
    Driver      "mouse"

    Option      "Protocol"      "IMPS/2"
    Option      "Device"        "/dev/psaux"
    Option      "Buttons"       "4"
    Option      "ZAxisMapping" "4 5"
EndSection
Back to top
View user's profile Send private message
kriz
Apprentice
Apprentice


Joined: 22 Jan 2003
Posts: 231

PostPosted: Sat May 01, 2010 12:28 pm    Post subject: Reply with quote

hast du evdev und uinput am laufen?
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat May 01, 2010 12:29 pm    Post subject: Reply with quote

Ok, normalerweise ist der aktuelle Stand der Dinge die Konfiguration von Input Devices über Hal.

nutzt du evdev? oder hast du noch xf86-input-driver-keyboard/mouse installiert?

hast du ein sauberes Upgrade auf Xorg-Server 1.5 damals gemacht?

ist bei xorg-server das Hal Useflag gesetzt?


Die Einträge in der Xorg.conf benötigst du nicht mehr, läuft über eine Hal Policy (die du evtl. noch erstellen musst).
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sat May 01, 2010 12:35 pm    Post subject: Reply with quote

ScytheMan wrote:
Ok, normalerweise ist der aktuelle Stand der Dinge die Konfiguration von Input Devices über Hal.

nutzt du evdev? oder hast du noch xf86-input-driver-keyboard/mouse installiert?

beides ist installiert. Ich musste evdev jetzt auch installieren, sonst startete X erst gar nicht.

ScytheMan wrote:
hast du ein sauberes Upgrade auf Xorg-Server 1.5 damals gemacht?

Schwer zu sagen - ich fürchte ich hab es einfach nur emerged und danach lief es wie gewohnt :)

ScytheMan wrote:
ist bei xorg-server das Hal Useflag gesetzt?

Japp, das steht drin

ScytheMan wrote:
Die Einträge in der Xorg.conf benötigst du nicht mehr, läuft über eine Hal Policy (die du evtl. noch erstellen musst).

also kann ich die xorg.conf jetzt löschen? Oder nur die Einträge der Maus und Tastatur entfernen??
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat May 01, 2010 2:26 pm    Post subject: Reply with quote

BlackEye wrote:

ScytheMan wrote:
Die Einträge in der Xorg.conf benötigst du nicht mehr, läuft über eine Hal Policy (die du evtl. noch erstellen musst).

also kann ich die xorg.conf jetzt löschen? Oder nur die Einträge der Maus und Tastatur entfernen??


Nur Section InputDevice löschen.
und sowas muss in deiner fdi stehen
unter /etc/hal/fdi/policy/ abspeichern

Code:

<?xml version="1.0" encoding="utf-8"?>
<deviceinfo version="0.2">
    <match key="info.capabilities" contains="input.mouse">
      <merge key="input.x11_driver" type="string">mouse</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.x11_driver" type="string">evdev</merge>
      </match>
    </match>
   <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <!-- Option "XkbModel" "pc105" -->
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">de</merge>
      <merge key="input.xkb.variant" type="string">nodeadkeys</merge>
   </match>
</deviceinfo>
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sat May 01, 2010 2:50 pm    Post subject: Reply with quote

Danke erstmal fuer die Tips, aber irgendwas mache ich wohl noch verkehrt.
Denn geaendert hat sich an dem Tastaturverhalten nichts und obendrein habe ich noch eine englische statt deutsche Tastatur jetzt.
Ich habe Dein angegeben Snipset unter /etc/hal/fdi/policy/20-input.fdi abgespeichert und den rechner komplett neu hochgefahren. Hat aber nichts gebracht.

Wie gesagt: Tastatur macht noch dieselben Mucken wie zuvor und englisch ist sie jetzt noch obendrein :)
Back to top
View user's profile Send private message
ScytheMan
l33t
l33t


Joined: 30 Nov 2005
Posts: 605

PostPosted: Sat May 01, 2010 10:54 pm    Post subject: Reply with quote

Als Kde Nutzer kannst du dein Tastaturlayout auch in den Systemeinstellungen umstellen.

Die Sonderzeichen Probleme existieren dann immer noch?
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun May 02, 2010 10:20 am    Post subject: Reply with quote

Ah ja, richtig. Wenn ich das im KDE Kontrollzentrum einstelle, dann habe ich in der Tat die deutsche Tastatur.
Aber die Sache mit den Sonderzeichen ist noch nicht ganz Koscher. Wenn ich hier im FF die ALT-Gr Taste drücke, dann geht der Cusor eine Stelle nach links und erst dann kann ich das '@' einfügen. Dafür geht die PgUp Taste.
Nun merke ich aber auch dass die Pfeiltasten an der Tastatur keine Wiederholungen mehr machen. Wenn ich also auf den Pfeil links drücke und gedrückt lasse, dann springt der Cursor nur genau ein Zeichen nach links. Oh nun nun merke ich dass die Pfeil-runter Taste ein Enter setzt...
Nee, hier ist doch alles quer :(
manno...
Back to top
View user's profile Send private message
fuzzy.SYS
n00b
n00b


Joined: 04 May 2010
Posts: 3

PostPosted: Tue May 04, 2010 2:39 am    Post subject: Reply with quote

Ich hatte genau dasselbe Problem:
Alt Gr macht ein links und die Pfeiltasten ganze krude Sachen.

https://forums.gentoo.org/viewtopic-t-821796.html

hat mich darauf gebracht das

Quote:
Option "AllowEmptyInput" "false"


aus meiner xorg.conf wieder zu entfernen und nun tut wieder alles normal.
Ich verstehe nur nicht warum...
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Tue May 04, 2010 12:15 pm    Post subject: Reply with quote

@fuzzy.SYS
Mit
Code:
Option "AllowEmptyInput" "false"
würdest du das hotplugging , srich die weitergabe der Eingabegeräte an HAL deaktivieren, und somit HAL gar nicht nutzen.

....................................................................................................................................
@BlackEye
Besteht hier noch Interesse?
Wenn ja, dann poste doch mal bitte deine aktuelle xorg.conf und die /var/log/Xorg.0.log
(möglichst per nopaste Dienst)
sowie die Ausgabe von
Code:
$ eix -I -c x11-drivers/xf86-input
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Tue May 04, 2010 1:04 pm    Post subject: Reply with quote

@Josef.95

mache ich sobald ich wieder an diesem Rechner sitze. Das ist vermutlich erst am WE wieder der Fall
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat May 08, 2010 11:18 am    Post subject: Reply with quote

Hoi! Ich habe exakt dasselbe Problem:

Taste => Funktion
Alt Gr => Pfeil nach Unten
enter (Im NUM Lock feld) => Alt Gr
entf => Druck
Pfeil nach oben => funktioniert nicht
Pfeil nach unten => funktioniert nicht


Meine USEs beim installieren:
Code:

[ebuild   R   ] x11-base/xorg-drivers-1.8  INPUT_DEVICES="evdev joystick keyboard mouse synaptics -acecad -aiptek -penmount -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="nvidia v4l vesa -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) (-impact) -intel -mach64 -mga -neomagic (-newport) -nouveau -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -via -virtualbox -vmware (-voodoo) (-xgi)" 0 kB
[ebuild   R   ] x11-base/xorg-server-1.8.0  USE="ipv6 nptl udev xorg -dmx -doc -hal -kdrive -minimal -static-libs -tslib" 4,978 kB
[ebuild   R   ] x11-base/xorg-x11-7.4-r1  0 kB


Die Tastatur ist übrigends die von meinem Notebook:
http://phpmygentoo.rainyday-productions.de/Tastatur_ACER_Aspire_9920G.JPG (Als Bild kann ich die nicht einfügen?)


Hier meine xorg.conf und die xorg.log (Bitte melden wenn etwas fehlt).

/etc/hal/fdi/policy/10-keymap.fdi habe ich gelöscht da ja HAL deinstalliert wurde.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)


Last edited by Gladdle on Sat May 08, 2010 3:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sat May 08, 2010 2:50 pm    Post subject: Reply with quote

@Gladdle

Du nutzt ja nun schon xorg-server-1.8 mit udev, da ist eine ganz andere Konfiguration der Eingabegeräte erforderlich,
siehe zb: http://www.gentoo.org/proj/en/desktop/x/x11/xorg-server-1.8-upgrade-guide.xml
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat May 08, 2010 3:44 pm    Post subject: Reply with quote

Ja und nein, man kann zwischen
Code:
Section "InputDevice"
und
Code:
Section "InputClass"
entscheiden, die Syntax ist halt anders, eins ist für Geräte, das andere für Gerätekategorieen. Das Ding habe ich mirschon mehrfach durchgelesen. Fakt ist sobald ich auf keymap de switche ist das tastaturlayout kaputt, im englischen funktioniert alles auf englisch. Ausserdem habe ich ja autoadddevices auf off.
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sat May 08, 2010 4:50 pm    Post subject: Reply with quote

Gladdle wrote:
[....]
Ausserdem habe ich ja autoadddevices auf off.

Hm.., Ok, heißt du möchtest die Settings deiner Eingabegeräte wirklich komplett selbst setzen...?
Puhh..., nungut...

Gibt es für dich einen triftigen Grund "autoadddevices off" zu setzen?

PS: Eventuell wäre es aber auch besser für diese xorg-server-1.8 Geschichte einen eigenen Thread zu eröffnen?!
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 268
Location: Cleebronn, Germany

PostPosted: Sat May 08, 2010 11:32 pm    Post subject: Reply with quote

egal ob mit oder ohne "autoadddevices", sobald das Tastaturlayout auf "de" umgeschalten wird ist dieses verdrehte Tastaturlayout da. Die "us" Version hingegen macht keine Probleme. In welchem Packet sind denn die Tastaturlayouts, vielleicht reicht es ja dieses neu zu emergen. Problem existiert im kdm, unter kde und allem was mit xorg zu tun hat.


Nachtrag (1):
Hier ist die Lösung:
Code:
Option "XkbRules" "xorg"
Komplett sieht das dann so aus:
Code:
Section "InputDevice"
    Identifier        "Keyboard (ACER Aspire 9920g)"
    Driver            "kbd"
    Option            "CoreKeyboard"
    Option            "XkbRules"       "xorg"
    Option            "XkbModel"       "pc105"
    Option            "XkbLayout"      "de"
    Option            "XkbVariant"     "nodeadkeys"
EndSection
Loesung gefunden auf dem ubuntu Forum :D
Trotsdem ein Danke an alle die geholfen haben :)



Nachtrag (2):
Wenn ich die Session "locke" kann ich das Passwort NICHT korrekt eingeben (Meldung: unlock failed). Ich habe sonderzeichen im Passwort. WtF? Ich will wieder meinen PC sperren können!
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun May 09, 2010 11:13 am    Post subject: Reply with quote

So, bei mir ist nach wie vor alles Käse :)
hier mal meine komplette xorg.conf
Und hier die aktuelle Xorg.0.log

Eigentlich kann man mit dem Rechner z.Zt. überhaupt nicht ernsthaft arbeiten.

Edit (vergessen):
Code:
eix -I -c x11-drivers/xf86-input
[I] x11-drivers/xf86-input-evdev (2.3.2@29.04.2010): Generic Linux input driver
[I] x11-drivers/xf86-input-keyboard (1.4.0@29.04.2010): Keyboard input driver
[I] x11-drivers/xf86-input-mouse (1.5.0@29.04.2010): X.Org driver for mouse input devices
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun May 09, 2010 12:45 pm    Post subject: Reply with quote

Quote:
(**) Option "AllowEmptyInput" "false"
Auch hier, ist es wirklich beabsichtigt das hotplugging zu deaktivieren?
Damit wird die weitergabe der Eingabegeräte an HAL verhindert....

Also kommentiere die Option
Code:
Option      "AllowEmptyInput"      "false"
in deiner xorg.conf aus, oder setze den Wert auf "true"
Wie schaut es dann nach einem X Neustart aus?
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun May 09, 2010 12:58 pm    Post subject: Reply with quote

ah - stimmt.. ich habe den Eintrag aus der xorg entfernt und nun geht alles korrekt.

Frage mich im Nachhinein wieso ich diesen Eintrag da drin hatte. Ist bestimmt irgend eine Altlast.

Okay - besten Dank. Mein Rechner ist wieder "benutzbar" :)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3629
Location: Germany

PostPosted: Sun May 09, 2010 1:07 pm    Post subject: Reply with quote

Na prima....

Magst du evtl. noch ein [gelöst] oder [solved] vor den Thread Titel setzen?!
danke
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun May 09, 2010 1:26 pm    Post subject: Reply with quote

ups - sorry.
Klar mache ich sofort!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum