Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
consolekit[-policykit] oder sys-auth/consolekit-0.4[policyk
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 10, 2010 8:16 am    Post subject: consolekit[-policykit] oder sys-auth/consolekit-0.4[policyk Reply with quote

Hallo,

habe mal wieder ein lustiges Problem:

Code:

sys-auth/consolekit:0

  ('installed', '/', 'sys-auth/consolekit-0.4.1', 'nomerge') pulled in by
    sys-auth/consolekit[-policykit] required by ('installed', '/', 'sys-apps/hal-0.5.13-r2', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'sys-auth/consolekit-0.4.1', 'merge') pulled in by
    >=sys-auth/consolekit-0.4[policykit] required by ('installed', '/', 'sys-auth/polkit-0.96-r1', 'nomerge')
    (and 4 more)


kann mir leider keinen Reim drauf machen
Bitte um Hilfe!
G. R.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon May 10, 2010 8:32 am    Post subject: Reply with quote

Hi
Es wäre bei sowas hilfreich wenn der Befehl der Ausgabe mit angegeben wird.
So kann hier kaum einer nachvollziehen woraus deine Ausgabe überhaupt entstanden ist...

Sollte eigentlich problemlos miteinander funktionieren, wurde evtl. versäumt bei emerge die "--newuse" Option mit anzugeben?

Ansonsten zeige mal bitte die Ausgabe von
Code:
 # USE="consolekit policykit" emerge -av1DNt hal
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon May 10, 2010 10:27 am    Post subject: Reply with quote

Klingt nach einer cirkulären Abhängigkeit. Also a ist abhängig von b und b ist abhängig von a und deshalb bekommst du beide nicht installiert. Bekommst du weg, in dem du USE="-policykit" emerge consolekit machst. Also so etwas in der Art. Müsstest da mal etwas mehr posten, dann kann man es genau sagen. Oder erst mal mit -consolekit übersetzen. Oder -hal.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 10, 2010 6:29 pm    Post subject: Reply with quote

Klaus Meier wrote:
Klingt nach einer cirkulären Abhängigkeit. Also a ist abhängig von b und b ist abhängig von a und deshalb bekommst du beide nicht installiert. Bekommst du weg, in dem du USE="-policykit" emerge consolekit machst. Also so etwas in der Art. Müsstest da mal etwas mehr posten, dann kann man es genau sagen. Oder erst mal mit -consolekit übersetzen. Oder -hal.


Hi,

im Moment sieht es so aus:

Code:
emerge --update world --deep

 * IMPORTANT: 7 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N    ] sys-power/pm-quirks-20100316
[ebuild     U ] gnome-base/gnome-common-2.28.0 [2.26.0]
[ebuild     U ] sys-power/acpid-2.0.4-r2 [1.0.10_p3]
[ebuild     U ] media-libs/libart_lgpl-2.3.21-r1 [2.3.20]
[ebuild     U ] x11-apps/mkfontscale-1.0.7 [1.0.6]
[ebuild  N    ] media-libs/libdvdnav-4.1.3_p1168
[ebuild     U ] x11-apps/mkfontdir-1.0.5 [1.0.4]
[ebuild     U ] media-fonts/encodings-1.0.3 [1.0.2-r1]
[ebuild  N    ] app-text/texlive-core-2008-r7  USE="X -doc -source -tk"
[ebuild  N    ] dev-texlive/texlive-documentation-base-2008  USE="-source"
[ebuild  N    ] virtual/tex-base-0
[ebuild  N    ] dev-texlive/texlive-basic-2008-r1  USE="-doc -source"
[ebuild     U ] dev-libs/libxml2-2.7.7 [2.7.6]
[ebuild     U ] app-text/docbook-xml-dtd-4.4-r2 [4.4-r1]
[ebuild     UD] app-text/gnome-doc-utils-0.18.1 [0.19.5]
[ebuild     U ] app-text/rarian-0.8.1-r1 [0.8.1]
[ebuild     U ] app-editors/nano-2.2.4 [2.1.10]
[ebuild  N    ] dev-libs/zziplib-0.13.49-r1  USE="sdl -test"
[ebuild  N    ] dev-tex/luatex-0.50.0-r1  USE="-doc"
[ebuild  N    ] dev-texlive/texlive-latex-2008-r2  USE="-doc -source"
[ebuild  N    ] dev-texlive/texlive-latexrecommended-2008-r2  USE="-doc -source"
[ebuild  N    ] virtual/latex-base-1.0
[ebuild  N    ] dev-tex/xmltex-1.9-r2
[ebuild  N    ] app-text/passivetex-1.25
[ebuild  N    ] app-text/xmlto-0.0.22  USE="latex"
[ebuild     U ] dev-libs/glib-2.22.5 [2.22.4]
[ebuild     U ] x11-misc/shared-mime-info-0.71 [0.70]
[ebuild     U ] dev-util/desktop-file-utils-0.16 [0.15]
[ebuild   R   ] sys-auth/consolekit-0.4.1  USE="-policykit*"
[ebuild     U ] gnome-base/orbit-2.14.18 [2.14.17]
[ebuild  N    ] media-plugins/gst-plugins-resindvd-0.10.17
[ebuild     U ] media-plugins/gst-plugins-meta-0.10-r4 [0.10-r2] USE="-lame% -pulseaudio% -taglib%"
[ebuild  NS   ] sys-kernel/gentoo-sources-2.6.33-r2 [2.6.33, 2.6.33-r1] USE="-build -deblob -symlink"
[ebuild     U ] sys-power/pm-utils-1.3.0-r2 [1.2.5]
[ebuild     U ] x11-libs/gtk+-2.18.9 [2.18.7]
[ebuild     U ] net-wireless/bluez-4.63 [4.39-r2] USE="-caps% -gstreamer* -pcmcia%"
[ebuild     UD] x11-libs/vte-0.22.5 [0.24.0]
[ebuild     U ] net-libs/libpcap-1.1.1 [1.0.0-r2] USE="-libnl%"
[ebuild     U ] gnome-base/libgnomeprint-2.18.7 [2.18.6]
[ebuild     U ] media-libs/libcanberra-0.23 [0.22] USE="-gstreamer* -tdb%"
[ebuild     U ] gnome-base/libbonoboui-2.24.3 [2.24.2]
[ebuild     U ] net-analyzer/nmap-5.21 [5.00-r2]
[ebuild     UD] x11-terms/gnome-terminal-2.28.2 [2.30.0]
[ebuild     U ] gnome-base/libgnomeprintui-2.18.5 [2.18.4]
[ebuild     U ] gnome-base/gnome-vfs-2.24.3-r1 [2.24.2]
[ebuild     U ] gnome-base/libgnomeui-2.24.3 [2.24.2]
[ebuild     U ] dev-java/sun-jdk-1.6.0.20 [1.6.0.19]
[ebuild     U ] app-cdr/k3b-1.91.0_rc2 [1.70.0_beta1] USE="handbook%*" LINGUAS="de%* -ast% -be% -bg% -ca% -ca@valencia% -cs% -csb% -da% -el% -en_GB% -eo% -es% -et% -eu% -fi% -fr% -ga% -gl% -he% -hi% -hne% -hr% -hu% -is% -it% -ja% -km% -ko% -ku% -lt% -mai% -nb% -nds% -nl% -nn% -oc% -pa% -pl% -pt% -pt_BR% -ro% -ru% -se% -sk% -sl% -sv% -th% -tr% -uk% -zh_CN% -zh_TW%"
[ebuild     U ] gnome-extra/libgsf-1.14.18 [1.14.15] USE="gtk%* -thumbnail%"
[ebuild     U ] gnome-base/librsvg-2.26.2 [2.26.0] USE="-tools%"
[ebuild     U ] gnome-extra/evolution-exchange-2.28.3 [2.26.3]


!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-auth/consolekit:0

  ('installed', '/', 'sys-auth/consolekit-0.4.1', 'nomerge') pulled in by
    >=sys-auth/consolekit-0.4[policykit] required by ('installed', '/', 'sys-auth/polkit-0.96-r1', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'sys-auth/consolekit-0.4.1', 'merge') pulled in by
    sys-auth/consolekit[-policykit] required by ('installed', '/', 'sys-apps/hal-0.5.13-r2', 'nomerge')
    (and 4 more)




G. R.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Mon May 10, 2010 6:45 pm    Post subject: Reply with quote

Du hast da ein ziemliches Gnome Durcheinander. Upgrade bei einigen Paketen und Downgrade bei anderen. Du hast da wohl ein paar Pakete aus dem Overlay installiert und das dann wieder entfernt. Und nun werden 2 unterschiedliche Versionen von Consolekit benötigt, die nicht gleichzeitig installiert sein können.

Mach mal USE="-consolekit" emerge -uDN world. Das sollte Consolekit erst mal ganz überflüssig machen. Und wenn dann alle Pakete auf einem Stand sind, dann ein emerge -uDN world. Das sollte klappen.
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Mon May 10, 2010 6:45 pm    Post subject: Reply with quote

Gelöst:
https://forums.gentoo.org/viewtopic-t-818828-highlight-sysauth+consolekit.html[/code]
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3627
Location: Germany

PostPosted: Mon May 10, 2010 7:01 pm    Post subject: Reply with quote

Quote:
* IMPORTANT: 7 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


Code:
$ eselect news read new
No news is good news.
:wink:

G.H.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum