Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Where does flash go?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Fri May 14, 2010 12:38 am    Post subject: [Solved]Where does flash go? Reply with quote

I downloaded 10.1 64bit from the adobe site but it did not include instructions on where to put it. After googling around I put libflashplayer.so in the following places:

~/.mozilla/plugins
~/.mozilla/firefox/Plugins (sic)
/usr/lib/mozilla-firefox/plugins
/usr/lib/mozilla/plugins
/usr/lib/firefox/plugins

None of these work. Where do I put the file so that it'll work? Before anyone says "emerge adobe-flash" that version of flash is old and doesn't play nice with pulseaudio - unless there's an overlay for latest flash.


Last edited by jordanwb on Tue May 18, 2010 1:26 am; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Fri May 14, 2010 1:19 am    Post subject: Reply with quote

Hello,
it's suppose to be sufficient to put libflashplayer.so in one place, i would prefer ~/.mozilla/plugins. I do not duplicate plugins. There is one thing to do before starting the browser. You need to remove the file pluginreg.dat from the root directory of every profile in ~/mozilla. This file can prevent the Mozilla like browsers to detect the new plugin. After suppress it, it will be regenerate in the new pluginreg.dat should include libflashplayer.so. If you have an other libflashplayer.so somewhere else, try to remove it. Two things who want to do the same thing at the same time can cause a conflict.
_________________
Paul


Last edited by Logicien on Fri May 14, 2010 1:21 am; edited 1 time in total
Back to top
View user's profile Send private message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Fri May 14, 2010 1:21 am    Post subject: Reply with quote

Logicien wrote:
I do not duplicate plugins.


I'm not trying to, I'm trying to find the correct location for the file. I never had to delete a pluginreg.dat when running Ubuntu.
Back to top
View user's profile Send private message
EatMeerkats
Apprentice
Apprentice


Joined: 15 Mar 2006
Posts: 234

PostPosted: Fri May 14, 2010 1:34 am    Post subject: Re: Where does flash go? Reply with quote

jordanwb wrote:
I downloaded 10.1 64bit from the adobe site but it did not include instructions on where to put it. After googling around I put libflashplayer.so in the following places:

~/.mozilla/plugins
~/.mozilla/firefox/Plugins (sic)
/usr/lib/mozilla-firefox/plugins
/usr/lib/mozilla/plugins
/usr/lib/firefox/plugins

None of these work. Where do I put the file so that it'll work? Before anyone says "emerge adobe-flash" that version of flash is old and doesn't play nice with pulseaudio - unless there's an overlay for latest flash.


That is the 32-bit version of the flash plugin — there is currently no 64-bit 10.1 beta. The version of adobe-flash you can emerge is the latest 64-bit version available, and it seems to work fine with pulseaudio for me.
Back to top
View user's profile Send private message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Fri May 14, 2010 1:45 am    Post subject: Reply with quote

Then google needs a good smack because that is the page I got for "adobe flash 64 bit linux". I re-emerged adobe-flash and now it isn't working. :x I have two sound devices: onboard and USB headset, changing the output device did not change flash's playing sound through my onboard sound chip.
Back to top
View user's profile Send private message
EatMeerkats
Apprentice
Apprentice


Joined: 15 Mar 2006
Posts: 234

PostPosted: Fri May 14, 2010 1:52 am    Post subject: Reply with quote

Ah, I only have one soundcard so I don't have this issue. Do you have your default ALSA device set up to use pulseaudio as suggested at http://www.pulseaudio.org/wiki/PerfectSetup#FlashPlayer10 ? Another option, if you really want to run the 10.1 beta, is to emerge nspluginwrapper, which lets you use 32-bit plugins in a 64-bit browser (this is what Ubuntu uses).
Back to top
View user's profile Send private message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Fri May 14, 2010 1:53 am    Post subject: Reply with quote

On my 64 bit ubuntu's I have a repo with latest 64 bit flash. I'll take a look at that link.

I put

Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}


in /etc/asound.conf, rebooted ran

Code:
jordanwb@JORDAN-LAPTOP ~ $ aplay -Dpulse /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so
aplay: main:608: audio open error: No such file or directory


Lovely

Running firefox from a terminal gives this little tibit:

Code:
LoadPlugin: failed to initialize shared library /usr/lib64/mozilla/plugins/libflashplayer.so [/usr/lib64/mozilla/plugins/libflashplayer.so: wrong ELF class: ELFCLASS32]


Using that I unmerged (unemerged?) adobe-flash, wgeted the 64 bit directly (had full url in a script), extracted it and copies it to /usr/lib64/mozilla/plugins and it works. Don't know if it'll play nice with pulseaudio.

Nope. 64 bit Flash won't work with pulseaudio. I'll worry about it tommorow.
Back to top
View user's profile Send private message
skellr
l33t
l33t


Joined: 18 Jun 2005
Posts: 901
Location: The Village, Portmeirion

PostPosted: Fri May 14, 2010 5:39 am    Post subject: Reply with quote

It will also look in $MOZ_PLUGIN_PATH

looks like i'm a bit late.
Back to top
View user's profile Send private message
EatMeerkats
Apprentice
Apprentice


Joined: 15 Mar 2006
Posts: 234

PostPosted: Fri May 14, 2010 4:42 pm    Post subject: Reply with quote

jordanwb wrote:
I put

Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}


in /etc/asound.conf, rebooted ran

Code:
jordanwb@JORDAN-LAPTOP ~ $ aplay -Dpulse /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so
aplay: main:608: audio open error: No such file or directory


Lovely


This is probably because your alsa-plugins isn't installed with the pulseaudio USE flag, which is required to redirect ALSA output to pulseaudio. Also, note that you have to set pcm.!default to type pulse for it to work with flash.
Back to top
View user's profile Send private message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Fri May 14, 2010 8:37 pm    Post subject: Reply with quote

Okay thanks I got "aplay -Dpulse ..." working. Let's check flash.

Nope. still ignores pulseaudio.
Back to top
View user's profile Send private message
EatMeerkats
Apprentice
Apprentice


Joined: 15 Mar 2006
Posts: 234

PostPosted: Tue May 18, 2010 12:04 am    Post subject: Reply with quote

Do you have
Code:
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}


in your /etc/asound.conf?
Back to top
View user's profile Send private message
jordanwb
l33t
l33t


Joined: 10 Jul 2008
Posts: 642
Location: Ottawa, Canada

PostPosted: Tue May 18, 2010 1:26 am    Post subject: Reply with quote

No I had this:

Code:
pcm.!pulse {
    type pulse
}
ctl.!pulse {
    type pulse
}


I changed it to what you posted and flash works right now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum