Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Problème de version
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Wed May 19, 2010 5:45 pm    Post subject: [emerge] Problème de version Reply with quote

Bonjour à tous.
Je viens de recevoir un portable récent et j'y installe Gentoo avec ACCEPT_KEYWORDS="~amd64" (le processeur est un i7 :D ). Seulement je ne veux pas du serveur X en 1.8, alors j'ai mis ds mon /etc/portage/package.keywords :
Code:
x11-base/xorg-server amd64
et sa ne marche pas. Pas plus que :
Code:
<x11-base/xorg-server-1.8.0
ou
=x11-base/xorg-server-1.7.6


Je l'ai mis dans package.mask mais quand je fais emerge -uDNav world sa fait pas prorpre, il me dis qu'il peut pas mettre à jour un drivers pcq xorg-server est necessaire en version 1.8.
Qqn a-t-il une explication, et surtout une solution me permettant de garder un paquet dans la branche stable ?

Merci d'avance.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8078
Location: ~Brussels - Belgique

PostPosted: Wed May 19, 2010 9:31 pm    Post subject: Reply with quote

Salut,

package.keyword ne fonctionne pas ainsi. Si tu veux une version stable, passe tout en stable et mets certains paquets en instable.
Ou alors, masque certains paquets, mais tu vas galérer, car xorg est une galaxie de dépendances...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Wed May 19, 2010 11:14 pm    Post subject: Re: [emerge] Problème de version Reply with quote

Picani wrote:
/etc/portage/package.keywords :
Code:
x11-base/xorg-server amd64

Non, ce qu'il faut faire ici, ce n'est pas "accepter amd64" mais bien "exclure ~amd64", c'est-à-dire :
Code:
x11-base/xorg-server -~amd64

Si suite à cela, certains paquets (pilotes ... ;-) ) rouspètent parce qu'ils ne trouvent pas xorg-1.8, il faudra les recompiler.

Note cependant qu'avec cette méthode, lorsque xorg-server-1.8 passera en stable, il sera alors automatiquement installé dès que tu feras une mise à jour.
Pour exclure définitivement une version particulière, il faut effectivement la masquer dans /etc/portage/package.mask.
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Thu May 20, 2010 4:33 pm    Post subject: Reply with quote

Ok merci. Mais alors, est-ce que je peux mettre à jour les paquets dont dépend xorg-server-1.7.7 ou je dois aussi les mettre dans package.mask ou dans package.keywords avec -~amd64 ?
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Thu May 20, 2010 4:49 pm    Post subject: Reply with quote

Picani wrote:
Mais alors, est-ce que je peux mettre à jour les paquets dont dépend xorg-server-1.7.7 ou je dois aussi les mettre dans package.mask ou dans package.keywords avec -~amd64 ?

Si le paquet dépend explicitement de la version 1.8 de xorg-server, alors il ne pourra pas être installé puisque cette version de xorg-server sera masquée.
La version concernée du paquet dépendant doit donc être masqué aussi pour pouvoir garder la version "qui marche".
Par contre, si la dépendance est générale (aucune mention de la version de xorg-server), alors il n'y aura aucun problème à mettre le paquet à jour.
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri May 21, 2010 5:31 pm    Post subject: Reply with quote

Ok ben c'est parfait alors merci. Sa fait juste pas très propre quand il y a un paquet qu'il peut pas mettre à jour à cause de la dépendance à xorg-server-1.8 mais c'est pas grave, tout marche.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum