Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]emerge --sync geht nicht mehr: Permission denied
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 19, 2010 8:55 am    Post subject: [gelöst]emerge --sync geht nicht mehr: Permission denied Reply with quote

Hallo, ich habe ein kleines Problem mit meinen emerge --sync: Anscheinend hab ich nicht die berechtigung, dateien im tree zu ändern ich bekomme immer massenweise solche fehlermeldungen:
Code:
rsync: rename "/usr/portage/sci-visualization/veusz/.veusz-1.5.ebuild.f7jGlu" -> "sci-visualization/veusz/veusz-1.5.ebuild": Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.iQA5qq) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.H5FTTf) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.FI3eMH) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.AFUvzQ) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.9B6tZs) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.8AFTzy) failed: Permission denied (13)
rsync: delete_file: unlink(sys-apps/parted/.parted-2.2.ebuild.2YbeKP) failed: Permission denied (13)

anscheinend läd er die neuen dateien jedes mal runter, aber das umbenennen geht nicht. der befehl wird mit "sudo" ausgeführt. ich hab schon gelesen, dass "chown portage:portage" angewand auf den tree helfen soll, aber hier nicht.. das löschen des gesamten trees hilft, da dann alle dateien neu geholt werden, was scheinbar problemlos geht, aber danach bei updates ist das selbe probleme wieder.
Erst hab ich vermutet, dass es an meinen sqfs/aufs kombination für den tree liegt, aber inzwischen hab ich wieder den standard für den tree hergestellt, so dass er jetzt wieder unter "/usr/portage" auf einem ext4 dateisystem liegt. "per hand" kann ich aber alles im tree machen was ich will (mit sudo). kann mir da jemand wieterhelfen?

schöne grüße
Christian


Last edited by Christian99 on Wed Jun 02, 2010 9:44 am; edited 1 time in total
Back to top
View user's profile Send private message
Jimini
Guru
Guru


Joined: 31 Oct 2006
Posts: 590
Location: Germany

PostPosted: Wed May 19, 2010 9:38 am    Post subject: Reply with quote

Schau mal hier nach, da hatte jemand das gleiche Problem. Hast du schonmal versucht, den Portage Tree einfach neu reinzuziehen?

MfG Jimini
_________________
"The most merciful thing in the world, I think, is the inability of the human mind to correlate all its contents." (H.P. Lovecraft: The Call of Cthulhu)
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 19, 2010 10:04 am    Post subject: Reply with quote

ja, ich hab sowohl den tree gelöscht, als auch ein chown gemacht. beides nix geholfen, siehe oben.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed May 19, 2010 10:31 am    Post subject: Reply with quote

Beim chown auch nicht das -R vergessen?
Auch mal ohne sudo probiert?
Und was sagt `emerge --info | grep FEATURES`?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 19, 2010 10:44 am    Post subject: Reply with quote

beim chown, das ich ausgeführt hab mars mit -R, habs nur hier vergessen.

emerge --info|grep FEATURES
Code:
FEATURES="assume-digests candy ccache distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"


ich nehme an du willst auf userfetch hinaus. da hab ich auch schon dran gedacht, und in der make.conf nachgeschaut, wo es nicht drin steht. heißt das, dass emerge userfetch als standardoption verwendet? seit wann?

emerge --sync ohne sudo:
Code:
emerge --sync
superuser access is required... adding --pretend to options

emerge: The 'sync' action does not support '--pretend'.


EDIT: hab bei FEATURES in der make.conf "-userfetch" hinzugefügt, hilt auch nicht.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Wed May 19, 2010 11:25 am    Post subject: Reply with quote

Ne, hab nach usersync geguckt, userfetch ist was anderes. Und mit 'ohne sudo' meinte ich eine "echte" root-Shell, sprich als root einloggen oder mit `su -` wechseln.
Ansonsten wie sehen denn die Rechte der betroffenen Dateien und v.a. der übergeordneten Verzeichnisse aus?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 19, 2010 11:43 am    Post subject: Reply with quote

achso, userfetch und usersync gibts beides...

wenn ich mit su wechsle macht das auch keinen unterschied.
die berechtigungen der verzeichnise sind drwxr-xr-x bzw -rwxr-xr-x bei den dateien, ich hab zwar nicht jede einzelne nachgeschaut, aber da ich gestern den kompletten tree mit emerge --sync geholt habe wird das schon passen (hoffe ich)
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon May 24, 2010 3:42 pm    Post subject: Reply with quote

*push*
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon May 24, 2010 4:04 pm    Post subject: Reply with quote

Haste mal das Dateisystem überprüft?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon May 24, 2010 4:56 pm    Post subject: Reply with quote

zuletzt vor 2 oder 3 bootups, aber da ging es schon nicht mehr. außerdem kann ich alle dateioperationen "per Hand" ganz normal durchführen. Und ich hatte das Anfangs auf einer squash/aufs kombination. da haben die probleme angefangen, und daraufhin hab ich es auf meine ganz normale systempartition umgelegt, was keine verängerung gebracht hat. Deswegen würd ich dateisystem ausschließen.
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Mon May 24, 2010 6:40 pm    Post subject: Reply with quote

Dann zeig was folgendes als user root ausgibt.
Code:

mount
ls -ld /usr/portage
ls -ld /usr/portage/sci-visualization
ls -ld /usr/portage/sci-visualization/veusz
ls -ld /usr/portage/sci-visualization/veusz/veusz-1.5.ebuild


Und die ausgabe von "emerge --sync", ersetzt durch "id" als
entsprechnenden user. Sprich, wenn du "sudo emerge --sync" verwendest
oder etwas anderes, dann "sudo id".
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon May 24, 2010 7:25 pm    Post subject: Reply with quote

also:
Code:
mount
/dev/sda5 on / type ext4 (rw,noatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
udev on /dev type tmpfs (rw,nosuid,relatime,size=10240k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
/dev/sda1 on /boot type ext2 (rw,noatime)
/dev/sdc3 on /home type ext4 (rw,noatime)
none on /var/tmp/portage type tmpfs (rw,nr_inodes=1M,size=2G)
/dev/sdb5 on /mnt/net type ext3 (ro,noatime)
shm on /dev/shm type tmpfs (rw,noexec,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
/dev/sr0 on /mnt/cdrom1 type iso9660 (ro,noexec,nosuid,nodev)

Code:
ls -ld /usr/portage
drwxr-xr-x 163 portage portage 4096 24. Mai 19:08 /usr/portage

Code:
ls -ld /usr/portage/sci-visualization
drwxr-xr-x 33 root root 4096 24. Mai 19:07 /usr/portage/sci-visualization

Code:
ls -ld /usr/portage/sci-visualization/veusz
drwxr-xr-x 3 root root 4096 18. Mai 15:37 /usr/portage/sci-visualization/veusz

Code:
ls -ld /usr/portage/sci-visualization/veusz/veusz-1.5.ebuild
-rw-r--r-- 1 root root 1256 18. Mai 15:37 /usr/portage/sci-visualization/veusz/veusz-1.5.ebuild


es macht auch keinen unterschied, wenn der besitzer der dateien portage:portage ist. Die Ausgabe von "sudo emerge --sync" siehst du beispielhaft oben im ersten post, wenn du wirklich alles sehn willst, was ja ewig lang ist, dann kann ich das auch posten.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Mon May 24, 2010 8:49 pm    Post subject: Reply with quote

a) du benutzt nicht zufällig SeLinux oder irgend ein anderes Sicherheitssystem, das root Rechte entzieht?
b) unter welchem User wird rsync ausgeführt? (top sollte das sagen können)


Last edited by Genone on Tue May 25, 2010 1:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Mon May 24, 2010 9:12 pm    Post subject: Reply with quote

a) nein, kein selinux oder ähnliches
b) rsync --recursive läuft als root (laut htop)
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Tue May 25, 2010 1:18 pm    Post subject: Reply with quote

Ok, dann bin ich mit meinem Latein auch langsam am Ende. Auf einem normalen Linux System sollte root eigentlich keine "Permission denied" Fehler kriegen können (von ein paar Spezialfällen wie /proc abgesehen)
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Tue May 25, 2010 3:04 pm    Post subject: Reply with quote

Genone wrote:
Ok, dann bin ich mit meinem Latein auch langsam am Ende. Auf einem normalen Linux System sollte root eigentlich keine "Permission denied" Fehler kriegen können (von ein paar Spezialfällen wie /proc abgesehen)
Oder das Filesystem hat einen defekt, da kenn ich das Problem her und konnte auch immer schön händisch gefixt werden.
Was sagt denn?
Code:

tune2fs -l /dev/sda5
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue May 25, 2010 4:53 pm    Post subject: Reply with quote

Code:
sudo tune2fs -l /dev/sda5                             
tune2fs 1.41.9 (22-Aug-2009)                                             
Filesystem volume name:   <none>                                         
Last mounted on:          /                                             
Filesystem UUID:          00fdcba2-8f24-4404-9161-4ba484bbd376           
Filesystem magic number:  0xEF53                                         
Filesystem revision #:    1 (dynamic)                                   
Filesystem features:      has_journal ext_attr resize_inode dir_index filetype needs_recovery extent flex_bg sparse_super large_file huge_file uninit_bg dir_nlink extra_isize                                                                                                                         
Filesystem flags:         signed_directory_hash                                                                                                     
Default mount options:    (none)                                                                                                                   
Filesystem state:         clean                                                                                                                     
Errors behavior:          Continue                                                                                                                 
Filesystem OS type:       Linux                                                                                                                     
Inode count:              3276800
Block count:              13107016
Reserved block count:     655350
Free blocks:              6581649
Free inodes:              2486170
First block:              0
Block size:               4096
Fragment size:            4096
Reserved GDT blocks:      1020
Blocks per group:         32768
Fragments per group:      32768
Inodes per group:         8192
Inode blocks per group:   512
Flex block group size:    16
Filesystem created:       Mon Mar 22 13:51:55 2010
Last mount time:          Tue May 18 23:09:33 2010
Last write time:          Mon May 17 08:59:17 2010
Mount count:              3
Maximum mount count:      38
Last checked:             Mon May 17 08:59:17 2010
Check interval:           15552000 (6 months)
Next check after:         Sat Nov 13 07:59:17 2010
Lifetime writes:          273 GB
Reserved blocks uid:      0 (user root)
Reserved blocks gid:      0 (group root)
First inode:              11
Inode size:               256
Required extra isize:     28
Desired extra isize:      28
Journal inode:            8
First orphan inode:       1507925
Default directory hash:   half_md4
Directory Hash Seed:      1367c67f-a382-41d2-b846-50de0c14de9d
Journal backup:           inode blocks


ich kann aber nicht so recht glauben, dass es am dateisystem liegt, sondern an portage. denn wie schon gesagt, der portagetree ist quasi nur zur fehlersuche auf der "/" partition. vorher war es auf einer anderen (sqfs/aufs). UND: per hand (d.h. "sudo mv ...") geht alles, was vorher nicht geht.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2225
Location: Germany

PostPosted: Tue May 25, 2010 11:42 pm    Post subject: Reply with quote

Hallo Christian99,

ich würde versuchen den Tree zu entfernen und ihn anschließend mit einem portage-latest.tar.bz2 Snapshot wieder herzustellen, so wie man das macht wenn man ein System neu installiert.

Wenn du ein Overlay/Layman verwenderst achte darauf das du beim Löschen von /usr/portage nicht auch den Unterordner /usr/portage/local gleich mit entfernst.

Gruß
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 26, 2010 6:56 am    Post subject: Reply with quote

hab ich auch schon gemacht. entweder löschen und portage-latest reinkopieren, oder löschen und emerge --sync. beides geht einmal, aber beim nächsten mal emerge --sync wieder genau das gleiche.
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Wed May 26, 2010 7:45 am    Post subject: Reply with quote

Und wie sieht es aus wenn du es per hand anschupst?
Code:

rsync --verbose $(portageq envvar PORTAGE_RSYNC_OPTS SYNC PORTDIR)
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Wed May 26, 2010 7:59 am    Post subject: Reply with quote

läuft, ich bin sprachlos....
jetzt kann ich wenigstens syncen, ohne den ganzen tree löschen zu müssen. aber wieso portage das nicht kann....
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Wed May 26, 2010 9:17 am    Post subject: Reply with quote

Christian99 wrote:
läuft, ich bin sprachlos....
jetzt kann ich wenigstens syncen, ohne den ganzen tree löschen zu müssen. aber wieso portage das nicht kann....

Wenn das geht und mittels emerge --sync nicht, müßte es bedeuten, dass portage den rsync befehl nicht als root anschups.
Eventuell mal portage und rsync neu installieren?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Thu May 27, 2010 9:37 am    Post subject: Reply with quote

portage hab ich bereits in 3 verschieden versionen probiert: 2.1.7.17, 2.1.7.3, 2.2-rc67. bei allen das gleiche. und rsync reemergen hat auch nix gebracht.
gibts denn irgendeine Einstellung die portage dazu veranlassen könnte, rsync nicht als root auszuführen? ich kann mich zwar nicht dran erinnern, dass ich da was umgestellt habe, aber wer weiß...
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Sun May 30, 2010 9:17 pm    Post subject: Reply with quote

ich pushe nochmal, im prinzip gehts zwar mit dem workaround, aber seltsam finde ich das schon
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Sun May 30, 2010 11:52 pm    Post subject: Reply with quote

Wie schon gesagt, die Einstellung damit rsync nicht als root läuft wäre FEATURES=usersync, was du ja aber nicht aktiviert hast. Und ich hatte ja extra nochmal gefragt als welcher User rsync läuft, insofern kann das eigentlich nicht das Problem sein. Hab aber auch keine Ahnung was es sonst sein könnte, ohne das jetzt komplett zu analysieren (was aus der Ferne ohnehin nur schwer möglich ist).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum