Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Epson C62 with CUPS, Could not print with Gimp
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
radsatori
n00b
n00b


Joined: 11 Sep 2003
Posts: 6
Location: Halifax, Nova Scotia

PostPosted: Thu Sep 11, 2003 11:11 am    Post subject: Epson C62 with CUPS, Could not print with Gimp Reply with quote

After setting up my CUPS printer and successfully testing it with lp on the command line, I still had a problem printing with GIMP. By running Gimp in a XTERM, I noticed that Gimp complained that it was unable to create a tmp file.

As per the following link, I noticed that I was missing a TMPDIR variable, and set it up by creating a new 99applications file in /etc/env.d adding the following line to it and doing a env-update.
TMPDIR="/tmp"

The link where I found the suggestion.
http://home.nyc.rr.com/computertaijutsu/cups.html

Please note, that GIMP when switching printers like to add the -oraw parameter in the command line, which you need to strip out so that it does not dump raw postscript code to the printer.

Another tip if you are new to CUPS, which I am, I finally caught on that the a good way to customize your print jobs is through a number of print devices added to CUPS, but with different names. Then customize each device with the parameters that you wish to use on that Queue. For example I create an epsonc62-economy printer, with bare minimum print quality in the configuration, to save ink.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum