Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
G5 fails to power off [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Sun May 30, 2010 3:57 am    Post subject: G5 fails to power off [SOLVED] Reply with quote

If I shut down from the KDE menu, it goes all the way to the end, finishing with remounting root read-only, but then it just stops there and after a minute or so the fans start to roar. If I choose restart, it does restart, but shutdown does not power off. How can I make it do so ? .config: http://www.pastebin.org/291513 and emerge --info: http://www.pastebin.org/291516.
_________________
Michael Mounteney


Last edited by mounty1 on Wed Jun 09, 2010 7:05 am; edited 1 time in total
Back to top
View user's profile Send private message
blob999
n00b
n00b


Joined: 07 Jun 2009
Posts: 64
Location: NATO area

PostPosted: Mon May 31, 2010 2:56 pm    Post subject: Reply with quote

there is a bug in linux-2.6.34, as i know it worked fine untill linux-2.6.32.
I've the same problem on my powermacg5 but with CRUX PPC 64bit.

http://lists.ozlabs.org/pipermail/linuxppc-dev/2010-April/081533.html
_________________
LinuxPPC user!
my blog: http://linuxpowerpc.blogspot.com/
Back to top
View user's profile Send private message
blob999
n00b
n00b


Joined: 07 Jun 2009
Posts: 64
Location: NATO area

PostPosted: Fri Jun 04, 2010 2:56 pm    Post subject: Reply with quote

mmh.. the same it happens with 2.6.33.5
_________________
LinuxPPC user!
my blog: http://linuxpowerpc.blogspot.com/
Back to top
View user's profile Send private message
bmaass
n00b
n00b


Joined: 15 Mar 2008
Posts: 25

PostPosted: Sun Jun 06, 2010 7:03 pm    Post subject: Reply with quote

Try turning off CONFIG_HIBERNATION in kernel.
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Sun Jun 06, 2010 10:11 pm    Post subject: done Reply with quote

CONFIG_HIBERATION=N in my kernel. Thanks for the suggestion though.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
blob999
n00b
n00b


Joined: 07 Jun 2009
Posts: 64
Location: NATO area

PostPosted: Tue Jun 08, 2010 6:37 pm    Post subject: Reply with quote

bmaass wrote:
Try turning off CONFIG_HIBERNATION in kernel.

Code:

root@powermacG5:~# cat /boot/config-2.6.33.5 |grep HIBERNATION
CONFIG_ARCH_HIBERNATION_POSSIBLE=y
# CONFIG_HIBERNATION is not set


it's disabled but it doesn't poweroff properly
_________________
LinuxPPC user!
my blog: http://linuxpowerpc.blogspot.com/
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Tue Jun 08, 2010 10:54 pm    Post subject: slippery eel Reply with quote

Code:
CONFIG_ARCH_HIBERNATION_POSSIBLE=y
Try turning it off ! Nothing in make menuconfig. If you do it manually, then make turns it back on before building! Really ! It rewrites .config before proceeding.

Later: hacked the Kconfig file to force it off. No difference; it still won't power off.

Solution: downgrade to 2.6.32-r7. It works.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
blob999
n00b
n00b


Joined: 07 Jun 2009
Posts: 64
Location: NATO area

PostPosted: Sat Jun 12, 2010 2:40 pm    Post subject: Reply with quote

well, lurking from #ppc64 i got the right hint! You need:

Code:
# CONFIG_SPARSE_IRQ is not set


now my CRUX PPC shutdown properly thus i suppose your GentooPPC 'll do the same.
_________________
LinuxPPC user!
my blog: http://linuxpowerpc.blogspot.com/
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Sun Jun 13, 2010 12:21 pm    Post subject: that's it ! Reply with quote

Thank you ! That works. If only I could get DRM working on 2.6.34, I could upgrade.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
bmaass
n00b
n00b


Joined: 15 Mar 2008
Posts: 25

PostPosted: Sun Jun 13, 2010 1:31 pm    Post subject: Reply with quote

blob999 wrote:
well, lurking from #ppc64 i got the right hint! You need:

Code:
# CONFIG_SPARSE_IRQ is not set


now my CRUX PPC shutdown properly thus i suppose your GentooPPC 'll do the same.
My G5 has sparse IRQ numbering, and powers off just fine. Do you know the reason it shouldn't work? Because it kinda does here...
Back to top
View user's profile Send private message
blob999
n00b
n00b


Joined: 07 Jun 2009
Posts: 64
Location: NATO area

PostPosted: Sun Jun 13, 2010 2:56 pm    Post subject: Reply with quote

someone on #ppc64 was talking about a bug (the poweroff disfunction on some pmac G5 was a consequence too) fixed with this patch:
http://lists.ozlabs.org/pipermail/linuxppc-dev/2010-June/083063.html
_________________
LinuxPPC user!
my blog: http://linuxpowerpc.blogspot.com/
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Sun Jun 13, 2010 11:04 pm    Post subject: patch the patch Reply with quote

I rewrote the patch as
Code:
...
     if (!desc || desc->status & IRQ_PER_CPU)
...
but that's a minor quibble.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
groomsi
n00b
n00b


Joined: 28 Jul 2010
Posts: 20
Location: New York

PostPosted: Sat Jul 31, 2010 6:38 pm    Post subject: Reply with quote

I have the exact same problem, so I expect that the solution here will work for me too. Unfortunately I didn't completely follow the discussion above. Should I downgrade the kernel? Rebuild my kernel with different options? Manually adjust the .config file? I appreciate your patience.
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 785
Location: Queensland

PostPosted: Sat Jul 31, 2010 11:52 pm    Post subject: No need to downgrade Reply with quote

No need to downgrade. All you have to do, in /usr/src/linux/arch/powerpc/kernel/irq.c at around line 297, is replace
Code:
if (desc && desc->status & IRQ_PER_CPU)
with
Code:
if (!desc || desc->status & IRQ_PER_CPU)
then recompile and install your kernel as usual. Presumably, hopefully, eventually, this fix will be incorporated into the official source, but until then you have to remember to re-apply the patch whenever you re-emerge the kernel source.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
groomsi
n00b
n00b


Joined: 28 Jul 2010
Posts: 20
Location: New York

PostPosted: Sun Aug 01, 2010 2:53 am    Post subject: no need to downgrade Reply with quote

It worked, thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum