Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Guide: Building a Stage1 using Gentoo and System Rescue CD
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Wed Apr 22, 2015 2:24 am    Post subject: Reply with quote

Wow.. It's been almost 5 years since I first started this thread, and I keep on updating it.

So, I added a few tweaks to the initial compile. For some reason, after GLIBC and BINUTILS compiles, nothing wants to compile saying GCC is busted. Well, I switched it around and compiled GCC first, then compiled BINUTILS and GLIBC and it's working perfectly.

I've been using this same script to compile my Raspberry Pi, Cubieboard1, and ODROID-C1, along with the MyBook Live (which is a PAIN with it being locked to a 2.6.32.x kernel). Still works great.

*EDIT* GCC was probably having issues due to me changing CHOST on the ARM boards. Separating them worked fine across all platforms, so I kept it.
Back to top
View user's profile Send private message
papandreoos
Tux's lil' helper
Tux's lil' helper


Joined: 17 Dec 2014
Posts: 136

PostPosted: Wed Jun 17, 2015 10:41 pm    Post subject: Reply with quote

find you on google search.
thank you for your work :-).
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Sun Nov 15, 2015 6:53 pm    Post subject: Reply with quote

Still around.. and the script still works.. and I'm still tweaking it.

I'm currently recompiling both MyBook Live's since kl_yang from the WD Community ported the 2.6.32 drivers to the 4.0/.1 kernel. For more information, https://community.wd.com/t/any-interests-in-kernel-4-0-on-my-book-live/60483
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Fri Dec 04, 2015 3:21 pm    Post subject: Reply with quote

Happy Holidays!

Anyway, I'm still tweakin' the script. I successfully compiled Gentoo along with a 4.1.13 kernel on my pair of MyBook Live drives.. and it works BEAUTIFULLY. I would highly suggest doing this to yours (since the warranty has probably expired awhile ago) unless you're using specific features.
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Thu Mar 03, 2016 4:52 am    Post subject: Reply with quote

Yep. Still here.

Did a few updates to the script, adding GCC 5.3.0, removing GCC 4.9.3, updating to Kernel 4.4, and stuff. I'm currently using it to recompile my Raspberry Pi A+ and a C.H.I.P.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Mar 06, 2016 1:19 am    Post subject: Reply with quote

Thanks for this !


Where was this thread 1 week ago :cry:


ah well, did a stage 3 install now,

next time it'll be a stage 1 again :D
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Tue May 10, 2016 2:11 pm    Post subject: Reply with quote

Added texinfo and iproute to the update area before bootstrap. For some reason, glibc-2.23-r2 keeps segfaulting at that point, but stops when I update those two.
Back to top
View user's profile Send private message
Simba7
l33t
l33t


Joined: 22 Jan 2007
Posts: 704
Location: Billings, MT, USA

PostPosted: Tue Oct 22, 2019 1:56 am    Post subject: Reply with quote

Greetings everyone. Yep. I'm still here.

I'm going to be updating the original post soon, but it keeps giving me a "Connection Reset". Not sure what's going on, but hopefully it'll be sorted out.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4
Page 4 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum