Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
AwesomeWM setzt Hintergrundbild nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
escorter
n00b
n00b


Joined: 26 May 2010
Posts: 10

PostPosted: Tue Jun 01, 2010 3:36 pm    Post subject: AwesomeWM setzt Hintergrundbild nicht Reply with quote

Hallo zusammen,

auf meinem Rechner habe ich Gentoo, gdm und AwesomeWM installiert. Leider setzt Awesome das Hintergrundbild nicht. Sobald ich aber Nautilus starte wird das Hintergrundbild gesetzt. Leider fehlt mir so der richtige Ansatz zum suchen.

Habt ihr eine Idee?

Gruß,
Gerrit
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Tue Jun 01, 2010 3:59 pm    Post subject: Reply with quote

Also Nautilus ist so ein Monstrum wie Explorer in Windows, er setzt unter anderem via gconf dein Hintergrundbild.

Ich kann mich erinnern, dass es da eine Commandline Option gab wie "--no-root" oder so. Da musst du mal in ein Terminal "nautilus --help" eingeben, leider kann man bei Gnome.org nichts dazu finden.
Diese Option laesst den Desktop in Ruhe, setzt kein hintergrund Bild und keine Shortcuts auf dem Desktop.

Fuer Awesome solltest du in deinem Profil eine Moeglichkeit haben dein "Theme" zu aendern in .config/awesome/

Generell klappt das aber bei mir auch nicht, deswegen habe ich einen Befehl in meine .xinit gepackt. Muss da spaeter mal Zuhause gucken.

Also 3 Optionen:
1. Nautilus im Hintergrund automatisch starten in der .xinit
nautilus &
2. Nautilus ohne den ganzen Desktop Krams starten und per config in deinem .config/awesome/ ordner das Theme anpassen
3. Nautilus ohne den ganzen Desktop Krams starten und ein kleines Programm vorweg starten das den Hintergrund setzt in der .xinit
xsetroot <irgendwas>
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
escorter
n00b
n00b


Joined: 26 May 2010
Posts: 10

PostPosted: Tue Jun 01, 2010 4:07 pm    Post subject: Reply with quote

also das starten von nautilus im hintergrund ist ja maximal ein workaround.
Wenn ich zuhause bin kann ich mal genau schauen, wie ich das Hintergrundbild gesetzt habe. Es ist in der rc.lua definiert aber den genauen Aufruf habe ich nicht im Kopf. Komisch finde ich, dass es das richtige Hintergrundbild ist und nicht irgend eins.

Gruß,
Gerrit
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Tue Jun 01, 2010 4:11 pm    Post subject: Reply with quote

Wenn du kein "custom" theme definierst, sucht er sich die Hintergruende aus /usr/share/themes glaube. Das kannst du ihm aber alles in der rc.lua sagen.

Nichtsdestotrotz wird Nautilus deinen Hintergrund wieder ueberschreiben, wenn du ihm nicht sagt den Desktop in Ruhe zu lassen.
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
escorter
n00b
n00b


Joined: 26 May 2010
Posts: 10

PostPosted: Tue Jun 01, 2010 4:17 pm    Post subject: Reply with quote

hmm, dann werde ich mal schauen, ob es per Zufall dort zu finden ist. Habe mir die lua Datei des default Themes kopiert und dort das Hintergrundbild eingefügt.

Laut http://pwet.fr/man/linux/commandes/nautilus müsste die richtige Option --no-desktop heißen, was dies aber nun konkret heißt und welche Features deaktiviert werden ist mir nicht ganz klar.

Die verschiedenen Optionen werde ich mal bei mir zu Hause probieren.

Wenn ich hier gerade einen awesome Experten habe. In der rc.lua wird bei mir mittels TERMINAL=urxvt das Terminal gesetzt. Mit der Kombination STRG+ENTER öffnet sich allerdings ein xterm. Kann ich überprüfen, ob die lua Datei überhaupt benutzt wird?

Gruß,
Gerrit
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Tue Jun 01, 2010 5:07 pm    Post subject: Reply with quote

In meinem Skript ist die variable terminal und nicht TERMINAL
Code:
-- This is used later as the default terminal and editor to run.
terminal = "mrxvt"
editor = os.getenv("EDITOR") or "nano"
editor_cmd = terminal .. " -e " .. editor


guck mal nach dieser Zeile:
Code:
awful.key({ modkey,           }, "Return", function () awful.util.spawn(terminal) end),


Bei mir ist die variable "klein" geschrieben.

meine .xinitrc:
Code:
disi@disi-desktop ~ $ cat .xinitrc
#!/bin/sh
setxkbmap gb &
gmpc &
feh --bg-scale /home/disi/pictures/wallpapers/blubb_wallpaper.png &
xcompmgr -c -t-5 -l-5 -r4.2 -o.55 &
exec /usr/bin/awesome


Mit feh hast du keine Probleme mehr, wenn du nautilus ohne Desktop startest. (musst du aber erst installieren)
Der Grund warum ich "feh" nehme ist, das xcompmgr sonst nicht richtig funzt. Es muss ein ordentlicher root background gesetzt sein.
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
jodel
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 113

PostPosted: Tue Jun 01, 2010 5:29 pm    Post subject: Reply with quote

Mit Nitrogen kann man auch ganz gut seinen Hintergrund setzen, z.B. im theme file:

Code:
theme.wallpaper_cmd = { "/usr/bin/nitrogen --restore" }



der klassische Weg:

Code:
theme.wallpaper_cmd = { "awsetbg /usr/share/awesome/themes/zenburn/zenburn-background.png" }



ich hab allerdings in letzter Zeit mein Wallpaper komplett deaktiviert, da man es bei tiling WMs eh meist nicht sieht.
Back to top
View user's profile Send private message
disi
Veteran
Veteran


Joined: 28 Nov 2003
Posts: 1354
Location: Out There ...

PostPosted: Tue Jun 01, 2010 6:50 pm    Post subject: Reply with quote

jodel wrote:

ich hab allerdings in letzter Zeit mein Wallpaper komplett deaktiviert, da man es bei tiling WMs eh meist nicht sieht.



Ausser du benutzt xcompmgr :)
Finde das schon schoener, wenn der Hintergrund durchs Terminal guckt.
_________________
Gentoo on Uptime Project - Larry is a cow
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum