Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] xorg läuft nicht. Intel Graka auf altem Laptop
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Tue Jun 01, 2010 5:54 pm    Post subject: [gelöst] xorg läuft nicht. Intel Graka auf altem Laptop Reply with quote

Nabend,

habe hier ein "älteren" Laptop (Maxdata Pro 6100x) mit einer Intel Grafikkarte. Habe hier frisch ein stable Gentoo installiert, aber bekomme xorg nicht zum laufen.
Mit "Xorg -configure" bekomme ich einen Segmentation fault [1]. Mache ich nur startx, hängt sich der Laptop komplett auf - mit einem schwarzen Bildschirm und keine Reaktion auf Eingaben (nichtmal mehr ein ssh connection funktioniert dann noch).
Ideen wie ich das Ding zum laufen bekomme? Habe noch keine xorg.conf erstellt da ich dachte das Teil würde mit HAL laufen...

[1]
Code:
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.32-gentoo-r7 i686
Current Operating System: Linux laptop 2.6.32-gentoo-r7 #2 SMP Tue Jun 1 13:54:46 CEST 2010 i686
Kernel command line: root=/dev/hda6
Build Date: 01 June 2010  12:38:44PM
 
Current version of pixman: 0.17.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun  1 14:45:09 2010
(II) Loader magic: 0x81e6a80                                                                                                                                                                                 
(II) Module ABI versions:                                                                                                                                                                                     
        X.Org ANSI C Emulation: 0.4                                                                                                                                                                           
        X.Org Video Driver: 6.0                                                                                                                                                                               
        X.Org XInput driver : 7.0                                                                                                                                                                             
        X.Org Server Extension : 2.0                                                                                                                                                                         
(--) using VT number 7                                                                                                                                                                                       
                                                                                                                                                                                                             
(--) PCI:*(0:0:2:0) 8086:3582:152d:0727 Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xe8000000/134217728, 0xe0000000/524288, I/O @ 0x00001800/8                                     
(--) PCI: (0:0:2:1) 8086:3582:152d:0727 Intel Corporation 82852/855GM Integrated Graphics Device rev 2, Mem @ 0xf0000000/134217728, 0xe0080000/524288                                                         
List of video drivers:                                                                                                                                                                                       
        sis                                                                                                                                                                                                   
        openchrome                                                                                                                                                                                           
        vmware                                                                                                                                                                                               
        glint                                                                                                                                                                                                 
        tdfx                                                                                                                                                                                                 
        savage                                                                                                                                                                                               
        radeon
        trident
        nv
        mach64
        ati
        neomagic
        intel
        mga
        vmwlegacy
        r128
        fbdev
        vesa
(II) LoadModule: "sis"
(II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
(II) Module sis: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 0.10.2
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "openchrome"
(II) Loading /usr/lib/xorg/modules/drivers/openchrome_drv.so
(II) Module openchrome: vendor="http://openchrome.org/"
        compiled for 1.7.6, module version = 0.2.904
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(II) LoadModule: "vmware"
(II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
(II) Module vmware: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 11.0.1
        Module class: X.Org Video Driver
        ABI class: X.Org Video Driver, version 6.0
(--) vmware: X configured to use vmwgfx X driver assume who ever did that knows what they are doing
(--) vmware: Please ignore above "[drm] failed to load kernel  module "vmwgfx""
(II) vmware: Using vmwlegacy driver everything is fine.

Backtrace:
0: Xorg (xorg_backtrace+0x3b) [0x80ac8fb]
1: Xorg (0x8048000+0x61665) [0x80a9665]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb780d40c]
3: Xorg (0x8048000+0x10e977) [0x8156977]
4: Xorg (xf86LoadModules+0xe0) [0x80af920]
5: Xorg (DoConfigure+0x7b) [0x815abab]
6: Xorg (InitOutput+0xae7) [0x80b1f47]
7: Xorg (0x8048000+0x1dc21) [0x8065c21]
8: /lib/libc.so.6 (__libc_start_main+0xe5) [0xb7349a65]
9: Xorg (0x8048000+0x1d991) [0x8065991]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Code:
# emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0/desktop/kde, gcc-4.3.4, glibc-2.10.1-r1, 2.6.32-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.32-gentoo-r7-i686-Intel-R-_Pentium-R-_M_processor_1.60GHz-with-gentoo-1.12.13
Timestamp of tree: Mon, 31 May 2010 10:00:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.65
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk hal iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3support qt4 readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Last edited by BlackEye on Tue Jun 01, 2010 6:57 pm; edited 2 times in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Tue Jun 01, 2010 6:37 pm    Post subject: Reply with quote

Hi
Quote:
List of video drivers:
sis
openchrome
vmware
glint
tdfx
savage
radeon
trident
nv
mach64
ati
neomagic
intel
mga
vmwlegacy
r128
fbdev
vesa
(II) LoadModule: "sis"
Benötigst du wirklich so viele verschiedene Treiber?
wenn nein, dann deinstalliere die nicht benötigten besser wieder, und erstelle zumindest eine minimale xorg.conf wo der benötigte Treiber angegeben ist.
Siehe zb auch http://en.gentoo-wiki.com/wiki/Intel_GMA
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Tue Jun 01, 2010 6:56 pm    Post subject: Reply with quote

Ah super, danke. Ich denke die ganzen Treiber waren das Problem. Hatte die VIDEO_CARDS Zeile zu spät in die make.conf eingefügt und da hat er wohl die Tonnen an Treiber installiert.

Klappt :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum