Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu][xorg]configuration xorg et souris
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Wed Jun 02, 2010 9:07 pm    Post subject: [Résolu][xorg]configuration xorg et souris Reply with quote

Bonjour,

Je suis débutant sur gentoo, et je galère dans la configuration de xorg. J'ai bien compris que le xorg.conf est déprécié
et on devrai utiliser xorg.conf.d

Le hic, c'est que je ne vois pas comment configurer le clavier, la souris, le screen, etc. Auriez-vous des exemples de configuration
à me donner svp ?

Pour le moment j'ai un fichier xorg.conf avec tout dedans, comme je le faisais sur debian. Mais ma souris ne fonctionne pas.

J'espère que vous pourrez m'aider.
_________________
- zerros -


Last edited by zerros on Wed Jun 30, 2010 8:27 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8129
Location: ~Brussels - Belgique

PostPosted: Thu Jun 03, 2010 6:06 am    Post subject: Reply with quote

Salut,

Rien ne t'empêche d'avoir un seul gros fichier xorg.conf.

Montre-le nous stp, nous regarderons ensemble ce qui ne va pas.

(Le but de Gentoo n'est pas de donner des solutions toutes faites, mais d'apprendre ensemble ;))
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Thu Jun 03, 2010 8:15 am    Post subject: Reply with quote

Merci pour la réponse. Voilà mon xorg.conf. J'ai réussi à faire fonctionner ma souris USB sur mon WindowMaker avec evdev.
Par contre impossible de faire fonctionner ma PS/2. Pas de /dev/psaux de créer, alors je pense qu'il doit me manquer quelque
chose dans mon kernel pour la reconnaissance de ma souris PS/2.

J'utilise slim comme gestionnaire de login, et je n'ai pas de souris du tout sur le login. Je ne vois pas bien pourquoi.

Voilà mon fichier :

Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen       0 "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "evdev"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/event5"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "XkbModel" "pc105"
    Option         "XkbLayout" "fr"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ACI PW201"
    HorizSync       30.0 - 80.0
    VertRefresh     55.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8600 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

_________________
- zerros -
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Thu Jun 03, 2010 5:12 pm    Post subject: Reply with quote

Pas de souris dans SLiM c'est normal, enfin moi j'en ai jamais eu alors que tt marche. Sinon compile X.org avec le support pour HAL et tout devrais marcher nickel. Et pour la souris PS/2 dans le noyau :
Code:
Device Drivers -->
     Input Device support -->
          Mice -->
Back to top
View user's profile Send private message
zerros
Apprentice
Apprentice


Joined: 02 Jun 2010
Posts: 179

PostPosted: Thu Jun 03, 2010 5:32 pm    Post subject: Reply with quote

Ca y est mon awesome fonctionne après le passage en desktop.

J'ai recompilé le noyau et la souris psaux marche également.

Il ne me reste plus qu'à chercher comment configurer awesome. merci pour l'aide.
_________________
- zerros -
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Sun Jun 06, 2010 12:09 pm    Post subject: Reply with quote

T'as le wiki en français ici mais tu as déjà du le trouver. Sinon avant de passer à KDE j'utilisais Fluxbox. Il est pas mal du tt aussi, mais pr ma culture générale, pourrais-tu me dire les avantages que tu trouves à Awesome par rapport aux autres gestionnaires de fenêtres "évolués" ?
Merci
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Jun 06, 2010 1:14 pm    Post subject: Reply with quote

Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum s'il te plait ? Merci :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum