Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qemu on ppc host, Ubuntu guest, no input
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 754
Location: Queensland

PostPosted: Sun Jun 06, 2010 11:29 am    Post subject: qemu on ppc host, Ubuntu guest, no input Reply with quote

Well, as per title. I want to install Ubuntu 9.10 (x86) on a qemu virtual machine running on a Gentoo ppc host. The command line is:
Code:
qemu -hda linux.img -cdrom vault/ubuntu-9.10-desktop-i386.is-net nic,vlan=0 -net user,vlan=0 -net nic,vlan=1 -net tap,vlan=1,ifname=tap0,script=bin/ifup,downscript=bin/ifdown -m 384
and once the CD boots up I select try without installing. The boot continues to the expected X desktop when several error dialogs appear.
  • The panel encountered a problem while loading "OAFIID:GNOME_FastUserSwitchApplet". Do you want to delete the applet from your configuration ? [Don't Delete] [Delete]
  • Sorry, the program "jockey-gtk" closed unexpectedly. If you were not doing anything confidential (entering passwords or other private information), you can help to improve the application by reporting the problem [...]
There is a third error message, according to the task bar, but no dialog therefor appears. Anyway, the main and real problem is that no input, keyboard or mouse, is accepted. It is not even possible to move the mouse pointer. Input was accepted when qemu first started ((I chose try without installing using arrow keys and the enter key). the qemu window knows it has focus because the title changes to QEMU - press ctrl-alt to exit grab but that is the only keystroke the does anything. I can't dismiss, move or affect the error dialogs in any way.

Any ideas ?
_________________
Michael Mounteney
Back to top
View user's profile Send private message
mounty1
l33t
l33t


Joined: 06 Jul 2006
Posts: 754
Location: Queensland

PostPosted: Wed Jun 09, 2010 7:03 am    Post subject: Must be Ubuntu Reply with quote

It works alright with the Gentoo live CD, so this must just be an Ubuntism.
_________________
Michael Mounteney
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum