Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Mehrfaches "emerge --update --deep world" ...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Whitewolf Fox
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2004
Posts: 78
Location: Ratingen

PostPosted: Sun Jun 06, 2010 9:14 pm    Post subject: [SOLVED] Mehrfaches "emerge --update --deep world" Reply with quote

Hallo zusammen,

ich taste mich nach längerem mal wieder etwas an Gentoo heran.
Mir ist folgendes aufgefallen, das ich nicht verstehe:

Wenn ich "emerge --update --deep world" ausführe, um die jeweils aktuellsten aller installierten Pakete zu installieren, dann klappt alles wunderbar.
Nachdem Portage hiermit fertig ist, und wenn ich _ohne_ "emerge --sync" auszuführen nochmal "emerge --update --deep world" ausführe, möchte Portage erneut die zuvor aktualisierten Pakete installieren.

Kann mir jemand erklären wieso? Meines Verständnisses nach sollten nach einmaligem ausführen doch alle aktuellen Pakete installiert worden sein. Selbst wenn es inzwischen X Aktualisierungen im Portage-Tree gäbe, sollte mein lokales System ohne abholen desselbigen ("emerge --sync") doch hiervon garnichts mitbekommen, oder? Auch USE FLags oder ähnliches wurden nicht verändert.

Vielen Dank schonmal.
_________________
http://www.marc-richter.info


Last edited by Whitewolf Fox on Mon Jun 07, 2010 2:52 pm; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3716
Location: Germany

PostPosted: Sun Jun 06, 2010 10:32 pm    Post subject: Reply with quote

Hm.. ungewöhnlich...

Magst du das mal an einem Beispiel Paket demonstrieren?!
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Sun Jun 06, 2010 10:51 pm    Post subject: Reply with quote

Und bitte auch dazu die Portage-Version angeben (bzw gleich ein emerge --info)
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
Whitewolf Fox
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2004
Posts: 78
Location: Ratingen

PostPosted: Mon Jun 07, 2010 2:53 pm    Post subject: Reply with quote

Hallo zusammen,

sorry, das scheint sich inzwischen selbst erledigt zu haben ... konnte es letzte Woche mehrfach nachstellen - nun nicht mehr.

Ich habe einmal den aktuellen Portage - Tree geholt, "emerge --update --deep world" ausgeführt, durchlaufen lassen und bei einem zweiten Aufruf kam nichts mehr.

Vielen Dank!
_________________
http://www.marc-richter.info
Back to top
View user's profile Send private message
cyril_sneer
n00b
n00b


Joined: 10 Mar 2010
Posts: 25
Location: Hamburg

PostPosted: Mon Jun 07, 2010 6:12 pm    Post subject: Reply with quote

Idee: Kann es sein, dass, als der Fehler auftrat, emerge nicht sauber durchgelaufen ist, und somit die Pakete gar nicht aktualisiert wurden?
Back to top
View user's profile Send private message
Whitewolf Fox
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2004
Posts: 78
Location: Ratingen

PostPosted: Tue Jun 08, 2010 6:10 pm    Post subject: Reply with quote

Ich kann dem Log weder das eine noch das andere entnehmen ... :P

Naja: Hauptsache ich habe doch verstanden wie Portage sich hier verhält ;)
_________________
http://www.marc-richter.info
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum