Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge]kdm ne démarre plus ![resolu]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 7:39 am    Post subject: [emerge]kdm ne démarre plus ![resolu] Reply with quote

Bonjour,

Suite à ma dernière mise à jour en redémarrant mon PC kdm ne démarre plus te je suis en invite de commande.
Un login sous mon user et un startx me donne un écran noir et une fenêtre signalant un message d'erreur (que j'ia pas noté comme un gros niais !).

Au prompt des erreurs au démarrage :
check d'un disque
mysql ne démarre pas
apache non plus !
ainsi que mediatomb (à cause de Mysql je pense !)
et ensuite kdm.

Ma dernière mise à jour ne me semble pas avoir touché à ces paquets, la voici :
Code:
ben@ataualpa ~ $ sudo tail -300 /var/log/emerge.log | grep ">>>"
Password:
1274806862:  >>> unmerge success: media-gfx/inkscape-0.47
1276067822: >>> Starting rsync with rsync://134.68.240.58/gentoo-portage
1276073966:  >>> emerge (1 of 33) app-portage/portage-utils-0.3.1 to /
1276074024:  >>> AUTOCLEAN: app-portage/portage-utils:0
1276074027:  >>> unmerge success: app-portage/portage-utils-0.2.1
1276074030:  >>> emerge (2 of 33) gnome-base/gnome-common-2.28.0 to /
1276074056:  >>> AUTOCLEAN: gnome-base/gnome-common:3
1276074059:  >>> unmerge success: gnome-base/gnome-common-2.26.0
1276074063:  >>> emerge (3 of 33) media-libs/freetype-2.3.12 to /
1276074348:  >>> AUTOCLEAN: media-libs/freetype:2
1276074354:  >>> unmerge success: media-libs/freetype-2.3.11
1276074358:  >>> emerge (4 of 33) x11-misc/util-macros-1.8.0 to /
1276074391:  >>> AUTOCLEAN: x11-misc/util-macros:0
1276074394:  >>> unmerge success: x11-misc/util-macros-1.6.1
1276074397:  >>> emerge (5 of 33) dev-db/sqlite-3.6.23.1 to /
1276074770:  >>> AUTOCLEAN: dev-db/sqlite:3
1276074773:  >>> unmerge success: dev-db/sqlite-3.6.22-r2
1276074777:  >>> emerge (6 of 33) dev-libs/openssl-0.9.8o to /
1276075373:  >>> AUTOCLEAN: dev-libs/openssl:0
1276075378:  >>> unmerge success: dev-libs/openssl-0.9.8n
1276075381:  >>> emerge (7 of 33) sys-devel/binutils-2.20.1-r1 to /
1276076127:  >>> AUTOCLEAN: sys-devel/binutils:0
1276076136:  >>> unmerge success: sys-devel/binutils-2.18-r3
1276076140:  >>> emerge (8 of 33) net-libs/gnutls-2.8.6 to /
1276076826:  >>> AUTOCLEAN: net-libs/gnutls:0
1276076829:  >>> unmerge success: net-libs/gnutls-2.8.5
1276076833:  >>> emerge (9 of 33) sys-devel/gcc-4.4.3-r2 to /
1276086244:  >>> AUTOCLEAN: sys-devel/gcc:4.4
1276086285:  >>> emerge (10 of 33) app-text/docbook-xml-dtd-4.3-r1 to /
1276086301:  >>> AUTOCLEAN: app-text/docbook-xml-dtd:4.3
1276086305:  >>> emerge (11 of 33) x11-themes/gnome-icon-theme-2.28.0 to /
1276086442:  >>> AUTOCLEAN: x11-themes/gnome-icon-theme:0
1276086459:  >>> unmerge success: x11-themes/gnome-icon-theme-2.26.0
1276086466:  >>> emerge (12 of 33) app-admin/eselect-python-20100321 to /
1276086496:  >>> AUTOCLEAN: app-admin/eselect-python:0
1276086498:  >>> unmerge success: app-admin/eselect-python-20091230
1276086501:  >>> emerge (13 of 33) dev-python/sip-4.10.2 to /
1276086575:  >>> AUTOCLEAN: dev-python/sip:0
1276086577:  >>> unmerge success: dev-python/sip-4.10
1276086582:  >>> emerge (14 of 33) dev-lang/python-3.1.2-r3 to /
1276087124:  >>> AUTOCLEAN: dev-lang/python:3.1
1276087160:  >>> emerge (15 of 33) dev-util/gtk-doc-am-1.13 to /
1276087192:  >>> AUTOCLEAN: dev-util/gtk-doc-am:0
1276087194:  >>> unmerge success: dev-util/gtk-doc-am-1.11
1276087196:  >>> emerge (16 of 33) dev-libs/glib-2.22.5 to /
1276087910:  >>> AUTOCLEAN: dev-libs/glib:2
1276087913:  >>> unmerge success: dev-libs/glib-2.22.4
1276087917:  >>> emerge (17 of 33) dev-libs/dbus-glib-0.86 to /
1276087996:  >>> AUTOCLEAN: dev-libs/dbus-glib:0
1276087998:  >>> unmerge success: dev-libs/dbus-glib-0.82-r1
1276088000:  >>> emerge (18 of 33) x11-libs/pango-1.26.2 to /
1276088263:  >>> AUTOCLEAN: x11-libs/pango:0
1276088266:  >>> unmerge success: x11-libs/pango-1.24.5-r1
1276088270:  >>> emerge (19 of 33) app-admin/syslog-ng-3.0.6 to /
1276088353:  >>> AUTOCLEAN: app-admin/syslog-ng:0
1276088356:  >>> unmerge success: app-admin/syslog-ng-3.0.4
1276088359:  >>> emerge (20 of 33) sys-auth/consolekit-0.4.1 to /
1276088465:  >>> AUTOCLEAN: sys-auth/consolekit:0
1276088468:  >>> unmerge success: sys-auth/consolekit-0.3.0-r2
1276088471:  >>> emerge (21 of 33) gnome-base/orbit-2.14.18 to /
1276088711:  >>> AUTOCLEAN: gnome-base/orbit:2
1276088714:  >>> unmerge success: gnome-base/orbit-2.14.17
1276088718:  >>> emerge (22 of 33) x11-wm/openbox-3.4.11.1 to /
1276088870:  >>> AUTOCLEAN: x11-wm/openbox:3
1276088873:  >>> unmerge success: x11-wm/openbox-3.4.10
1276088876:  >>> emerge (23 of 33) app-admin/sudo-1.7.2_p7 to /
1276088961:  >>> AUTOCLEAN: app-admin/sudo:0
1276088964:  >>> unmerge success: app-admin/sudo-1.7.2_p4
1276088967:  >>> emerge (24 of 33) x11-libs/gtk+-2.18.9 to /
1276090735:  >>> AUTOCLEAN: x11-libs/gtk+:2
1276090739:  >>> unmerge success: x11-libs/gtk+-2.18.6
1276090743:  >>> emerge (25 of 33) net-wireless/bluez-4.63 to /
1276090944:  >>> AUTOCLEAN: net-wireless/bluez:0
1276090947:  >>> unmerge success: net-wireless/bluez-4.39-r2
1276090951:  >>> emerge (26 of 33) app-text/ghostscript-gpl-8.71-r1 to /
1276092350:  >>> AUTOCLEAN: app-text/ghostscript-gpl:0
1276092354:  >>> unmerge success: app-text/ghostscript-gpl-8.64-r3
1276092358:  >>> emerge (27 of 33) gnome-base/gconf-2.28.1 to /
1276092488:  >>> AUTOCLEAN: gnome-base/gconf:2
1276092493:  >>> unmerge success: gnome-base/gconf-2.26.2-r1
1276092497:  >>> emerge (28 of 33) x11-libs/libwnck-2.28.0 to /
1276092638:  >>> AUTOCLEAN: x11-libs/libwnck:0
1276092642:  >>> unmerge success: x11-libs/libwnck-2.26.2-r2
1276092646:  >>> emerge (29 of 33) gnome-extra/libgsf-1.14.18 to /
1276092785:  >>> AUTOCLEAN: gnome-extra/libgsf:0
1276092788:  >>> unmerge success: gnome-extra/libgsf-1.14.15
1276092794:  >>> emerge (30 of 33) gnome-base/librsvg-2.26.2 to /
1276092969:  >>> AUTOCLEAN: gnome-base/librsvg:2
1276092972:  >>> unmerge success: gnome-base/librsvg-2.26.0
1276092976:  >>> emerge (31 of 33) dev-python/PyQt4-4.7.3 to /
1276094754:  >>> depclean
1276094822:  >>> unmerge success: sys-devel/gcc-4.3.4
1276095791:  >>> emerge (1 of 1) media-gfx/imagemagick-6.6.1.2 to /


Lors de ces mises à jour j'ai fait un depclean et un revdep-rebuild qui n'ont rien remontés si ce n'est media-gfx/imagemagick-6.6.1.2

Je ne sais pas trop comment investiguer sur ce problème pour en trouver la cause et la réparer !
Help me please !


Last edited by BENJI on Mon Jul 26, 2010 7:57 am; edited 1 time in total
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Jun 11, 2010 8:24 am    Post subject: Reply with quote

Tu n'aurais pas oublie de faire un dispatch-conf ?
A la fin de la maj il t'a pas dit qu'il y avait des modif de /etc ?
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 8:27 am    Post subject: Reply with quote

C'est une bonne remarque mais non j'ai fait ça bien ! Même si moi j'utilise plutôt etc-update
Code:
ataualpa ben # etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)


En même temps tous les fichiers de conf qui été impactés ne m'étant pas connu j'ai fait un merge automatique.
De mémoire il y avait du syslog et je ne sais plus quoi d'autre !
Y a t-il un moyen de retrouver l'historique des fichiers modifiés ?
Back to top
View user's profile Send private message
KeNNys
Apprentice
Apprentice


Joined: 08 Mar 2010
Posts: 155
Location: Bourges (centre 18)

PostPosted: Fri Jun 11, 2010 8:54 am    Post subject: Reply with quote

que donne ton fichier log pour xorg ?
je crois que le chemin c'est ;
/var/log/Xorg.0.log
_________________
KeNNys
---------------
Gentoo
---------------
Think Linux
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 9:13 am    Post subject: Reply with quote

Le voici, je me demande s'il n'y en a pas un autre à checker :
Code:
ben@ataualpa ~ $ sudo cat /var/log/Xorg.0.log
Password:

X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.31-gentoo-r10 i686
Current Operating System: Linux ataualpa 2.6.31-gentoo-r10 #2 Thu Mar 11 16:39:33 CET 2010 i686
Kernel command line: root=/dev/hdb2 acpi=force
Build Date: 19 April 2010  09:43:23PM

Current version of pixman: 0.17.2
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Jun 11 09:24:41 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "AutoAddDevices" "False"
(**) Not automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Extension "Composite" is enabled
(II) Loader magic: 0x81ece80
(II) Module ABI versions:
        X.Org ANSI C Emulation: 0.4
        X.Org Video Driver: 6.0
        X.Org XInput driver : 7.0
        X.Org Server Extension : 2.0
(--) using VT number 7

(--) PCI:*(0:1:0:0) 10de:0253:0000:0000 nVidia Corporation NV25 [GeForce4 Ti 4200] rev 163, Mem @ 0xde000000/16777216, 0xd0000000/134217728, 0xddc80000/524288, BIOS @ 0x????????/131072
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded. This was enabled by default and also specified in the config file.
(II) "dri" will be loaded by default.
(II) "dri2" will be loaded by default.
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.0.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions/librecord.so
(II) Module record: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.13.0
        Module class: X.Org Server Extension
        ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "xtrap"
(WW) Warning, couldn't open module xtrap
(II) UnloadModule: "xtrap"
(EE) Failed to load module "xtrap" (module does not exist, 0)
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Server Extension
(II) NVIDIA GLX Module  96.43.14  Sun Nov  8 18:24:17 PST 2009
(II) Loading extension GLX
(II) LoadModule: "dri"
(WW) Warning, couldn't open module dri
(II) UnloadModule: "dri"
(EE) Failed to load module "dri" (module does not exist, 0)
(II) LoadModule: "dri2"
(WW) Warning, couldn't open module dri2
(II) UnloadModule: "dri2"
(EE) Failed to load module "dri2" (module does not exist, 0)
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.5.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.4.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 7.0
(II) NVIDIA dlloader X Driver  96.43.14  Sun Nov  8 18:12:51 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules/libfb.so
(II) Module fb: vendor="X.Org Foundation"
        compiled for 1.7.6, module version = 1.0.0
        ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "UseEvents" "false"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce4 Ti 4200 at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 04.25.00.37.27
(II) NVIDIA(0): Detected AGP rate: 2X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce4 Ti 4200 at PCI:1:0:0:
(--) NVIDIA(0):     Samsung SyncMaster (DFP-0)
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): Samsung SyncMaster (DFP-0): External Single Link TMDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(WW) NVIDIA(0):
(WW) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
(WW) NVIDIA(0):     will be used as the requested mode.
(WW) NVIDIA(0):
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) NVIDIA(0): DPI set to (89, 87); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(--) Depth 24 pixmap format is 32 bpp
(II) NVIDIA(0): Initialized GART.
(II) NVIDIA(0): Setting mode "nvidia-auto-select"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(==) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(**) Option "Protocol" "auto"
(**) Option "Device" "/dev/input/mice"
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse0: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse0: Buttons: 11
(**) Mouse0: Sensitivity: 1
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(**) Mouse0: (accel) keeping acceleration scheme 1
(**) Mouse0: (accel) acceleration profile 0
(II) Mouse0: Setting mouse protocol to "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(**) Option "CoreKeyboard"
(**) Keyboard0: always reports core events
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "XkbRules" "base"
(**) Keyboard0: XkbRules: "base"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "fr"
(**) Keyboard0: XkbLayout: "fr"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) config/hal: Adding input device HID 062a:0000
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) config/hal: Adding input device Sleep Button
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) config/hal: Adding input device Power Button
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) config/hal: Adding input device Power Button
(II) AutoAddDevices is off - not adding device.
(EE) config/hal: NewInputDeviceRequest failed (8)
(II) UnloadModule: "mouse"
(II) UnloadModule: "kbd"

les erreurs hal !
Code:
ben@ataualpa ~ $ sudo grep EE /var/log/Xorg.0.log
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) Failed to load module "xtrap" (module does not exist, 0)
(EE) Failed to load module "dri" (module does not exist, 0)
(EE) Failed to load module "dri2" (module does not exist, 0)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)
(EE) config/hal: NewInputDeviceRequest failed (8)

un lien avec dbus-glib peut-être ?
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri Jun 11, 2010 12:18 pm    Post subject: Reply with quote

T'as pensé à faire après la maj :
Code:
# emerge --depclean -a

et
Code:
# revdep-rebuild

?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 1:09 pm    Post subject: Reply with quote

oui oui,
enfin à tout hasard je viens de le relancer mais j'ai peu d'espoir !
qqn a une autre idée là moi je sèche !

EDIT==
Code:
ataualpa ben # emerge --depclean -a

 * Depclean may break link level dependencies.  Thus, it is
 * recommended to use a tool such as `revdep-rebuild` (from
 * app-portage/gentoolkit) in order to detect such breakage.
 *
 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always
 * be kept.  They can be manually added to this set with
 * `emerge --noreplace <atom>`.  Packages that are listed in
 * package.provided (see portage(5)) will be removed by
 * depclean, even if they are part of the world set.
 *
 * As a safety measure, depclean will not remove any packages
 * unless *all* required dependencies have been resolved.  As a
 * consequence, it is often necessary to run `emerge --update
 * --newuse --deep world` prior to depclean.

Calculating dependencies... done!
>>> No packages selected for removal by depclean
>>> To see reverse dependencies, use --verbose
Packages installed:   855
Packages in world:    80
Packages in system:   50
Required packages:    855
Number removed:       0

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Par contre le revdep rebuilt est encours et remonte plein de lien broken.
Très curieux.
Je viens de faire la vérif dans l'historique de mes commandes et j'ia bien fait un deplclean suivi d'un revdep-rebuild qui n'avait rien remonté comme problème. J'attends la fin de l'analyse pour vous tenir au jus !


Last edited by BENJI on Fri Jun 11, 2010 1:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 1:16 pm    Post subject: Reply with quote

Code:
emerge -1av glib dbus-glib

et si ça ne va pas, il va falloir recompiler plein de paquets:
Code:
emerge -1av `equery d glib`

_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 1:24 pm    Post subject: Reply with quote

Voilà le résultat du revdep-rebuild :
Code:
 * Messages for package media-gfx/imagemagick-6.6.1.2:

 * ERROR: media-gfx/imagemagick-6.6.1.2 failed:
 *   unexpected portageq exit code: 2
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 1575:  Called has_version '=sys-devel/gcc-*[openmp]'
 *     ebuild.sh, line  184:  Called die
 * The specific snippet of code:
 *                      die "unexpected portageq exit code: ${retval}"
 *
 * If you need support, post the output of 'emerge --info =media-gfx/imagemagick-6.6.1.2',
 * the complete build log and the output of 'emerge -pqv =media-gfx/imagemagick-6.6.1.2'.
 * The complete build log is located at '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/temp/environment'.
 * S: '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work/ImageMagick-6.6.1-2'

le log ici :
Code:
ataualpa ben # less /var/tmp/portage/media-gfx/imagemagick-6.6.1.2/temp/build.log
 * CPV:  media-gfx/imagemagick-6.6.1.2
 * REPO: gentoo
 * USE:  X bzip2 cxx elibc_glibc jpeg kernel_linux lcms openmp perl png svg tiff truetype userland_GNU x86 xml zlib
sandbox:main  signal SIGQUIT already had a handler ...

>>> Unpacking source...
>>> Unpacking ImageMagick-6.6.1-2.tar.xz to /var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work
>>> Source unpacked in /var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work
sandbox:main  signal SIGQUIT already had a handler ...

>>> Preparing source in /var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work/ImageMagick-6.6.1-2 ...
>>> Source prepared.
sandbox:main  signal SIGQUIT already had a handler ...

>>> Configuring source in /var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work/ImageMagick-6.6.1-2 ...
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-gcc'
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-gcc'
ERROR: Invalid atom: '=sys-devel/gcc-*[openmp]'
 * ERROR: media-gfx/imagemagick-6.6.1.2 failed:
 *   unexpected portageq exit code: 2
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 1575:  Called has_version '=sys-devel/gcc-*[openmp]'
 *     ebuild.sh, line  184:  Called die
 * The specific snippet of code:
 *                      die "unexpected portageq exit code: ${retval}"
 *
 * If you need support, post the output of 'emerge --info =media-gfx/imagemagick-6.6.1.2',
 * the complete build log and the output of 'emerge -pqv =media-gfx/imagemagick-6.6.1.2'.
 * The complete build log is located at '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/temp/environment'.
 * S: '/var/tmp/portage/media-gfx/imagemagick-6.6.1.2/work/ImageMagick-6.6.1-2'
sandbox:main  signal SIGQUIT already had a handler ...

ça change qqch à ta réponse précédente ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 1:41 pm    Post subject: Reply with quote

Je viens de voir que dans mon tout premier emerge python 3 vient d'être installé.

Je viens de lire les news sur cette migration.

Code:
ataualpa ben # locale -a | grep 'en_GB'
en_GB
en_GB.iso88591
en_GB.utf8

Code:
ataualpa ben # locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

je crois que c'est typiquement ce qu'il ne faut surtout pas avoir comme conf...
comment je m'en sors ?
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 2:16 pm    Post subject: Reply with quote

Pour Python, passe immédiatement à la version 2, pas la 3.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Fri Jun 11, 2010 2:39 pm    Post subject: Reply with quote

Et comment tu fais ?
Moi j'ai ça et j'ai rien demandé !
Code:
*  dev-lang/python
      Latest version available: 3.1.2-r3
      Latest version installed: 3.1.2-r3
      Size of files: 9,557 kB
      Homepage:      http://www.python.org/
      Description:   Python is an interpreted, interactive, object-oriented programming language.
      License:       PSF-2.2


Imaginons que je repasse en version 2, mes locales ont qu'en même besoin d'être mise à jour, tu ne crois pas ?
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri Jun 11, 2010 3:41 pm    Post subject: Reply with quote

Alors tu essayes de faire :
Code:
# emerge -av --onsehot python-2.6.4-r1

Si sa marche pas télécharge ici (enfin dans le répertoire dev-lang de ton architecture) un paquet binaire de python-2.6.4-r1. Puis fais :
Code:
# emerge -K python-2.6.4-r1
# eselect python list
pour savoir quel numéro a python 2 et
Code:
# eselect python set [le numéro de python 2]

Et tu seras repassé en python 2
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 5:54 pm    Post subject: Reply with quote

Pas besoin de chipoter autant !

"eselect python set 1" suffit.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Picani
Apprentice
Apprentice


Joined: 05 Jul 2009
Posts: 180

PostPosted: Fri Jun 11, 2010 7:52 pm    Post subject: Reply with quote

Mais la sortie de son eix python indique qu'il n'as plus python 2.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7937
Location: ~Brussels - Belgique

PostPosted: Fri Jun 11, 2010 8:42 pm    Post subject: Reply with quote

As-tu supprimé manuellement python 2 ?
Emerge installe les deux versions côte à côte, normalement...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Jun 14, 2010 8:06 am    Post subject: Reply with quote

Bonjour,
Absent pendant le WE je ne trouve vos réponses que maintenant.
alors
Code:
ataualpa ben # eselect python list
Available Python interpreters:
  [1]   python2.4
  [2]   python2.6 *
  [3]   python3.1

mais c'est bien la version 3.1 qui est installée.
J'ai trouvé dans /var/log/emerge.log sur un unmerge de python 2.6.4-r1 (mais c'était pas du manuel) :
Code:
ataualpa ben # grep "python-2.6.4-r1" /var/log/emerge.log
1268048478:  >>> emerge (3 of 33) dev-lang/python-2.6.4-r1 to /
1268048482:  === (3 of 33) Cleaning (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268048482:  === (3 of 33) Compiling/Merging (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268049011:  === (3 of 33) Merging (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268049052:  === (3 of 33) Post-Build Cleaning (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268049052:  ::: completed emerge (3 of 33) dev-lang/python-2.6.4-r1 to /
1268687946:  >>> emerge (6 of 10) dev-lang/python-2.6.4-r1 to /
1268687951:  === (6 of 10) Cleaning (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268687951:  === (6 of 10) Compiling/Merging (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268688569:  === (6 of 10) Merging (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268688597:  === Unmerging... (dev-lang/python-2.6.4-r1)
1268688616:  >>> unmerge success: dev-lang/python-2.6.4-r1
1268688627:  === (6 of 10) Post-Build Cleaning (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268688627:  ::: completed emerge (6 of 10) dev-lang/python-2.6.4-r1 to /
1276506604:  *** emerge --oneshot --ask --verbose python-2.6.4-r1

et depuis il semble que la version 2.6 ai été réinstallée (ligne 1274780040) :
Code:

grep "python-" /var/log/emerge.log
[...]
1268688597:  === Unmerging... (dev-lang/python-2.6.4-r1)
1268688616:  >>> unmerge success: dev-lang/python-2.6.4-r1
1268688627:  === (6 of 10) Post-Build Cleaning (dev-lang/python-2.6.4-r1::/usr/portage/dev-lang/python/python-2.6.4-r1.ebuild)
1268688627:  ::: completed emerge (6 of 10) dev-lang/python-2.6.4-r1 to /
1270159566:  >>> emerge (15 of 45) app-admin/python-updater-0.8 to /
1270159569:  === (15 of 45) Cleaning (app-admin/python-updater-0.8::/usr/portage/app-admin/python-updater/python-updater-0.8.ebuild)
1270159569:  === (15 of 45) Compiling/Merging (app-admin/python-updater-0.8::/usr/portage/app-admin/python-updater/python-updater-0.8.ebuild)
1270159576:  === (15 of 45) Merging (app-admin/python-updater-0.8::/usr/portage/app-admin/python-updater/python-updater-0.8.ebuild)
1270159581:  >>> AUTOCLEAN: app-admin/python-updater:0
1270159581:  === Unmerging... (app-admin/python-updater-0.7-r1)
1270159584:  >>> unmerge success: app-admin/python-updater-0.7-r1
1270159586:  === (15 of 45) Post-Build Cleaning (app-admin/python-updater-0.8::/usr/portage/app-admin/python-updater/python-updater-0.8.ebuild)
1270159586:  ::: completed emerge (15 of 45) app-admin/python-updater-0.8 to /
1274780040:  >>> emerge (18 of 35) dev-lang/python-2.4.6 to /
1274780044:  === (18 of 35) Cleaning (dev-lang/python-2.4.6::/usr/portage/dev-lang/python/python-2.4.6.ebuild)
1274780044:  === (18 of 35) Compiling/Merging (dev-lang/python-2.4.6::/usr/portage/dev-lang/python/python-2.4.6.ebuild)
1274780463:  === (18 of 35) Merging (dev-lang/python-2.4.6::/usr/portage/dev-lang/python/python-2.4.6.ebuild)
1274780491:  === (18 of 35) Post-Build Cleaning (dev-lang/python-2.4.6::/usr/portage/dev-lang/python/python-2.4.6.ebuild)
1274780491:  ::: completed emerge (18 of 35) dev-lang/python-2.4.6 to /
1276086466:  >>> emerge (12 of 33) app-admin/eselect-python-20100321 to /
1276086469:  === (12 of 33) Cleaning (app-admin/eselect-python-20100321::/usr/portage/app-admin/eselect-python/eselect-python-20100321.ebuild)
1276086469:  === (12 of 33) Compiling/Merging (app-admin/eselect-python-20100321::/usr/portage/app-admin/eselect-python/eselect-python-20100321.ebuild)
1276086488:  === (12 of 33) Merging (app-admin/eselect-python-20100321::/usr/portage/app-admin/eselect-python/eselect-python-20100321.ebuild)
1276086496:  === Unmerging... (app-admin/eselect-python-20091230)
1276086498:  >>> unmerge success: app-admin/eselect-python-20091230
1276086501:  === (12 of 33) Post-Build Cleaning (app-admin/eselect-python-20100321::/usr/portage/app-admin/eselect-python/eselect-python-20100321.ebuild)
1276086501:  ::: completed emerge (12 of 33) app-admin/eselect-python-20100321 to /
1276086582:  >>> emerge (14 of 33) dev-lang/python-3.1.2-r3 to /
1276086586:  === (14 of 33) Cleaning (dev-lang/python-3.1.2-r3::/usr/portage/dev-lang/python/python-3.1.2-r3.ebuild)
1276086586:  === (14 of 33) Compiling/Merging (dev-lang/python-3.1.2-r3::/usr/portage/dev-lang/python/python-3.1.2-r3.ebuild)
1276087109:  === (14 of 33) Merging (dev-lang/python-3.1.2-r3::/usr/portage/dev-lang/python/python-3.1.2-r3.ebuild)
1276087160:  === (14 of 33) Post-Build Cleaning (dev-lang/python-3.1.2-r3::/usr/portage/dev-lang/python/python-3.1.2-r3.ebuild)
1276087160:  ::: completed emerge (14 of 33) dev-lang/python-3.1.2-r3 to /
1276506604:  *** emerge --oneshot --ask --verbose python-2.6.4-r1

La dernière ligne c'est ce que j'ai essayé ce matin et qui n'a pas abouti !
Comment je m'en sors ?
La blessure à l'air profonde regardez ce que donne un man emerge :
Code:
ataualpa ben # man emerge
/usr/bin/gtbl: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
groff: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
Poussin
l33t
l33t


Joined: 08 Jun 2007
Posts: 659
Location: Liège

PostPosted: Mon Jun 14, 2010 8:54 am    Post subject: Reply with quote

lance python-updater
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Jun 14, 2010 10:35 am    Post subject: Reply with quote

C'est fait c'est gavé de message d'erreur !
Code:
* The following 12 packages have failed to build or install:
 *
 *  ('ebuild', '/', 'dev-python/sip-4.10.2', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/sip-4.10.2/temp/build.log'
 *  ('ebuild', '/', 'dev-python/numpy-1.3.0-r1', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/numpy-1.3.0-r1/temp/build.log'
 *  ('ebuild', '/', 'dev-libs/boost-1.41.0-r3', 'merge'), Log file:
 *   '/var/tmp/portage/dev-libs/boost-1.41.0-r3/temp/build.log'
 *  ('ebuild', '/', 'dev-python/lxml-2.2.6', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/lxml-2.2.6/temp/build.log'
 *  ('ebuild', '/', 'dev-python/pygame-1.9.1', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/pygame-1.9.1/temp/build.log'
 *  ('ebuild', '/', 'dev-python/imaging-1.1.7', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/imaging-1.1.7/temp/build.log'
 *  ('ebuild', '/', 'x11-libs/vte-0.22.5', 'merge'), Log file:
 *   '/var/tmp/portage/x11-libs/vte-0.22.5/temp/build.log'
 *  ('ebuild', '/', 'dev-python/PyQt4-4.7.3', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/PyQt4-4.7.3/temp/build.log'
 *  ('ebuild', '/', 'dev-python/kaa-base-0.6.0', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/kaa-base-0.6.0/temp/build.log'
 *  ('ebuild', '/', 'dev-python/kaa-imlib2-0.2.3-r1', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/kaa-imlib2-0.2.3-r1/temp/build.log'
 *  ('ebuild', '/', 'dev-python/kaa-metadata-0.7.7', 'merge'), Log file:
 *   '/var/tmp/portage/dev-python/kaa-metadata-0.7.7/temp/build.log'
 *  ('ebuild', '/', 'media-tv/xbmc-9.11-r4', 'merge'), Log file:
 *   '/var/tmp/portage/media-tv/xbmc-9.11-r4/temp/build.log'

exemple :
Code:
ataualpa ben # less /var/tmp/portage/dev-python/PyQt4-4.7.3/temp/build.log
 * CPV:  dev-python/PyQt4-4.7.3
 * REPO: gentoo
 * USE:  X dbus elibc_glibc kde kernel_linux opengl sql svg userland_GNU webkit x86
>>> Unpacking source...
>>> Unpacking PyQt-x11-gpl-4.7.3.tar.gz to /var/tmp/portage/dev-python/PyQt4-4.7.3/work
>>> Source unpacked in /var/tmp/portage/dev-python/PyQt4-4.7.3/work
>>> Preparing source in /var/tmp/portage/dev-python/PyQt4-4.7.3/work/PyQt-x11-gpl-4.7.3 ...
 * Applying PyQt4-4.6.1-configure-multilib.patch ...
  [ ok ]
 * Applying PyQt4-4.7.2-configure.py.patch ...
  [ ok ]
 * Preparation of dev-python/PyQt4-4.7.3 with CPython 2.6...
 * Preparation of dev-python/PyQt4-4.7.3 with CPython 3.1...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/PyQt4-4.7.3/work/PyQt-x11-gpl-4.7.3 ...
 * Configuration of dev-python/PyQt4-4.7.3 with CPython 2.6...
python2.6 configure.py --confirm-license --bindir=/usr/bin --destdir=/usr/lib/python2.6/site-packages --sipdir=/usr/share/sip --qsci-api --enable=QtCore --enable=QtNetwork --enable=QtScript --enable=QtTest --enable=QtXml --enable=QtGui --enable=QtDesigner --enable=QtScriptTools --enable=QtOpenGL --enable=QtSql --enable=QtSvg --enable=QtWebKit CC=i686-pc-linux-gnu-gcc CXX=i686-pc-linux-gnu-g++ LINK=i686-pc-linux-gnu-g++ LINK_SHLIB=i686-pc-linux-gnu-g++ CFLAGS='-O2 -march=pentium3 -pipe' CXXFLAGS='-O2 -march=pentium3 -pipe' LFLAGS='-Wl,-O1'
Determining the layout of your Qt installation...
Error: /usr/bin/qmake failed to create a makefile. Make sure you have a working
Qt v4 qmake on your PATH or use the -q argument to explicitly specify a working
Qt v4 qmake.
 * ERROR: dev-python/PyQt4-4.7.3 failed:
 *   Configuration failed with CPython 2.6 in configuration() function
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 5070:  Called python_execute_function '-s' 'configuration'
 *   environment, line 3409:  Called die
 * The specific snippet of code:
 *                       die "${failure_message}";
 *
 * If you need support, post the output of 'emerge --info =dev-python/PyQt4-4.7.3',
 * the complete build log and the output of 'emerge -pqv =dev-python/PyQt4-4.7.3'.
 * The complete build log is located at '/var/tmp/portage/dev-python/PyQt4-4.7.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt4-4.7.3/temp/environment'.
 * S: '/var/tmp/portage/dev-python/PyQt4-4.7.3/work/PyQt-x11-gpl-4.7.3'
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jun 15, 2010 7:48 am    Post subject: Reply with quote

comment est-ce que je peux revenir à python-2.6.4-r1 car ça ne marche pas !
Code:
ataualpa torrent # emerge -av python-2.6.4-r1
!!! 'python-2.6.4-r1' is not a valid package atom.
!!! Please check ebuild(5) for full details.

J'ai pourtant bien l'ebuild !
Code:
ataualpa torrent # ls -l /usr/portage/dev-lang/python/
total 164
-rw-r--r-- 1 root    root    84355 Jun  4 21:35 ChangeLog
-rw-r--r-- 1 root    root     4838 Jun  4 21:35 Manifest
drwxr-xr-x 2 portage portage  4096 Sep  6  2009 files
-rw-r--r-- 1 root    root      661 Dec  6  2009 metadata.xml
-rw-r--r-- 1 root    root     9276 May 25 19:35 python-2.4.6.ebuild
-rw-r--r-- 1 root    root     9639 May 25 19:35 python-2.5.4-r4.ebuild
-rw-r--r-- 1 root    root     9579 May 25 19:35 python-2.6.4-r1.ebuild
-rw-r--r-- 1 root    root     9493 May 25 19:35 python-2.6.5-r2.ebuild
-rw-r--r-- 1 root    root     9322 Jun  4 21:35 python-3.1.2-r3.ebuild
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Tue Jun 15, 2010 9:37 am    Post subject: Reply with quote

BENJI wrote:
Quote:
ataualpa torrent # emerge -av python-2.6.4-r1
!!! 'python-2.6.4-r1' is not a valid package atom.
!!! Please check ebuild(5) for full details.

J'ai pourtant bien l'ebuild !

Il ne dit pas que l'ebuild n'existe pas mais bien que ta syntaxe n'est pas correcte !
Pour contrôler la version du paquet, il faut mettre un préfixe devant l'atom, par exemple le signe "=" pour une version précise.
Donc :
Quote:
emerge -av =python-2.6.4-r1

Il te dit aussi que tout ça est expliqué dans man 5 ebuild ;-)
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jun 15, 2010 10:11 am    Post subject: Reply with quote

ghoti wrote:

Il ne dit pas que l'ebuild n'existe pas mais bien que ta syntaxe n'est pas correcte !
Pour contrôler la version du paquet, il faut mettre un préfixe devant l'atom, par exemple le signe "=" pour une version précise.
Donc :
Quote:
emerge -av =python-2.6.4-r1

Il te dit aussi que tout ça est expliqué dans man 5 ebuild ;-)

Merci,
j'ai pas trop d'atom crochu avec !
comme dis plus haut dans le post ma commande man ne fonctionne plus !

Je viens donc de relancer la compilation mais j'ai des doutes sur le fiat que ça résolve mon problème... tient d'ailleurs le résultat ne s'est pas fait trop attendre
Code:
ataualpa torrent # emerge -av =python-2.6.4-r1

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-lang/python-2.6.4-r1  USE="berkdb gdbm ipv6 ncurses readline ssl threads tk (wide-unicode) xml -build -doc -examples -sqlite -wininst" 10,999 kB

Total: 1 package (1 reinstall), Size of downloads: 10,999 kB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-lang/python-2.6.4-r1
>>> Downloading 'ftp://gentoo.imj.fr/pub/gentoo/distfiles/Python-2.6.4.tar.bz2'
--2010-06-15 13:32:17--  ftp://gentoo.imj.fr/pub/gentoo/distfiles/Python-2.6.4.tar.bz2
           => `/usr/portage/distfiles/Python-2.6.4.tar.bz2'
Resolving gentoo.imj.fr... 94.23.194.173
Connecting to gentoo.imj.fr|94.23.194.173|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /pub/gentoo/distfiles ... done.
==> SIZE Python-2.6.4.tar.bz2 ... 11249486
==> PASV ... done.    ==> RETR Python-2.6.4.tar.bz2 ... done.
Length: 11249486 (11M) (unauthoritative)

100%[===================================================================================================================>] 11,249,486   470K/s   in 24s

2010-06-15 13:32:42 (464 KB/s) - `/usr/portage/distfiles/Python-2.6.4.tar.bz2' saved [11249486]

 * Python-2.6.4.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                               [ ok ]
>>> Downloading 'ftp://gentoo.imj.fr/pub/gentoo/distfiles/python-gentoo-patches-2.6.4-r1.tar.bz2'
--2010-06-15 13:32:43--  ftp://gentoo.imj.fr/pub/gentoo/distfiles/python-gentoo-patches-2.6.4-r1.tar.bz2
           => `/usr/portage/distfiles/python-gentoo-patches-2.6.4-r1.tar.bz2'
Resolving gentoo.imj.fr... 94.23.194.173
Connecting to gentoo.imj.fr|94.23.194.173|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD (1) /pub/gentoo/distfiles ... done.
==> SIZE python-gentoo-patches-2.6.4-r1.tar.bz2 ... 12570
==> PASV ... done.    ==> RETR python-gentoo-patches-2.6.4-r1.tar.bz2 ... done.
Length: 12570 (12K) (unauthoritative)

100%[===================================================================================================================>] 12,570      --.-K/s   in 0.09s

2010-06-15 13:32:43 (132 KB/s) - `/usr/portage/distfiles/python-gentoo-patches-2.6.4-r1.tar.bz2' saved [12570]

 * python-gentoo-patches-2.6.4-r1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                             [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]
 * CPV:  dev-lang/python-2.6.4-r1
 * REPO: gentoo
 * USE:  berkdb elibc_glibc gdbm ipv6 kernel_linux ncurses readline ssl threads tk userland_GNU wide-unicode x86 xml
 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.
>>> Unpacking source...
>>> Unpacking Python-2.6.4.tar.bz2 to /var/tmp/portage/dev-lang/python-2.6.4-r1/work
>>> Unpacking python-gentoo-patches-2.6.4-r1.tar.bz2 to /var/tmp/portage/dev-lang/python-2.6.4-r1/work
>>> Source unpacked in /var/tmp/portage/dev-lang/python-2.6.4-r1/work
>>> Preparing source in /var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4 ...
 * Applying various patches (bugfixes/updates) ...
 *   01_all_static_library_location.patch ...                                                                                                          [ ok ]
 *   02_all_disable_modules_and_ssl.patch ...                                                                                                          [ ok ]
 *   03_all_add_portage_search_path.patch ...                                                                                                          [ ok ]
 *   04_all_libdir.patch ...                                                                                                                           [ ok ]
 *   05_all_verbose_building_of_extensions.patch ...                                                                                                   [ ok ]
 *   06_all_dbm_automagic.patch ...                                                                                                                    [ ok ]
 *   07_all_internal_expat.patch ...                                                                                                                   [ ok ]
 *   08_all_non-zero_exit_status_on_failure.patch ...                                                                                                  [ ok ]
 *   09_all_use_external_libffi.patch ...                                                                                                              [ ok ]
 *   10_all_disable_multiprocessing_with_disabled_threads.patch ...                                                                                    [ ok ]
 *   11_all_arm_OABI.patch ...                                                                                                                         [ ok ]
 *   12_all_check_availability_of_nis_headers.patch ...                                                                                                [ ok ]
 *   21_all_distutils_cxxflags.patch ...                                                                                                               [ ok ]
 *   22_all_distutils_rpath_gcc.patch ...                                                                                                              [ ok ]
 *   23_all_turkish_locale.patch ...                                                                                                                   [ ok ]
 *   24_all_distutils_byte-compiling.patch ...                                                                                                         [ ok ]
 *   25_all_dont_ignore___cmp___of_metaclasses.patch ...                                                                                               [ ok ]
 * Done with patching
 * Running eautoreconf in '/var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4' ...
 * Running aclocal ...                                                                                                                                 [ ok ]
 * Running autoconf ...                                                                                                                                [ ok ]
 * Running autoheader ...                                                                                                                              [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4 ...
 * Disabled modules:  _sqlite3
gcc-config: error: could not run/locate 'i686-pc-linux-gnu-gcc'
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-fpectl --enable-shared --enable-ipv6 --with-threads --enable-unicode=ucs4 --infodir=${prefix}/share/info --mandir=${prefix}/share/man --with-libc= --with-system-ffi
checking for --with-universal-archs... 32-bit
checking MACHDEP... linux2
checking EXTRAPLATDIR...
checking machine type as reported by uname -m... i686
checking for --without-gcc... no
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4/config.log
 * ERROR: dev-lang/python-2.6.4-r1 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 5431:  Called econf '--with-fpectl' '--enable-shared' '--enable-ipv6' '--with-threads' '--enable-unicode=ucs4' '--infodir=${prefix}/share/info' '--mandir=${prefix}/share/man' '--with-libc=' '--with-system-ffi'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/python-2.6.4-r1',
 * the complete build log and the output of 'emerge -pqv =dev-lang/python-2.6.4-r1'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/python-2.6.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.6.4-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4'

>>> Failed to emerge dev-lang/python-2.6.4-r1, Log file:

>>>  '/var/tmp/portage/dev-lang/python-2.6.4-r1/temp/build.log'

 * Messages for package dev-lang/python-2.6.4-r1:

 * "bsddb" module is out-of-date and no longer maintained inside dev-lang/python. It has
 * been additionally removed in Python 3. You should use external, still maintained "bsddb3"
 * module provided by dev-python/bsddb3 which supports both Python 2 and Python 3.
 * ERROR: dev-lang/python-2.6.4-r1 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 5431:  Called econf '--with-fpectl' '--enable-shared' '--enable-ipv6' '--with-threads' '--enable-unicode=ucs4' '--infodir=${prefix}/share/info' '--mandir=${prefix}/share/man' '--with-libc=' '--with-system-ffi'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =dev-lang/python-2.6.4-r1',
 * the complete build log and the output of 'emerge -pqv =dev-lang/python-2.6.4-r1'.
 * The complete build log is located at '/var/tmp/portage/dev-lang/python-2.6.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lang/python-2.6.4-r1/temp/environment'.
 * S: '/var/tmp/portage/dev-lang/python-2.6.4-r1/work/Python-2.6.4'

je pète un plomb !
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Tue Jun 15, 2010 10:59 am    Post subject: Reply with quote

BENJI wrote:
Bonjour,
Absent pendant le WE je ne trouve vos réponses que maintenant.
alors
Code:
ataualpa ben # eselect python list
Available Python interpreters:
  [1]   python2.4
  [2]   python2.6 *
  [3]   python3.1

mais c'est bien la version 3.1 qui est installée.


Non, tu as 3 versions d'installées (2.4, 2.6 et 3.1) mais c'est la 2.6 qui est active !
Comme elle semble poser problème, essaie tout d'abord d'activer la 2.4 comme te l'a suggéré XavierMiller :
Code:
 eselect python set 1
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Jun 15, 2010 11:27 am    Post subject: Reply with quote

ok c'est fait mais je fais quoi ensuite !
Code:
ataualpa torrent # python-updater
  File "/usr/bin/portageq", line 152
    print("ERROR: insufficient parameters!", file=sys.stderr)
                                                 ^
SyntaxError: invalid syntax
  File "/usr/bin/portageq", line 152
    print("ERROR: insufficient parameters!", file=sys.stderr)
                                                 ^
SyntaxError: invalid syntax
 * Python 2 and Python 3 not installed

ça sent pas bon !
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3580
Location: Belgium

PostPosted: Tue Jun 15, 2010 12:38 pm    Post subject: Reply with quote

En effet, j'ai l'impression qu'on se disperse et qu'on rame dans la soupe :-(
Pour tenter de remettre de l'ordre, essaie tout d'abord de virer python-3.1 car il ne convient de toutes façons pas à portage.
Code:
emerge -Ca python:3.1

Masque cette version pour être sûr de ne plus la ramasser par la suite.
Ensuite, essaie de (re)emerger une version du slot 2.6 de python
Code:
emerge -1a python:2.6

Si ça ne va pas, utilise la méthode de Picani plus haut pour installer une version binaire.
Si ça passe, vérifie comme plus haut avec eselect que la version 2.6* est bien active.
A ce moment, lance python-updater.
Après ça, on y verra peut-être plus clair ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum