Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] How to remove kdelibs-9999 dep in kmix-9999.ebuild
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MacJariel
n00b
n00b


Joined: 12 Jun 2010
Posts: 2

PostPosted: Sat Jun 12, 2010 3:31 pm    Post subject: [Solved] How to remove kdelibs-9999 dep in kmix-9999.ebuild Reply with quote

Hello guys,

I recently had some fun with pulseaudio and because I'm a KDE user and latest kmix in portage does not support pulseaudio, I decided to merge svn version of kmix. I downloaded kmix-9999.ebuild from kde overlay and put it into my private overlay. When I tried to emerge this, I got a dependency problem:

Code:

emerge: there are no ebuilds to satisfy ">=kde-base/kdelibs-9999[-kdeprefix,-aqua]".
(dependency required by "kde-base/kmix-9999" [ebuild])


Finally I managed to manually merge the app with ebuild kmix-9999.ebuild merge, but anytime I want to upgrade system with emerge -u world, it gets downgraded.

So I think the best would be to remove the dependency from the ebuild. But I have no idea how to do it. Here's the ebuild:

kde-base/kmix-9999.ebuild:
Code:

# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI="3"

KMNAME="kdemultimedia"
inherit kde4-meta

DESCRIPTION="KDE mixer gui"
KEYWORDS=""
IUSE="alsa debug +handbook pulseaudio"

DEPEND="
        alsa? ( >=media-libs/alsa-lib-1.0.14a )
        pulseaudio? ( >=media-sound/pulseaudio-0.9.12 )
"
RDEPEND="${DEPEND}"

src_configure() {
        mycmakeargs=(
                $(cmake-utils_use_with pulseaudio PulseAudio)
                $(cmake-utils_use_with alsa)
        )

        kde4-meta_src_configure
}


Could anybody help me how to disable the kdelibs-9999 dependency or maybe how to change it to kdelibs:4.4 dependency?


Last edited by MacJariel on Sun Jun 13, 2010 10:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
SamuliSuominen
Retired Dev
Retired Dev


Joined: 30 Sep 2005
Posts: 2133
Location: Finland

PostPosted: Sat Jun 12, 2010 3:57 pm    Post subject: Reply with quote

You can add "/etc/portage/profile/package.provided" file with:

=kde-base/kdelibs-9999

Or you can try to modify the ebuild and add KDE_MINIMAL="4.4" before the inherit line, but I'm not sure if that will work.
Back to top
View user's profile Send private message
MacJariel
n00b
n00b


Joined: 12 Jun 2010
Posts: 2

PostPosted: Sun Jun 13, 2010 1:04 am    Post subject: Reply with quote

Thanks, adding kdelibs to package.provided works, although I had to put just kde-base/kdelibs-9999 (without equal sign).

I also tried KDE_MINIMAL before posting, but it didn't work (it seems that it gets overwritten somewhere in kde eclass).
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Jun 13, 2010 2:56 pm    Post subject: Reply with quote

Moved from Gentoo Chat to Unsupported Software.
support question about unsupported stuff, so moved here
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum