Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
World-Update und qt3support
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
mario88
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 122
Location: Vienna

PostPosted: Wed Jun 16, 2010 11:02 am    Post subject: World-Update und qt3support Reply with quote

Code:

workstation ~ # emerge -uDavN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:               

x11-libs/qt-qt3support:4

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.6.2', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.6.2[-debug,-aqua] required by ('installed', '/', 'x11-libs/qt-gui-4.6.2', 'nomerge')

  ('installed', '/', 'x11-libs/qt-qt3support-4.6.2', 'nomerge') pulled in by
    >=x11-libs/qt-qt3support-4.5.1:4[kde] required by ('ebuild', '/', 'kde-base/pykde4-4.3.5-r1', 'merge')
    >=x11-libs/qt-qt3support-4.5.1:4[kde] required by ('installed', '/', 'kde-base/solid-4.3.5', 'nomerge')
    >=x11-libs/qt-qt3support-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdepasswd-4.3.5', 'nomerge')
    (and 21 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy ">=x11-libs/gtk+-2.19.7" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/gtk+-2.20.1-r1 (masked by: ~x86 keyword)

(dependency required by "gnome-base/gnome-panel-2.30.0-r1" [ebuild])
(dependency required by "world" [argument])

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

(das mit dem gtk+ interessiert mich vorerst mal nicht)

Ich habe qt3support als globales USE-Flag gesetzt?
Was gefällt ihm hier nicht? (werde daraus nicht wirklich schlau)

danke im Voraus
m4ri0
_________________
Cyber Anarchist
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum