Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Postfix für Versand über Imap und Outlook einrichten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 116

PostPosted: Sun Jun 20, 2010 7:55 pm    Post subject: Postfix für Versand über Imap und Outlook einrichten Reply with quote

Hi,

ich habe einen Postfix-Mailserver laufen mit Dovecot für Imap. Squirrelmail klappt super mit dem User und ich kann mails empfangen und sende. Wenn ich aber unter Outlook den Account eingebe und dann SMTP mit Port 25 anlege, dann kann er keine Mails verschicken und meldet jedes Mal das der Server keinen Zugriff ermöglicht. Auch im Log steht überhaupt nix, das der Client versucht eine Mail zu verschicken.

Was mache ich falsch?

Gruß kami
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1754

PostPosted: Tue Jun 22, 2010 10:35 am    Post subject: Re: Postfix für Versand über Imap und Outlook einrichten Reply with quote

kami22 wrote:
Hi,

ich habe einen Postfix-Mailserver laufen mit Dovecot für Imap. Squirrelmail klappt super mit dem User und ich kann mails empfangen und sende. Wenn ich aber unter Outlook den Account eingebe und dann SMTP mit Port 25 anlege, dann kann er keine Mails verschicken und meldet jedes Mal das der Server keinen Zugriff ermöglicht. Auch im Log steht überhaupt nix, das der Client versucht eine Mail zu verschicken.

Was mache ich falsch?

Gruß kami


Hallo,

Schuß ins "Blaue"

wenn Outlook auf einem anderen Rechner läuft und Squirrelnmail auf dem gleichen Rechner, hast Du wohl den Imap an die lokale IP gebunden?

Schau mal im Logfile bzw. poste mal die Configdateien. Ist sicher auch mal interessant Deine Lösung zu sehen.

G. R.
Back to top
View user's profile Send private message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 116

PostPosted: Tue Jun 22, 2010 11:04 am    Post subject: Reply with quote

Hi,

der Imap funktioniert ja aber es ist ja nur das Problem mit dem Versand über SMTP, und wenn ich in der Konsole per Telnet von Extern auf meinen Rechner Port 25 connecte, dann kann ich ja Mails schicken nur per Outlook geht es halt nicht und im mail.log passiert gar nix.

Gruß kami
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9236
Location: beyond the rim

PostPosted: Tue Jun 22, 2010 11:19 am    Post subject: Reply with quote

Also hat das Problem rein gar nichts mit IMAP zu tun, das Subject ist daher etwas missverständlich.
Um das Problem einzugrenzen würde ich mal kurzfristig einen anderen E-Mail Client ausprobieren, wenns damit geht liegt das Problem definitiv bei Outlook. Ansonsten vielleicht mal mit Wireshark (auf dem Windows Rechner) schauen ob Outlook überhaupt versucht eine Verbindung aufzubauen, vielleicht ist ja auch einfach nur irgendwo ein Tippfehler in der Konfiguration (die sind manchmal schwer zu erkennen).
Back to top
View user's profile Send private message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 116

PostPosted: Tue Jun 22, 2010 11:24 am    Post subject: Reply with quote

Hi,

ja das habe ich schon probiert. Habe es auf meinem Mac mit Mail getestet und auch noch von extern. Leider funktioniert es gar nicht. Ist das sonst irgendwie eine Postfix config Sache oder Dovecot?

Gruß kami
Back to top
View user's profile Send private message
jodel
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 113

PostPosted: Tue Jun 22, 2010 11:49 am    Post subject: Reply with quote

vielleicht hilft dir ja diese Anleitung:
http://www.kurzor.org/2010/04/02/setting-up-a-mailserver-on-gentoo

bei mir hats so geklappt.
Back to top
View user's profile Send private message
Hollowman
Guru
Guru


Joined: 19 Apr 2007
Posts: 584

PostPosted: Tue Jun 22, 2010 1:43 pm    Post subject: Reply with quote

Hallo

poste mal bitte das Ergebnis von

netstat -taunp

auf dem Server. Bei laufenden Emaildiensten.

Von dem Rechner wo Outlook installiert ist, kannst du per telnet Mails versenden? Sicher das du es mit Outlook auch auf Port 25 machst? Nicht das du SSl oder STARTTLS versuchst.

Wie lautet die Fehlermeldung von Outlook.

Sebastian
Back to top
View user's profile Send private message
kami22
Tux's lil' helper
Tux's lil' helper


Joined: 14 Apr 2006
Posts: 116

PostPosted: Thu Jun 24, 2010 9:53 am    Post subject: Reply with quote

Hi,

so Problem hat sich durch die Neueinstellung von Postfix und Dovecot anhand des Tutorials gelöst. Hat super geklappt und nun läuft der Mailserver ohne Problem.

@jodel: Hast du vielleicht noch mehr so gute Tuts in Richtung Procmail einrichten und ähnliches?

Vielen dank.

Gruß kami
Back to top
View user's profile Send private message
jodel
Tux's lil' helper
Tux's lil' helper


Joined: 28 Sep 2004
Posts: 113

PostPosted: Thu Jun 24, 2010 11:27 am    Post subject: Reply with quote

kami22 wrote:
Hi,

so Problem hat sich durch die Neueinstellung von Postfix und Dovecot anhand des Tutorials gelöst. Hat super geklappt und nun läuft der Mailserver ohne Problem.

@jodel: Hast du vielleicht noch mehr so gute Tuts in Richtung Procmail einrichten und ähnliches?

Vielen dank.

Gruß kami


leider hab ich zu procmail nichts, aber ich hatte vor mich in nächster Zeit mal mit der bei dovecot eingebauten Sortierfunktion zu beschäftigen: http://wiki.dovecot.org/LDA/Sieve

scheint auch nicht so kompliziert zu sein.
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Thu Jun 24, 2010 11:52 am    Post subject: Reply with quote

kami22 wrote:
@jodel: Hast du vielleicht noch mehr so gute Tuts in Richtung Procmail einrichten und ähnliches?

Dovecot hat eine sehr gute Sieve-Implementierung. Schau dir die mal an ... Ausserdem kann man Sieve per Managesieve vom Client aus verwalten und braucht keinen Shell-Zugriff :) (Sieve-Plugins gibts u.a. fuer Thunderbird und Roundcube)
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum