Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to install masked gst-plugins-?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Fri Jun 25, 2010 1:07 am    Post subject: how to install masked gst-plugins-? Reply with quote

Hello there, I'm sure I'm doing something quite stupid, but I figured I could go crazy over this while someone here already knows the answer. When I try to watch some videos on totem I get:

Code:
$ totem videofile.avi
** Message: don't know how to handle video/x-xvid, framerate=(fraction)2997/125, width=(int)512, height=(int)384
** Message: Missing plugin: gstreamer|0.10|totem|XVID MPEG-4 decoder|decoder-video/x-xvid (XVID MPEG-4 decoder)
** Message: Automatic missing codec installation not supported (helper script missing)


but directly with gstreamer I can watch things without trouble:
Code:
$gst-launch-0.10 playbin uri=file:///path/to/my/videofile.avi
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstPulseSinkClock
ERROR: from element /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage: Output window was closed
Additional debug info:
xvimagesink.c(1295): gst_xvimagesink_handle_xevents (): /GstPlayBin:playbin0/GstBin:vbin/GstAutoVideoSink:videosink/GstXvImageSink:videosink-actual-sink-xvimage
Execution ended after 17954006300 ns.
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...


Anyhow when I read the first error message I tried to install the missing codec directly. Gstreamer's mpeg-4 codec is in gst-plugins-bad, which if I understand correctly now one needs to install each codec separately instead of on a whole package, but looking at the ebuild for gst-plugins-xvid for example one sees the keywords ~amd64 and ~x86 only.

So my two questions are:

1) why can I watch with gstreamer (let alone ffplay) but not with totem that is supposed to use only gstreamer?

2) how do I install the plugin that totem is complaining about?

Thanks

R.
Back to top
View user's profile Send private message
KeteTabz
n00b
n00b


Joined: 28 Apr 2008
Posts: 25

PostPosted: Fri Jun 25, 2010 9:36 am    Post subject: Reply with quote

Hello,

Do you unmask it? Try to unmask it and emerge it.
Use gnome-player instead of totem. Although totem must play it without any problem.

Do you update all media-plugins/gst-plugins-* ? and then re-compile totem.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3793

PostPosted: Fri Jun 25, 2010 11:53 am    Post subject: Reply with quote

i dont know about totem, i dont use it, but if it uses the gstreamer framework all you have to do is look to the USE flags from the media-plugins/gst-plugins-meta package and adjust them to your needs.

cheers
Back to top
View user's profile Send private message
potuz
Guru
Guru


Joined: 30 Jan 2010
Posts: 378

PostPosted: Fri Jun 25, 2010 4:04 pm    Post subject: Reply with quote

KeteTabz wrote:

Do you update all media-plugins/gst-plugins-* ? and then re-compile totem.


Hi and thanks for both your answers, I did indeed update all media-plugins/gst-plugins-* I could and then recompile totem. But note that the keywording in plugins-xdiv does not allow for a ppc version, that was the point of one of my questions.

Also, the other question is the most puzzling one to me, I don't understand why playbin on gstreamer shows the files without trouble while totem doesn't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum