Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] soffice.bin: xcb_io.c _XAllocID: Assertion `r ???
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 25, 2010 10:31 am    Post subject: [solved] soffice.bin: xcb_io.c _XAllocID: Assertion `r ??? Reply with quote

Hi everyone,

I just ran into the following error-message:

oowriter
soffice.bin: xcb_io.c:461: _XAllocID: Assertion `ret != inval_id' failed.

when downgrading from xorg-server 1.7* to 1.6* (including it's libraries) again since suspending-to-ram is broken with catalyst-drivers (fglrx) 10.5 & 10.6

unfortunately I have no other option to use ati-drivers 10.1 since 10.2-10.4 won't work for me (on Gentoo)


any ideas how to fix that error message and what might be causing it ?

many thanks in advance !


edit:

this happens both with openoffice and openoffice-bin !
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jun 25, 2010 10:46 am    Post subject: Reply with quote

ok, *fixed*

well the problem was a too high libX11 version:

I masked the 1.3* versions and installed 1.2.2 - now it seems to be working again

the following bug-report at launchpad got me the idea that libX11 & libxcb & xcb-proto are involved:

https://bugs.launchpad.net/ubuntu/+source/libx11/+bug/507062


xcb_io.c seems to be some magic file since I can't find it ;)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum