Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[hoffentlich gelöst] GCC nicht auffindbar
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Fri Jul 02, 2010 8:41 pm    Post subject: [hoffentlich gelöst] GCC nicht auffindbar Reply with quote

Hallo und guten Abend,

in den letzten Stunden habe ich mal KDE aktualisiert. Abschließend wollte ich dann noch ein revdep-rebuild und ein kernel-update durchführen. revdep-rebuild bricht beim Versuch, den gcc zu installieren mit der Meldung, der C Compiler könne keine ausführbare Datei erstellen, ab und ein kernel Bauen endet auch relativ abrupt mit einem could not run/locate 'gcc'.

Eigentlich halte ich mich nicht für so doof, aus einem gentoo einfach den gcc zu deinstallieren, aber irgendwas ist auf jeden Fall kaputt.

Eix behauptet zu mindest, der gcc wäre noch da:

Code:
sys-devel/gcc
     Available versions: 
        (2.95)  *2.95.3-r9 ~*2.95.3-r10!s
        (3.1)   *3.1.1-r2
        (3.2)   **3.2.2!s *3.2.3-r4
        (3.3)   ~3.3.6-r1!s
        (3.4)   3.4.6-r2!s
        (4.0)   ~*4.0.4!s
        (4.1)   4.1.2!s
        (4.2)   ~4.2.4-r1!s
        (4.3)   4.3.2-r3!s ~4.3.2-r4!s ~4.3.3-r2!s 4.3.4!s ~4.3.5!s
        (4.4)   ~4.4.1!s ~4.4.2!s 4.4.3-r2!s ~4.4.3-r3!s ~4.4.4!s ~4.4.4-r1!s
        (4.5)   [M]**4.5.0!s
        {altivec bootstrap boundschecking build d doc fixed-point fortran gcj graphite gtk hardened ip28 ip32r10k java libffi lto mudflap multilib multislot n32 n64 nls nocxx nopie nossp nptl objc objc++ objc-gc openmp static test vanilla}                                                                                                                   
     Installed versions:  4.4.3-r2(4.4)!s(21:21:53 26.05.2010)(fortran gcj gtk mudflap multilib nls nptl openmp -altivec -bootstrap -build -doc -fixed-point -graphite -hardened -libffi -multislot -n32 -n64 -nocxx -objc -objc++ -objc-gc -test -vanilla)                                                                                                       
     Homepage:            http://gcc.gnu.org/
     Description:         The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking


Hat jemand eine Idee, was das sein könnte?

Viele Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.


Last edited by Schinkencroissant on Fri Jul 02, 2010 9:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Fri Jul 02, 2010 8:47 pm    Post subject: Reply with quote

Hi

Was sagt den ein
Code:
gcc-config -l
oder gcc mit gcc-config mal neu setzen.

MfG
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Fri Jul 02, 2010 8:50 pm    Post subject: Reply with quote

Hallo,

Code:
gcc-config -l
 * gcc-config: Active gcc profile is invalid!
 [1] x86_64-pc-linux-gnu-4.4.3


angeblich kaputt, aber ich weiß nicht, was und wie da jetzt kaputt ist.

Danke schonmal,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Fri Jul 02, 2010 8:55 pm    Post subject: Reply with quote

Hi

Schinkencroissant wrote:
Hallo,

Code:
gcc-config -l
 * gcc-config: Active gcc profile is invalid!
 [1] x86_64-pc-linux-gnu-4.4.3


angeblich kaputt, aber ich weiß nicht, was und wie da jetzt kaputt ist.

Danke schonmal,

Schinkencroissant

Mach ma:
Code:
gcc-config x86_64-pc-linux-gnu-4.4.3



MfG
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Fri Jul 02, 2010 9:01 pm    Post subject: Reply with quote

Hi

Hänge auch noch ein
Code:
env-update && source /etc/profile
dran.

MfG
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Fri Jul 02, 2010 9:06 pm    Post subject: Reply with quote

Hallo,

gab diese Meldung aus:

Code:
sudo gcc-config x86_64-pc-linux-gnu-4.4.3
Passwort:
 * Switching native-compiler to x86_64-pc-linux-gnu-4.4.3 ...

 * Your gcc has a bug with GCC_SPECS.
 * Please re-emerge gcc.
 * http://bugs.gentoo.org/68395

>>> Regenerating /etc/ld.so.cache...                                                                                                                                       [ ok ]

 * If you intend to use the gcc from the new profile in an already
 * running shell, please remember to do:

 *   # source /etc/profile


und jetzt scheint der GCC wieder zu kompilieren.

Scheint, als wäre das Problem damit gelöst,

woher könnte das denn gekommen sein (und was war das überhaupt?)

vielen Dank und gute Nacht,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Sat Jul 03, 2010 9:39 am    Post subject: Reply with quote

Hi

Du solltest nun möglichst noch ein fix_libtool_files.sh durchlaufen lassen, ansonsten könnte es in Zukunft noch weitere Überraschungen geben ;-)

gcc WARN: postinst wrote:
If you have issues with packages unable to locate libstdc++.la, │
then try running 'fix_libtool_files.sh' on the old gcc versions.


/edit:
Ich vermute mal das 4.3.4 deine letzte gcc Version war?
wenn ja, dann also
Code:
# fix_libtool_files.sh 4.3.4

aber überprüfe es besser noch mal, zb sollte es mit
Code:
$ genlop gcc
ersichtlich sein welcher deine bisherige Version war.

MfG
Back to top
View user's profile Send private message
Schinkencroissant
Guru
Guru


Joined: 09 Oct 2009
Posts: 309

PostPosted: Sat Jul 03, 2010 12:57 pm    Post subject: Reply with quote

Hallo,

genlop behauptet, ich hätte vorher schon die gleiche Version gehabt:

Code:
Wed May 26 21:22:27 2010 >>> sys-devel/gcc-4.4.3-r2                                                                                                                         
     Fri Jul  2 23:54:24 2010 >>> sys-devel/gcc-4.4.3-r2


Funktioniert das Skript auch, wenn die vorige Version die gleiche war oder müsste ich dann den Vorvorgänger angeben?

Grüße,

Schinkencroissant
_________________
"Es muss ein Lehrplan her und eine Wertediskussion
und keine Werte unter 120 Phon!"

- J.B.O.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Sat Jul 03, 2010 2:58 pm    Post subject: Reply with quote

Nein, du musst schon die Vorvorgänger Version angeben. Wenn du den stable Zweig verwendest wird dies relativ sicher 4.3.4 gewesen sein.
Genaueres hierzu ist auch in der Gentoo Dokumentation zu finden, siehe zb
Gentoo GCC-Aktualisierungsanleitung
Back to top
View user's profile Send private message
Schorchgrinder
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jun 2006
Posts: 82
Location: Lower Uncton

PostPosted: Sat Jul 03, 2010 8:58 pm    Post subject: Reply with quote

Schinkencroissant wrote:

* Your gcc has a bug with GCC_SPECS.
* Please re-emerge gcc.
* https://bugs.gentoo.org/68395

>


Schon mal in der make.conf geschaut ob da was falsch ist?

So schaut es bei mir aus
Code:

gentoo64 / # emerge --info
Portage 2.1.8.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.4, glibc-2.11.2-r0, 2.6.33-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r1-x86_64-AMD_Athlon-tm-_II_X4_600e_Processor-with-gentoo-2.0.1
Timestamp of tree: Thu, 01 Jul 2010 15:00:23 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.1-r1
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
virtual/os-headers:  2.6.34
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j8"

_________________
AMD Athlon 1000 Mhz, RIVA TNT2/TNT2 Pro, Creative Labs SB Live, 1500 MB Arbeitsspeicher
damit läuft der Rechner unter Gentoo immer noch recht gut

AMD Athlon II X4 600e 2200 Mhz, Nvidia G210, 4GB RAM
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum