Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]libknotificationitem blockiert kde-4.4.4 update
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Tue Jul 06, 2010 9:23 pm    Post subject: [solved]libknotificationitem blockiert kde-4.4.4 update Reply with quote

Hallo,

Quote:
)
[noch viele viele viele andere]
[uninstall ] kde-base/solid-hardware-4.3.5
[blocks b ] kde-base/solid-hardware:4.3[-kdeprefix] ("kde-base/solid-hardware:4.3[-kdeprefix]" is blocking kde-base/solid-runtime-4.4.4)
[ebuild NS ] kde-base/kdebase-runtime-meta-4.4.4 [4.3.5] USE="handbook (-aqua) (-kdeprefix) -semantic-desktop"
[uninstall ] kde-base/kdebase-runtime-meta-4.3.5
[blocks b ] kde-base/kdebase-runtime-meta:4.3[-kdeprefix] ("kde-base/kdebase-runtime-meta:4.3[-kdeprefix]" is blocking kde-base/kdebase-runtime-meta-4.4.4)
[blocks b ] kde-base/kdebase-runtime-meta:4.4[-kdeprefix] ("kde-base/kdebase-runtime-meta:4.4[-kdeprefix]" is blocking kde-base/kdebase-runtime-meta-4.3.5)
[ebuild NS ] kde-base/kdebase-startkde-4.4.4 [4.3.5] USE="(-aqua) (-kdeenablefinal) (-kdeprefix)"
[uninstall ] kde-base/kdebase-startkde-4.3.5
[blocks b ] kde-base/kdebase-startkde:4.3[-kdeprefix] ("kde-base/kdebase-startkde:4.3[-kdeprefix]" is blocking kde-base/kdebase-startkde-4.4.4)
[blocks b ] kde-base/kdebase-startkde:4.4[-kdeprefix] ("kde-base/kdebase-startkde:4.4[-kdeprefix]" is blocking kde-base/kdebase-startkde-4.3.5)
[blocks B ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('installed', '/', 'kde-base/libknotificationitem-4.3.5', 'nomerge') pulled in by
>=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kappfinder-4.3.5', 'nomerge')

('ebuild', '/', 'kde-base/kdelibs-4.4.4', 'merge') pulled in by
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/klipper-4.4.4', 'merge')
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kstartupconfig-4.4.4', 'merge')
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/plasma-workspace-4.4.4', 'merge')
(and 136 more)


ich habe bereits probiert libknotificationitem zu deinstallieren, aber helfen tut es nicht, wie in diesem thread beschrieben:
https://forums.gentoo.org/viewtopic-t-833555.html?sid=4b9d4c106c37398ecd0b77804ef2680e

Was übersehe ich da wieder?

grüße
Dennis
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB


Last edited by skydoom on Wed Jul 07, 2010 9:31 am; edited 1 time in total
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Jul 06, 2010 9:51 pm    Post subject: Reply with quote

Quote:
('installed', '/', 'kde-base/libknotificationitem-4.3.5', 'nomerge') pulled in by
>=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('installed', '/', 'kde-base/kappfinder-4.3.5', 'nomerge')


sieht so aus, als ob du kappfinder runterschmeißen musst. das scheints nicht für 4.4 zu geben.
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Tue Jul 06, 2010 10:06 pm    Post subject: Reply with quote

kappfinder ist weg, allerdings immer noch:

Quote:
[blocks b ] kde-base/kdebase-startkde:4.4[-kdeprefix] ("kde-base/kdebase-startkde:4.4[-kdeprefix]" is blocking kde-base/kdebase-startkde-4.3.5)
[blocks B ] kde-base/libknotificationitem:4.3[-kdeprefix] ("kde-base/libknotificationitem:4.3[-kdeprefix]" is blocking kde-base/kdelibs-4.4.4)

Total: 184 packages (33 upgrades, 1 downgrade, 19 new, 130 in new slots, 1 reinstall, 133 uninstalls), Size of downloads: 772,636 kB
Conflict: 265 blocks (1 unsatisfied)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

('ebuild', '/', 'kde-base/kdelibs-4.4.4', 'merge') pulled in by
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/klipper-4.4.4', 'merge')
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kstartupconfig-4.4.4', 'merge')
>=kde-base/kdelibs-4.4.4[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/plasma-workspace-4.4.4', 'merge')
(and 136 more)

('ebuild', '/', 'kde-base/libknotificationitem-4.3.5', 'merge') pulled in by
>=kde-base/libknotificationitem-4.3.5[-kdeprefix,-aqua] required by ('ebuild', '/', 'kde-base/kappfinder-4.3.5', 'merge')



Sind vieleicht noch Pakete da die kappfinder brauchen?
Wie find ich das raus?
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Jul 06, 2010 10:10 pm    Post subject: Reply with quote

Quote:
Sind vieleicht noch Pakete da die kappfinder brauchen?
Wie find ich das raus?

sieht so. probier mal "equery d kappfinder".
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Tue Jul 06, 2010 10:11 pm    Post subject: Reply with quote

Quote:
[ Searching for packages depending on kappfinder... ]
kde-base/kdebase-meta-4.3.5 (!kdeprefix? >=kde-base/kappfinder-4.3.5[aqua=,-kdeprefix])
(kdeprefix? >=kde-base/kappfinder-4.3.5:4.3[aqua=,kdeprefix])


kann ich kdebase-meta im laufenden betrieb runterschmeißen?
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2042
Location: My own world! I and Gentoo!

PostPosted: Tue Jul 06, 2010 10:16 pm    Post subject: Reply with quote

Ja. diese Meta-Pakete sind reine "Sammel-Pakete" in deren einfach nur Abhängigkeiten stehen.
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1176

PostPosted: Tue Jul 06, 2010 10:18 pm    Post subject: Reply with quote

hm, ja. weil es nur ein meta packet ist, sollte das nix machen. es ist aber seltsam, dass kdebase-meta anscheinend nicht geupdatet werden soll. schau mal ob das in der liste der upzudatenden pakete dabei ist.
probier mal "emerge -uD kdebase-meta", und wenn das nicht geht, dann kdebase-meta deinstallieren und wieder installieren.
wenn dus nicht wieder installierst gehn beim nächsten "emerge --depclean" die kdebasis-sachen verloren.
Back to top
View user's profile Send private message
skydoom
Tux's lil' helper
Tux's lil' helper


Joined: 19 Aug 2006
Posts: 141
Location: Eschershausen, Niedersachsen

PostPosted: Wed Jul 07, 2010 9:31 am    Post subject: Reply with quote

Ich habs deinstalliert, Update durchgeführt, kdebase-meta installiert (Version 4.4.4) und alles ist gut! :D

Danke!
dennis
_________________
Mein Rechner:
Gentoo Linux 2.6.29-gentoo-r5
Intel Core2Duo 6420 @ 2.13GHz
MB: Abit AB9
HDD: 2x Samsung 200GB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum