Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Firefox 4.0 beta out- works nice so far
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3838
Location: Dallas area

PostPosted: Tue Oct 12, 2010 5:23 pm    Post subject: Reply with quote

anyone tried the beta 8 version yet?
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Tue Oct 12, 2010 9:34 pm    Post subject: Reply with quote

Works great, compiles and runs fine with "qt4" flag :D
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2860
Location: Bay Area, CA

PostPosted: Wed Oct 13, 2010 3:41 am    Post subject: Reply with quote

builds but hangs on startup....-safe-mode also hangs. Back to beta6.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2860
Location: Bay Area, CA

PostPosted: Wed Oct 13, 2010 3:50 am    Post subject: Reply with quote

Lustmored wrote:
Works great, compiles and runs fine with "qt4" flag :D
which overlay has the qt4 support for firefox? "mozilla" overlay definitely doesn't have it.
Back to top
View user's profile Send private message
Lustmored
Apprentice
Apprentice


Joined: 28 May 2010
Posts: 206
Location: Poland

PostPosted: Wed Oct 13, 2010 8:46 am    Post subject: Reply with quote

devsk wrote:
Lustmored wrote:
Works great, compiles and runs fine with "qt4" flag :D
which overlay has the qt4 support for firefox? "mozilla" overlay definitely doesn't have it.


ouh damn. I thought it was still there and was surprised when it've build with those flag unmasked. Sorry :oops:
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5618
Location: Removed by Neddy

PostPosted: Sat Dec 04, 2010 6:58 pm    Post subject: Reply with quote

what are poeple doing about the dev-python/gtkmozembed-python-2.25.3::gentoo issue that is blocking net-libs/xulrunner-1.9*
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Dec 04, 2010 9:25 pm    Post subject: Reply with quote

Naib wrote:
what are poeple doing about the dev-python/gtkmozembed-python-2.25.3::gentoo issue that is blocking net-libs/xulrunner-1.9*


I bumped it to my local overlay and updated the dependency to >=net-libs/xulrunner-1.9.1

so that xulrunner-2.0_beta* would also work

you might need to bump it from dev-python/gtkmozembed-python-2.25.3 to dev-python/gtkmozembed-python-2.25.3-r1
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
keet
Guru
Guru


Joined: 09 Sep 2008
Posts: 529

PostPosted: Sun Dec 05, 2010 12:04 am    Post subject: 4.0b8pre Reply with quote

I'm posting with 4.0b8pre; it seems to work, except that the first page at http://www.mozilla.com/en-US/firefox/4.0b8pre/whatsnew/ says: 'Hmmm, we’re having trouble finding that one. We hate to say it, but we couldn’t find that page or file you’re looking for.'
Back to top
View user's profile Send private message
XQYZ
Apprentice
Apprentice


Joined: 19 Jul 2009
Posts: 231
Location: Europe

PostPosted: Sun Dec 05, 2010 12:36 am    Post subject: Reply with quote

I've been running it for a while now and it's pretty sweet. I kinda miss most of my extensions, but I guess they'll soon get their betas, too. Anyhow, only issue I'm having ATM is that http://4walled.org/ doesn't seem to work correctly anymore (when you scroll down to the bottom edge it's supposed to get additional wallpapers, in FF4 it just reaches the bottom and does nothing). I'm not sure if it's a FF bug or if the JS on the site is somehow incompatible with FF4. It worked fine in FF3 and still does in Epiphany. Haven't had the time to investigate yet.
Back to top
View user's profile Send private message
TomCat1
n00b
n00b


Joined: 18 May 2005
Posts: 15
Location: Prague

PostPosted: Fri Dec 10, 2010 10:13 am    Post subject: xulrunner-2.0_beta8_pre-r8 Reply with quote

Can't emerge xulrunner-2.0_beta8_pre-r8.

Code:
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient_standalone.o] Error 1
make[3]: *** Waiting for unfinished jobs....
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make: *** [default] Error 2
emake failed


please help
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Dec 10, 2010 1:26 pm    Post subject: Re: xulrunner-2.0_beta8_pre-r8 Reply with quote

TomCat1 wrote:
Can't emerge xulrunner-2.0_beta8_pre-r8.

Code:
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient_standalone.o] Error 1
make[3]: *** Waiting for unfinished jobs....
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make: *** [default] Error 2
emake failed


please help


I don't know exactly where that error message is pointing to but

make sure you have the latest

dev-libs/nss and dev-libs/nspr (you might need to unmask or un-keyword them)

if xulrunner and firefox fail due to other errors later - try emerging them with FEATURES="-sandbox -usersandbox"
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
TomCat1
n00b
n00b


Joined: 18 May 2005
Posts: 15
Location: Prague

PostPosted: Fri Dec 10, 2010 6:48 pm    Post subject: Reply with quote

Thanks for the answer. I have installed dev-libs/nss-3.12.8 and dev-libs/nspr-4.8.6-r1. Also net-libs/xulrunner-2.0_beta8_pre-r6 compiles fine. I already tried to compile with gcc version 4.1.2, 4.4.5 and 4.5.1-r1 without success. Then I did emerge -e world and found out, that I have similar problem with emerging kde-base/kdelibs-4.5.85.

FEATURES="-sandbox -usersandbox" emerge -av1 xulrunner gives this output.
Code:
/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/config/nsinstall -R -m 644 libappcomps.a  ../../../staticlib/components
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components/build'
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components'
make[3]: Entering directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
x86_64-pc-linux-gnu-g++ -o XRemoteClient_standalone.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient_standalone.pp XRemoteClient.cpp
XRemoteClient.cpp
mozilla-xremote-client.cpp
x86_64-pc-linux-gnu-g++ -o XRemoteClient.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient.pp XRemoteClient.cpp
x86_64-pc-linux-gnu-g++ -o mozilla-xremote-client.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/mozilla-xremote-client.pp mozilla-xremote-client.cpp
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient_standalone.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [XRemoteClient.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make: *** [default] Error 2
emake failed
 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'

>>> Failed to emerge net-libs/xulrunner-2.0_beta8_pre-r8, Log file:

>>>  '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'

 * Messages for package net-libs/xulrunner-2.0_beta8_pre-r8:

 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Dec 22, 2010 12:23 pm    Post subject: Reply with quote

TomCat1 wrote:
Thanks for the answer. I have installed dev-libs/nss-3.12.8 and dev-libs/nspr-4.8.6-r1. Also net-libs/xulrunner-2.0_beta8_pre-r6 compiles fine. I already tried to compile with gcc version 4.1.2, 4.4.5 and 4.5.1-r1 without success. Then I did emerge -e world and found out, that I have similar problem with emerging kde-base/kdelibs-4.5.85.

FEATURES="-sandbox -usersandbox" emerge -av1 xulrunner gives this output.
Code:
/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/config/nsinstall -R -m 644 libappcomps.a  ../../../staticlib/components
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components/build'
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components'
make[3]: Entering directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
x86_64-pc-linux-gnu-g++ -o XRemoteClient_standalone.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient_standalone.pp XRemoteClient.cpp
XRemoteClient.cpp
mozilla-xremote-client.cpp
x86_64-pc-linux-gnu-g++ -o XRemoteClient.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient.pp XRemoteClient.cpp
x86_64-pc-linux-gnu-g++ -o mozilla-xremote-client.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/mozilla-xremote-client.pp mozilla-xremote-client.cpp
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient_standalone.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [XRemoteClient.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make: *** [default] Error 2
emake failed
 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'

>>> Failed to emerge net-libs/xulrunner-2.0_beta8_pre-r8, Log file:

>>>  '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'

 * Messages for package net-libs/xulrunner-2.0_beta8_pre-r8:

 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'


I just hit the same error-message with beta9_pre *ugh* :?

I'll see if I can get it to run

make sure you have the latest nspr and nss installed (they meanwhile got bumped to newer betas !)

edit:

probably coding style / programming issue:
http://gcc.gnu.org/gcc-4.4/porting_to.html

Quote:
An example.

#include <cstring>

const char* str1;
char* str2 = strchr(str1, 'a');
Gives the following compiler error:

error: invalid conversion from ‘const char*’ to ‘char*’
Fixing this is easy, as demonstrated below.

#include <cstring>

const char* str1;
const char* str2 = strchr(str1, 'a');

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
dusik
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jan 2005
Posts: 129
Location: Durham, NC, USA

PostPosted: Mon Dec 27, 2010 9:26 am    Post subject: Reply with quote

I can't compile beta9_pre-r1 on amd64 using GCC 4.5.1-r1:
Code:
In file included from AudioParent.cpp:40:0:
../../dist/include/mozilla/dom/AudioParent.h:44:27: fatal error: nsAudioStream.h: No such file or directory
compilation terminated.
make[4]: *** [AudioParent.o] Error 1
make[4]: *** Waiting for unfinished jobs....
In file included from ContentParent.cpp:71:0:
AudioParent.h:44:27: fatal error: nsAudioStream.h: No such file or directory
compilation terminated.
make[4]: *** [ContentParent.o] Error 1
ContentChild.cpp:61:27: fatal error: nsAudioStream.h: No such file or directory
compilation terminated.
make[4]: *** [ContentChild.o] Error 1
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta9_pre-r1/work/mozilla-central/dom/ipc'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta9_pre-r1/work/mozilla-central/dom'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta9_pre-r1/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta9_pre-r1/work/mozilla-central'
make: *** [default] Error 2
emake failed
 * ERROR: net-libs/xulrunner-2.0_beta9_pre-r1 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 6138:  Called _eapi2_src_compile
 *     ebuild.sh, line  657:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"

My USE flags:
Code:
[ebuild     U ] net-libs/xulrunner-2.0_beta9_pre-r1 [1.9.2.13] USE="dbus ipc libnotify -alsa -custom-optimization -debug -gnome -startup-notification -system-sqlite -webm% -wifi (-java%*)" 0 kB [0=>1]
[ebuild     U ] www-client/firefox-4.0_beta9_pre-r1 [3.6.13] USE="dbus ipc libnotify -alsa -bindist -custom-optimization -gnome -startup-notification -system-sqlite -webm% -wifi (-java%*)"

Is it the -alsa? (I've got OSS4)
Back to top
View user's profile Send private message
jbouzan
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2007
Posts: 138

PostPosted: Mon Dec 27, 2010 8:14 pm    Post subject: Reply with quote

Probably a good guess. Working here (~amd64 GCC 4.5.1-r1)
Code:
$ eix -e firefox
[I] www-client/firefox
     Available versions:  3.6.8 3.6.9 (~)3.6.9-r1 3.6.11 3.6.12 3.6.13 {M}(~)4.0_beta9_pre-r1[1] {+alsa bindist custom-optimization dbus elibc_FreeBSD gnome +ipc java libnotify linguas_af linguas_ar linguas_as linguas_be linguas_bg linguas_bn linguas_bn_BD linguas_bn_IN linguas_ca linguas_cs linguas_cy linguas_da linguas_de linguas_el linguas_en linguas_en_GB linguas_en_US linguas_eo linguas_es linguas_es_AR linguas_es_CL linguas_es_ES linguas_es_MX linguas_et linguas_eu linguas_fa linguas_fi linguas_fr linguas_fy linguas_fy_NL linguas_ga linguas_ga_IE linguas_gl linguas_gu linguas_gu_IN linguas_he linguas_hi linguas_hi_IN linguas_hr linguas_hu linguas_id linguas_is linguas_it linguas_ja linguas_ka linguas_kk linguas_kn linguas_ko linguas_ku linguas_lt linguas_lv linguas_mk linguas_ml linguas_mr linguas_nb linguas_nb_NO linguas_nl linguas_nn linguas_nn_NO linguas_oc linguas_or linguas_pa linguas_pa_IN linguas_pl linguas_pt linguas_pt_BR linguas_pt_PT linguas_rm linguas_ro linguas_ru linguas_si linguas_sk linguas_sl linguas_sq linguas_sr linguas_sv linguas_sv_SE linguas_ta linguas_ta_LK linguas_te linguas_th linguas_tr linguas_uk linguas_vi linguas_zh_CN linguas_zh_TW startup-notification system-sqlite +webm wifi}                                                       
     Installed versions:  4.0_beta9_pre-r1[1](11:31:32 12/27/10)(alsa dbus ipc libnotify startup-notification webm -bindist -custom-optimization -gnome -system-sqlite -wifi)                                                                                                                                                     
     Homepage:            http://www.mozilla.com/firefox
     Description:         Firefox Web Browser

[1] "mozilla" /var/lib/layman/mozilla

Other guess is that webm might be required now, but that seems unlikely.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jan 03, 2011 11:23 pm    Post subject: Reply with quote

TomCat1 wrote:
Thanks for the answer. I have installed dev-libs/nss-3.12.8 and dev-libs/nspr-4.8.6-r1. Also net-libs/xulrunner-2.0_beta8_pre-r6 compiles fine. I already tried to compile with gcc version 4.1.2, 4.4.5 and 4.5.1-r1 without success. Then I did emerge -e world and found out, that I have similar problem with emerging kde-base/kdelibs-4.5.85.

FEATURES="-sandbox -usersandbox" emerge -av1 xulrunner gives this output.
Code:
/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/config/nsinstall -R -m 644 libappcomps.a  ../../../staticlib/components
make[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components/build'
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/xpfe/components'
make[3]: Entering directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
x86_64-pc-linux-gnu-g++ -o XRemoteClient_standalone.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient_standalone.pp XRemoteClient.cpp
XRemoteClient.cpp
mozilla-xremote-client.cpp
x86_64-pc-linux-gnu-g++ -o XRemoteClient.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/XRemoteClient.pp XRemoteClient.cpp
x86_64-pc-linux-gnu-g++ -o mozilla-xremote-client.o -c -I../../../dist/stl_wrappers -I../../../dist/system_wrappers -include ../../../config/gcc_hidden.h -DXPCOM_GLUE -DOSTYPE=\"Linux2.6\" -DOSARCH=Linux  -I. -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/usr/include/nspr -I/usr/include/nss       -fPIC  -fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -march=amdfam10 -pipe -Wno-error -fPIC -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/mozilla-xremote-client.pp mozilla-xremote-client.cpp
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
XRemoteClient.cpp: In member function 'virtual nsresult XRemoteClient::Init()':
XRemoteClient.cpp:145:77: error: invalid conversion from 'char**' to 'const char**'
XRemoteClient.cpp:145:77: error:   initializing argument 2 of 'int XInternAtoms(Display*, const char**, int, int, Atom*)'
make[3]: *** [XRemoteClient_standalone.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [XRemoteClient.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central/widget/src/xremoteclient'
make[2]: *** [libs_tier_platform] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make[1]: *** [tier_platform] Error 2
make[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'
make: *** [default] Error 2
emake failed
 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'

>>> Failed to emerge net-libs/xulrunner-2.0_beta8_pre-r8, Log file:

>>>  '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'

 * Messages for package net-libs/xulrunner-2.0_beta8_pre-r8:

 * ERROR: net-libs/xulrunner-2.0_beta8_pre-r8 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 5925:  Called _eapi2_src_compile
 *     ebuild.sh, line  654:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =net-libs/xulrunner-2.0_beta8_pre-r8',
 * the complete build log and the output of 'emerge -pqv =net-libs/xulrunner-2.0_beta8_pre-r8'.
 * This ebuild is from an overlay named 'mozilla': '/var/lib/layman/mozilla/'
 * The complete build log is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/temp/environment'.
 * S: '/var/tmp/portage/net-libs/xulrunner-2.0_beta8_pre-r8/work/mozilla-central'


any news on this ?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jan 04, 2011 2:46 pm    Post subject: Reply with quote

the strange thing is - I'm also starting to get this error with mail-client/thunderbird

so it must be something else involved

I'm betting on nspr and its dependency nss (both beta versions and required for newest xulrunner and firefox)

edit:

Quote:
nsGTKRemoteService.cpp: In static member function ‘static void nsGTKRemoteService::EnsureAtoms()’:
nsGTKRemoteService.cpp:256:29: error: invalid conversion from ‘char**’ to ‘const char**’
nsGTKRemoteService.cpp:256:29: error: initializing argument 2 of ‘int XInternAtoms(Display*, const char**, int, int, Atom*)’
make[5]: *** [nsGTKRemoteService.o] Error 1
(this is from thunderbird)

so this made me think:

anyone having problems to emerge xulrunner, firefox and/or thunderbird

has recently upgraded to gnome 2.32 and gtk+ 2.22* ?

edit2:

argh !

still happening

edit3:

thunderbird compiled fine now - it really seems to be coding (style) problem

I'm wondering which gcc-version upstream is using gcc 4.3 ? :?

attempting to fix it now ...
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jan 04, 2011 4:45 pm    Post subject: Reply with quote

net-libs/xulrunner-2.0_beta9_pre-r2:

XRemoteClient.cpp
line 117 - 128
Quote:
// Minimize the roundtrips to the X-server
static char *XAtomNames[] = {
MOZILLA_VERSION_PROP,
MOZILLA_LOCK_PROP,
MOZILLA_COMMAND_PROP,
MOZILLA_RESPONSE_PROP,
"WM_STATE",
MOZILLA_USER_PROP,
MOZILLA_PROFILE_PROP,
MOZILLA_PROGRAM_PROP,
MOZILLA_COMMANDLINE_PROP
};


Quote:
to // Minimize the roundtrips to the X-server
static const char *XAtomNames[] = {
MOZILLA_VERSION_PROP,
MOZILLA_LOCK_PROP,
MOZILLA_COMMAND_PROP,
MOZILLA_RESPONSE_PROP,
"WM_STATE",
MOZILLA_USER_PROP,
MOZILLA_PROFILE_PROP,
MOZILLA_PROGRAM_PROP,
MOZILLA_COMMANDLINE_PROP
};


nsXRemoteService.cpp
line 92 - 102
Quote:
// Minimize the roundtrips to the X server by getting all the atoms at once
static char *XAtomNames[] = {
MOZILLA_VERSION_PROP,
MOZILLA_LOCK_PROP,
MOZILLA_COMMAND_PROP,
MOZILLA_RESPONSE_PROP,
MOZILLA_USER_PROP,
MOZILLA_PROFILE_PROP,
MOZILLA_PROGRAM_PROP,
MOZILLA_COMMANDLINE_PROP
};


Quote:
// Minimize the roundtrips to the X server by getting all the atoms at once
static const char *XAtomNames[] = {
MOZILLA_VERSION_PROP,
MOZILLA_LOCK_PROP,
MOZILLA_COMMAND_PROP,
MOZILLA_RESPONSE_PROP,
MOZILLA_USER_PROP,
MOZILLA_PROFILE_PROP,
MOZILLA_PROGRAM_PROP,
MOZILLA_COMMANDLINE_PROP
};

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue Jan 04, 2011 7:16 pm    Post subject: Reply with quote

Interestingly, I can't watch video on youtube with firefox-4.0_beta9_pre-r2, but I can watch the same video within facebook, if youtube link is shared on facebook. Any idea?
I already unmerged and re-emerged adobe-flash-10.2.161.23_pre20101117, nothing changed.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jan 04, 2011 7:26 pm    Post subject: Reply with quote

seems like the compile-error is caused by libX11 1.4.0 and already reverted by upstream - you guys should either downgrade or re-emerge if you're using a live-ebuild of libX11 :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
selberbauer
Apprentice
Apprentice


Joined: 20 Dec 2010
Posts: 276

PostPosted: Wed Jan 05, 2011 5:53 pm    Post subject: Reply with quote

i have a stupid question:
How do i emerge firefox 4.0?
I have downloaded it and i can start it with the script, but i want to have it in KDE and not just as a script to start

Cheers
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Jan 05, 2011 7:42 pm    Post subject: Reply with quote

selberbauer wrote:
i have a stupid question:
How do i emerge firefox 4.0?
I have downloaded it and i can start it with the script, but i want to have it in KDE and not just as a script to start

Cheers


add the mozilla-overlay with layman:

Gentoo Overlays: Users' Guide

then you need to unmask it

Code:
echo "=net-libs/xulrunner-2.0_beta*" >> /etc/portage/package.unmask
echo "=www-client/firefox-4.0_beta*" >> /etc/portage/package.unmask


after that

Code:
emerge firefox -pv

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
selberbauer
Apprentice
Apprentice


Joined: 20 Dec 2010
Posts: 276

PostPosted: Thu Jan 06, 2011 3:24 pm    Post subject: Reply with quote

Ok thankys :D

Is there a possibility to change the theme to transparency (KDE4) or do i have to wait until the final?

Also by Konqueror i get by pressing "ctrl" the ability to change spaces/fields with the keyboard, so i dont have to use the mice.

Cheers
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Jan 07, 2011 2:11 pm    Post subject: Reply with quote

selberbauer wrote:
Ok thankys :D

Is there a possibility to change the theme to transparency (KDE4) or do i have to wait until the final?



you probably need firefox with qt-support for that but afaik qt-support has stopped being developed so far - maybe there's a theme that does this ?

selberbauer wrote:


Also by Konqueror i get by pressing "ctrl" the ability to change spaces/fields with the keyboard, so i dont have to use the mice.

Cheers


not that I know of - there are surely some extensions/add-ons for that :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
quezak
n00b
n00b


Joined: 11 Jan 2011
Posts: 13

PostPosted: Wed Jan 19, 2011 3:35 pm    Post subject: Reply with quote

I'm trying to install the beta10 version. I installed the overlay, unmasked necessary packages, but I get the error:
Code:
qzk-lapc /var/lib/layman/mozilla # emerge -av =www-client/firefox-4.0_beta10_pre

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-libs/nss-3.12.9".
(dependency required by "www-client/firefox-4.0_beta10_pre" [ebuild])
(dependency required by "=www-client/firefox-4.0_beta10_pre" [argument])

This version of dev-libs/nss is in the overlay AND it's unmasked and installed:
Code:
*  dev-libs/nss
      Latest version available: 3.12.9_beta2
      Latest version installed: 3.12.9_beta2

so why do I still get the error about nss-3.12.9?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum