Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fehler bei "emerge wine"
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
bioscript
n00b
n00b


Joined: 08 Jul 2010
Posts: 15

PostPosted: Thu Jul 08, 2010 5:59 am    Post subject: Fehler bei "emerge wine" Reply with quote

Seit Tagen versuche ich wine-1.1.44 zu installieren, doch leider schlägt dies immer fehl.
Habe auch schon im Internet gesucht. Wurde aber nicht fündig.

Code:
>>> Emerging (1 of 1) app-emulation/wine-1.1.44
 * wine-1.1.44.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * wine_gecko-1.0.0-x86.cab RMD160 SHA1 SHA256 size ;-) ...              [ ok ]
 * winepulse-0.36.patch RMD160 SHA1 SHA256 size ;-) ...                  [ ok ]
 * winepulse-0.35-configure.ac.patch RMD160 SHA1 SHA256 size ;-) ...     [ ok ]
 * winepulse-0.36-winecfg.patch RMD160 SHA1 SHA256 size ;-) ...          [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * CPV:  app-emulation/wine-1.1.44
 * REPO: gentoo
 * USE:  X alsa amd64 cups dbus elibc_glibc gecko jpeg kernel_linux mp3 ncurses opengl oss perl png pulseaudio ssl threads truetype userland_GNU
>>> Unpacking source...
>>> Unpacking wine-1.1.44.tar.bz2 to /var/tmp/portage/app-emulation/wine-1.1.44/work
>>> Source unpacked in /var/tmp/portage/app-emulation/wine-1.1.44/work
>>> Preparing source in /var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44 ...
 * Applying winepulse-0.36.patch ...                                      [ ok ]
 * Applying winepulse-0.35-configure.ac.patch ...                         [ ok ]
 * Applying winepulse-0.36-winecfg.patch ...                              [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44' ...
 * Running autoconf ...                                                   [ ok ]
 * Running autoheader ...                                                 [ ok ]
 * Applying wine-1.1.15-winegcc.patch ...                                 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44 ...
 * econf: updating wine-1.1.44/tools/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating wine-1.1.44/tools/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib32 --sysconfdir=/etc/wine --with-alsa --without-capi --without-cms --with-cups --with-curses --without-esd --without-fontconfig --without-gnutls --without-gphoto --without-gsm --without-hal --without-jack --with-jpeg --without-ldap --with-mpg123 --without-nas --without-openal --with-opengl --with-openssl --with-oss --with-png --with-pthread --with-pulse --without-sane --disable-tests --with-freetype --disable-win64 --with-x --without-xcomposite --without-xinerama --without-xml --without-xslt
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc -m32
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44/config.log
 * ERROR: app-emulation/wine-1.1.44 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 3323:  Called econf '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--without-cms' '--with-cups' '--with-curses' '--without-esd' '--without-fontconfig' '--without-gnutls' '--without-gphoto' '--without-gsm' '--without-hal' '--without-jack' '--with-jpeg' '--without-ldap' '--with-mpg123' '--without-nas' '--without-openal' '--with-opengl' '--with-openssl' '--with-oss' '--with-png' '--with-pthread' '--with-pulse' '--without-sane' '--disable-tests' '--with-freetype' '--disable-win64' '--with-x' '--without-xcomposite' '--without-xinerama' '--without-xml' '--without-xslt'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =app-emulation/wine-1.1.44',
 * the complete build log and the output of 'emerge -pqv =app-emulation/wine-1.1.44'.
 * The complete build log is located at '/var/tmp/portage/app-emulation/wine-1.1.44/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/wine-1.1.44/temp/environment'.
 * S: '/var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44'

>>> Failed to emerge app-emulation/wine-1.1.44, Log file:

>>>  '/var/tmp/portage/app-emulation/wine-1.1.44/temp/build.log'

 * Messages for package app-emulation/wine-1.1.44:

 * ERROR: app-emulation/wine-1.1.44 failed:
 *   econf failed
 *
 * Call stack:
 *     ebuild.sh, line   54:  Called src_configure
 *   environment, line 3323:  Called econf '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--without-cms' '--with-cups' '--with-curses' '--without-esd' '--without-fontconfig' '--without-gnutls' '--without-gphoto' '--without-gsm' '--without-hal' '--without-jack' '--with-jpeg' '--without-ldap' '--with-mpg123' '--without-nas' '--without-openal' '--with-opengl' '--with-openssl' '--with-oss' '--with-png' '--with-pthread' '--with-pulse' '--without-sane' '--disable-tests' '--with-freetype' '--disable-win64' '--with-x' '--without-xcomposite' '--without-xinerama' '--without-xml' '--without-xslt'
 *     ebuild.sh, line  544:  Called die
 * The specific snippet of code:
 *            die "econf failed"
 *



emerge --info =app-emulation/wine-1.1.44:

Code:
Portage 2.1.8.3 (default/linux/amd64/10.0/no-multilib, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.33-gentoo-r2-x86_64-AMD_Athlon-tm-_II_X4_620_Processor-with-gentoo-1.12.13
Timestamp of tree: Wed, 07 Jul 2010 05:15:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -msse -msse2 -msse3 -m3dnow"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -msse -msse2 -msse3 -m3dnow"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="rsync://de-mirror.org/gentoo/ rsync://mirror.netcologne.de/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 berkdb bzip2 cli cracklib crypt cups cxx dbus dri exif flac fortran gdbm gpm hal iconv ipv6 jpeg jpeg2k mmx modules mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg openmp pam pcre perl png pppd pulseaudio python raw readline reflection session spl sse sse2 ssl svg sysfs tcpd tiff truetype unicode wma-fixed wmf xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Hat jemand eine Idee wo der Fehler liegen könnte?
Auch die Installation einer früheren Version ist nicht möglich.
Back to top
View user's profile Send private message
bioscript
n00b
n00b


Joined: 08 Jul 2010
Posts: 15

PostPosted: Thu Jul 08, 2010 6:32 am    Post subject: Reply with quote

Und hier noch ein Auszug aus der config.log:

Code:
Configured with: /var/tmp/portage/sys-devel/gcc-4.4.3-r2/work/gcc-4.4.3/configure --prefix=/usr --bindir=/usr/x86_64-pc-linux-gnu/gcc-bin/4$
Thread model: posix
gcc version 4.4.3 (Gentoo 4.4.3-r2 p1.2)
configure:3199: $? = 0
configure:3188: x86_64-pc-linux-gnu-gcc -m32 -V >&5
x86_64-pc-linux-gnu-gcc: '-V' must come at the start of the command line
configure:3199: $? = 1
configure:3188: x86_64-pc-linux-gnu-gcc -m32 -qversion >&5
x86_64-pc-linux-gnu-gcc: unrecognized option '-qversion'
x86_64-pc-linux-gnu-gcc: no input files
configure:3199: $? = 1
configure:3219: checking whether the C compiler works
configure:3241: x86_64-pc-linux-gnu-gcc -m32  -O2 -pipe -march=native  -Wl,-O1 conftest.c  >&5
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3$
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3$
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lgcc
collect2: ld returned 1 exit status
configure:3245: $? = 1
configure:3283: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "Wine"
| #define PACKAGE_TARNAME "wine"
| #define PACKAGE_VERSION "1.1.44"
| #define PACKAGE_STRING "Wine 1.1.44"
| #define PACKAGE_BUGREPORT "wine-devel@winehq.org"
| #define PACKAGE_URL "http://www.winehq.org"
| /* end confdefs.h.  */
|
| int
| main ()
| {
|
|   ;
|   return 0;
| }
configure:3288: error: in `/var/tmp/portage/app-emulation/wine-1.1.44/work/wine-1.1.44':
configure:3292: error: C compiler cannot create executables
See `config.log' for more details.
Back to top
View user's profile Send private message
Necoro
Veteran
Veteran


Joined: 18 Dec 2005
Posts: 1912
Location: München (Germany)

PostPosted: Thu Jul 08, 2010 7:49 am    Post subject: Reply with quote

Ich glaube dir nicht, dass du gegooglet hast ... Hier sind so häufig Threads wegen dem 'C compiler cannot create executables'-Fehler. Und Google fördert denn auch u.a. das hier zu Tage: http://wolf-u.li/3170/fehler-unter-gentoo-configure-error-c-compiler-cannot-create-executables/
_________________
Inter Deum Et Diabolum Semper Musica Est.
Back to top
View user's profile Send private message
bioscript
n00b
n00b


Joined: 08 Jul 2010
Posts: 15

PostPosted: Thu Jul 08, 2010 9:36 am    Post subject: Reply with quote

Danke für die Antwort, aber darauf bin ich auch bereits gekommen.
Ich habe mir sogar, wie dazu in einem anderen (im übrigen über Yahoo gefundenen) Forum empfohlen, ein kleines "Hallo Welt"-Programm geschrieben und mit gcc kompiliert. Das, sowie das emergen anderer Programme funktioniert perfekt. Nur bei WINE klappt es nicht.

Code:
gcc-config -c
ergibt: x86_64-pc-linux-gnu-4.4.3


@Necoro: Du kannst gerne glauben was Du willst. Es heisst noch lange nicht, das die gefundenen Lösungsvorschläge zum Erfolg führen. Und genau das habe ich gemeint. Ok. Das "wurde nicht fündig" kann durchaus verschieden verstanden werden. Da habe ich mich wohl einfach zu ungenau ausgedrückt.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Thu Jul 08, 2010 10:09 am    Post subject: Reply with quote

ich weiß zwar jetzt nicht direkt weiter, aber ich glaube ich hatte das "c compiler cannot create executables" auch mal wegen eines (schreib)fehlers in den CFLAGS. Wieso das aber jetzt nur bei wine auftritt, weiß ich nicht. eventuell verändert der die CFLAGS und es geht irgendwas schief.

probier doch mal "-msse -msse2 -msse3 -m3dnow" raus zu nehmen. wenn ich das alles richtig verstanden habe müsste das durch "-march=native" sowieso aktiviert werden.
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2044
Location: My own world! I and Gentoo!

PostPosted: Thu Jul 08, 2010 10:34 am    Post subject: Reply with quote

Hast du für wine evtl extra CFLAGS definiert, und dich da verschrieben/falsche Flags definiert.
Schau dazu mal unter /etc/portage/env/<cat>/<paket>
_________________
mfg
Steel
___________________
Sorry for my bad English.

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Jul 08, 2010 10:46 am    Post subject: Reply with quote

Wurde beim letzten gcc Update eventuell die postinstall Message
Quote:
If you have issues with packages unable to locate libstdc++.la, │
then try running 'fix_libtool_files.sh' on the old gcc versions.
übersehen und nicht ausgeführt?
Back to top
View user's profile Send private message
AmonAmarth
l33t
l33t


Joined: 03 Mar 2005
Posts: 727

PostPosted: Thu Jul 08, 2010 11:14 am    Post subject: Reply with quote

in deinem emerge --info output steht:

Portage 2.1.8.3 (default/linux/amd64/10.0/no-multilib, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)

hat das seine richtigkeit? es scheint mir doch so als das du ein desktop system aufziehen willst, da wirste früher oder später ohne multilib "spaß" bekommen.
Back to top
View user's profile Send private message
bioscript
n00b
n00b


Joined: 08 Jul 2010
Posts: 15

PostPosted: Thu Jul 08, 2010 11:19 am    Post subject: Reply with quote

@Josef.95:
Es wurde bisher kein Update durchgeführt.

@ Max Steel:
Verzeichnis /etc/portage/env ist nicht vorhanden. Ist mir aber auch nicht bewußt, dass spezielle CFLAGS definiert sind.

@Christian99:
Quote:
probier doch mal "-msse -msse2 -msse3 -m3dnow" raus zu nehmen

Habe ich gemacht. Das bringt leider auch keinen Erfolg.

@alle:
Hat denn jemand zufällig wine mit einem no-multilib-Profil laufen?
Back to top
View user's profile Send private message
69719
l33t
l33t


Joined: 20 Sep 2004
Posts: 865

PostPosted: Thu Jul 08, 2010 11:45 am    Post subject: Reply with quote

Ich tippe auf CONFIG_IA32_EMULATION, aktivier dies im Kernel und es sollte funktionieren.
Mit dem -m32 parameter erstellt er ein 32 bit binary, daher wird es wohl deswegen fehlschlagen.
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Thu Jul 08, 2010 11:52 am    Post subject: Reply with quote

Quote:
configure:3241: x86_64-pc-linux-gnu-gcc -m32 -O2 -pipe -march=native -Wl,-O1 conftest.c >&5


beachte das -m32: das heißt, dass 32-bit code erzeugt wird, wofür normalerweise 32-bit libs gebraucht werden. wenn du nomultilib profil hast, hast du vermutlich diese libs nicht. mach mal "locate libgcc.". da sollte sowas wie
Code:
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.3/32/libgcc.a
/usr/lib64/gcc/x86_64-pc-linux-gnu/4.4.3/libgcc.a

kommen. wenn eine zeile (die mit /32/) fehlt, würde es erklären, wieso dann "cannot find -lgcc" kommt.
entweder stellst du dann auf ein multilib profil um, oder es gibt für wine ein "win64" useflag. eventuell geht es dann damit, aber
Code:
local use flags (searching: win64)
************************************************************
!!! "--ask" should only be used in a terminal. Exiting.
[-    ] win64 (app-emulation/wine):
Build a 64bit version of Wine (won't run Win32 binaries)


das ist normalerweise auch nicht, was du willst.
am einfachsten wäre wirklich "multilib" zu verwenden.

Mal generell: sollte so was nicht vom ebuild überprüft werden?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Jul 08, 2010 11:59 am    Post subject: Reply with quote

Quote:
Mal generell: sollte so was nicht vom ebuild überprüft werden?
Das tut es normal auch!
Code:
$ emerge -pv wine

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-emulation/wine" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-emulation/wine-9999 (masked by: package.mask, missing keyword)
/usr/portage/profiles/features/64bit-native/package.mask:
# AMD64 Team <amd64@gentoo.org>
# Mask packages that rely on amd64 multilib
........
.......
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Thu Jul 08, 2010 12:10 pm    Post subject: Reply with quote

das kann man aber wieder unmasken. würde nicht sowas wie
Code:
!win64? ( sys-apps/gcc[multilib] )

bei den DEPENDs von wine zuverlässiger funktionieren?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3649
Location: Germany

PostPosted: Thu Jul 08, 2010 12:19 pm    Post subject: Reply with quote

Christian99 wrote:
das kann man aber wieder unmasken. würde nicht sowas wie
Code:
!win64? ( sys-apps/gcc[multilib] )

bei den DEPENDs von wine zuverlässiger funktionieren?
Nein, ich denke nicht das es geht, da müsste man wohl die gesamte toolchain neu auf multilib umstellen.

Ich hab nie probiert wine auf einen no-multilib System zu installieren (geht wohl normal auch nicht)
Ich würde meinen das kann man vergessen. Und ein einfaches nachträgliches umstellen auf ein multilib Profil ist afaik nicht (so ohne weiteres) möglich, in der Gentoo FAQ wird zu einer kompletten neu-Installation geraten.

/edit:
Quote:
Warnung
Momentan können Sie nicht von einem no-multilib zu einem Profil mit aktiviertem Multilib wechseln. Überdenken Sie Ihre Entscheidung also zweimal bevor Sie das no-multilib Profil benutzen.
http://www.gentoo.de/doc/de/gentoo-amd64-faq.xml#multilib
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum